Bug 586770

Summary: [abrt] crash in hamster-applet- db.py:307:__get_fact:IndexError: list index out of range
Product: [Fedora] Fedora Reporter: Martin Ebourne <fedora>
Component: hamster-appletAssignee: Mads Villadsen <maxx>
Status: CLOSED WONTFIX QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 13CC: cristian.ciupitu, maxx
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard: abrt_hash:47117895
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-06-27 15:55:56 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Description Flags
File: backtrace none

Description Martin Ebourne 2010-04-28 10:49:46 UTC
abrt 1.0.9 detected a crash.

architecture: x86_64
cmdline: python /usr/lib64/hamster-applet/hamster-applet --oaf-activate-iid=OAFIID:Hamster_Applet_Factory --oaf-ior-fd=21
component: hamster-applet
executable: /usr/lib64/hamster-applet/hamster-applet
package: hamster-applet-
reason: db.py:307:__get_fact:IndexError: list index out of range
release: Fedora release 13 (Goddard)

db.py:307:__get_fact:IndexError: list index out of range

Traceback (most recent call last):
  File "/usr/lib64/python2.6/site-packages/hamster/applet.py", line 536, in _open_edit_activity
    dialogs.edit.show(self.applet, fact_id = fact["id"])
  File "/usr/lib64/python2.6/site-packages/hamster/configuration.py", line 138, in show
    dialog = self.get_dialog_class()(parent, **kwargs)
  File "/usr/lib64/python2.6/site-packages/hamster/edit_activity.py", line 48, in __init__
    fact = runtime.storage.get_fact(fact_id)
  File "/usr/lib64/python2.6/site-packages/hamster/storage.py", line 54, in get_fact
    return self.__get_fact(id)
  File "/usr/lib64/python2.6/site-packages/hamster/db.py", line 307, in __get_fact
    return self.__group_tags(self.fetchall(query, (_("Unsorted"), id)))[0]
IndexError: list index out of range

Local variables in innermost frame:
query: '\n                   SELECT a.id AS id,\n                          a.start_time AS start_time,\n                          a.end_time AS end_time,\n                          a.description as description,\n                          b.name AS name, b.id as activity_id,\n                          coalesce(c.name, ?) as category, coalesce(c.id, -1) as category_id,\n                          e.name as tag\n                     FROM facts a\n                LEFT JOIN activities b ON a.activity_id = b.id\n                LEFT JOIN categories c ON b.category_id = c.id\n                LEFT JOIN fact_tags d ON d.fact_id = a.id\n                LEFT JOIN tags e ON e.id = d.tag_id\n                    WHERE a.id = ?\n                 ORDER BY e.name\n        '
self: <hamster.db.Storage object at 0x28d4c50>
id: 749

Comment 1 Martin Ebourne 2010-04-28 10:49:49 UTC
Created attachment 409763 [details]
File: backtrace

Comment 2 Cristian Ciupitu 2010-07-21 21:21:32 UTC
Package: hamster-applet-2.30.1-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)

I tried to set the start time of an in progress task, into the future. The task started at 12:18, it was 12:19 and I tried to set it to 12:20.

Comment 3 Mads Villadsen 2010-08-11 18:59:11 UTC
Reported upstream here: https://bugzilla.gnome.org/show_bug.cgi?id=626661

Comment 4 Bug Zapper 2011-06-02 14:46:10 UTC
This message is a reminder that Fedora 13 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 13.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '13'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 13's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 13 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 

Comment 5 Bug Zapper 2011-06-27 15:55:56 UTC
Fedora 13 changed to end-of-life (EOL) status on 2011-06-25. Fedora 13 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.