Bug 587185

Summary: Installation failed in kickstart after preupgrade
Product: [Fedora] Fedora Reporter: He Rui <rhe>
Component: preupgradeAssignee: Richard Hughes <richard>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 12CC: anaconda-maint-list, icj, jlaska, jonathan, nushio, richard, vanmeeuwen+fedora
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-05-25 03:32:39 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
kickstart install error
none
anaconda log from ivan
none
My ks.cfg
none
Anaconda log from Nushio none

Description He Rui 2010-04-29 05:45:28 EDT
Created attachment 410051 [details]
kickstart install error

Description of problem:
Install f12 x86_64 with 500M /boot, then preupgrade. After it finished and reboot, kickstart install failed with the error screen saying: The root for the previous installed system were not found. 
 
Version-Release number of selected component (if applicable):
preupgrade-1.1.4-1.fc12.noarch
anaconda 13.38

How reproducible:
100%

Steps to Reproduce:
1. Install f12 x86_64 with 500M /boot
2. On the installed system, preupgrade to 13.
3. Click reboot after finishing.
4. Kickstart install failed with error screen(attached.)
Comment 1 James Laska 2010-04-29 10:34:58 EDT
Thanks for the bug report Hurry.  Do you have this system around still?  Are you able to attach the grub.conf prior to rebooting into upgrade.  Can you also change to tty2 and attach /tmp/anaconda.log when you see the error shown in the attached screenshot?

Thanks!
Comment 2 Iván Jiménez 2010-04-29 19:03:31 EDT
Created attachment 410258 [details]
anaconda log from ivan
Comment 3 Iván Jiménez 2010-04-29 19:06:56 EDT
Ups, bugzilla ate my comment, here it's again:

I can reproduce this on f12 x86_64 bare metal. I attached anaconda.log; partition layout is:

/dev/sda1               1           7       56196    6  FAT16
/dev/sda2               8         399     3148740    c  W95 FAT32 (LBA)
/dev/sda4             426       19452   152834377+   5  Extendida
/dev/sda5             426       16361   128000000   83  Linux
/dev/sda6   *       16361       17891    12287999+  83  Linux
/dev/sda7           17891       18400     4095999+  83  Linux

root fs is on sda6

preupgrade-1.1.5-1.fc12.noarch
anaconda 13.38 (with 290420010 install.img)
Comment 4 Juan Manuel Rodriguez 2010-04-29 19:43:45 EDT
I got hit with this bug too. 

I'll try to detail as much as I can on what I did. 

I put a Fresh Copy of Fedora 12 i686 LiveCD and installed it on a completely wiped Hard drive with only one gigantic / partition, and one 1024mb swap partition. 

I proceeded to update Fedora 12. Installed OpenOffice, emesene, messed with Gnome's config a bit, then rebooted and ran Preupgrade (Graphical one), and selected Fedora 13 (Branch). 

After all was done downloading, it boot into the pretty anaconda. After 5-6 mins in, the screen went blank. I thought it kicked in the screensaver, but moving the mouse wouldn't do anything. Hitting the Caps lock didn't light any keyboard lights, and ctrl-alt-f1/f2/f7 didn't bring any text input. (Side note: Function-Wireless did toggle bluetooth/wifi)

I ended up shutting off the computer entirely after 30 or 40 mins of staring onto the blank screen. Tried to run the Upgrade Process again, and no luck. Said no "install.img" was found. 

Ended up back on Fedora 12, but Gnome had no panels, and alt-f2 didn't pop up anything. I ended up running preupgrade-cli from terminal. It downloaded some packages. Reboot into Anaconda, and the cute "The root for the previous installed system were not found. " popped up. 

I'll attach logs when I get them.
Comment 5 Juan Manuel Rodriguez 2010-04-29 20:00:11 EDT
Created attachment 410274 [details]
My ks.cfg

After running preupgrade-cli, this is the ks.cfg I have.
Comment 6 Juan Manuel Rodriguez 2010-04-29 20:21:36 EDT
Created attachment 410278 [details]
Anaconda log from Nushio
Comment 7 Iván Jiménez 2010-04-30 17:23:13 EDT
I think this should be reassigned to anaconda, because I can reproduce it without preupgrade; just putting vmlinuz, initrd.img and install.img in /boot and booting from that I never get an option to upgrade, so anaconda never finds f12's root.

Also, problem here is that it mounts sda5 (DEBUG anaconda: isys.py:mount()- going to mount /dev/sda5 on /mnt/sysimage as ext4 with options ro) which is /home and then fails (DEBUG anaconda: No upgrade root was found). Even if I explicitly use upgrade with --root-device=sda6 in ks, it still mounts sda5.
Comment 8 He Rui 2010-05-25 03:32:39 EDT
It was the bug of anaconda 13.38, and verified it fixes in anaconda 13.42 after preupgrading.