Bug 587962

Summary: [abrt] crash in firefox-3.5.9-2.fc12: Process /usr/lib/firefox-3.5/firefox was killed by signal 11 (SIGSEGV)
Product: [Fedora] Fedora Reporter: Daniel Vilha <danielvilha>
Component: firefoxAssignee: Gecko Maintainer <gecko-bugs-nobody>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 12CC: campbecg, gecko-bugs-nobody
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard: abrt_hash:f66df5dddd64118304afbd77a55e9422024e1a98
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-05-01 20:44:15 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
File: backtrace none

Description Daniel Vilha 2010-05-01 15:24:29 EDT
abrt 1.0.9 detected a crash.

architecture: i686
Attached file: backtrace
cmdline: /usr/lib/firefox-3.5/firefox
component: firefox
executable: /usr/lib/firefox-3.5/firefox
global_uuid: f66df5dddd64118304afbd77a55e9422024e1a98
kernel: 2.6.32.11-99.fc12.i686
package: firefox-3.5.9-2.fc12
rating: 4
reason: Process /usr/lib/firefox-3.5/firefox was killed by signal 11 (SIGSEGV)
release: Fedora release 12 (Constantine)
Comment 1 Daniel Vilha 2010-05-01 15:24:32 EDT
Created attachment 410727 [details]
File: backtrace
Comment 2 Chris Campbell 2010-05-01 20:41:26 EDT
#3  <signal handler called>
No symbol table info available.
#4  0x02b8d7cd in add_java_method_to_class_descriptor (cx=0xb34e2000, jEnv=
    0x9bd37940, class_descriptor=0x9cc018c0, method_name_jstr=0x0, 
    java_method=0x9ccc4610, is_static_method=0, is_constructor=0)
    at jsj_method.c:453
        methodID = <value optimized out>
        fun = <value optimized out>
        java_class = 0x9bc3aaa8
        member_descriptor = 0x0
        sig_cstr = 0x0
        method_name = 0x0
        signature = 0x0
        specp = <value optimized out>
        method_spec = 0x0
#5  0x02b8da51 in jsj_ReflectJavaMethods (cx=0xb34e2000, jEnv=0x9bd37940, 
    class_descriptor=0x9cc018c0, reflect_only_static_methods=0)
    at jsj_method.c:563
        method_name_jstr = <value optimized out>
        java_method = 0x9ccc4610
        modifiers = <value optimized out>
        joMethodArray = 0x9bc3aab8
        joConstructorArray = <value optimized out>
        num_methods = 285
        num_constructors = <value optimized out>
        i = 39
        java_class = 0x9bc3aaa8
        ok = <value optimized out>
#6  0x02b89374 in reflect_java_methods_and_fields (cx=<value optimized out>, 
    jEnv=<value optimized out>, class_descriptor=0x9cc018c0, 
    reflect_statics_only=0) at jsj_class.c:558
        member_descriptor = <value optimized out>
        success = 1
#7  0x02b89428 in jsj_GetClassInstanceMembers (cx=0xb34e2000, jEnv=
    0x9bd37940, class_descriptor=0x9cc018c0) at jsj_class.c:606
No locals.
#8  0x02b8944c in jsj_LookupJavaMemberDescriptorById (cx=0xb34e2000, jEnv=
    0x9bd37940, class_descriptor=0x9cc018c0, id=-1681175452)
    at jsj_class.c:702
        member_descriptor = <value optimized out>
#9  0x02b87c39 in lookup_member_by_id (cx=0xb34e2000, jEnv=0x9bd37940, obj=
    0x9cc02380, java_wrapperp=0x0, id=-1681175452, member_descriptorp=0x0, vp=
    0xbf9b43f8, proto_chainp=0xbf9b43f4, prop_infop=0xbf9b43e4)
    at jsj_JavaObject.c:528
        idval = <value optimized out>
        java_wrapper = 0x9d802650
        member_descriptor = 0x0
        member_name = <value optimized out>
        class_descriptor = 0x9cc018c0
        proto_chain = <value optimized out>
        found_in_proto = 0
#10 0x02b8811b in JavaObject_lookupProperty (cx=0xb34e2000, obj=0x9cc02380, 
    id=-1681175452, objp=0xbf9b44cc, propp=0xbf9b44c8) at jsj_JavaObject.c:840
        jEnv = 0x9bd37940
        old_reporter = 0
        dummy_val = -1080343456
        proto_chain = <value optimized out>
        prop_info = {wantProp = 1, name = 
    0xbf9b4418 "\210D\233\277)\r\177\005", attributes = 91992191, prop = 
    0xb3387d00}
        jsj_env = 0x9c0c7b40



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 3 Chris Campbell 2010-05-01 20:44:15 EDT
Thank you for taking the time to submit this bug report.

This particular bug has already been reported into our bug tracking system, but please feel free to report any further bugs you find.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

*** This bug has been marked as a duplicate of bug 561079 ***