Bug 589250

Summary: iSCSI root install+boot fails in Fedora 13. Latest iscsi-initiator-utils required
Product: [Fedora] Fedora Reporter: James Laska <jlaska>
Component: iscsi-initiator-utilsAssignee: Mike Christie <mchristi>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 13CC: agrover, harald, hdegoede, jcasale, jturner, mchristi, mh-fedora, peter, prashant.wakchaure, thatch45
Target Milestone: ---Keywords: CommonBugs
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard: https://fedoraproject.org/wiki/Common_F13_bugs#iscsi-install
Fixed In Version: iscsi-initiator-utils-6.2.0.872-4.fc13 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-05-26 17:39:10 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 507684    

Description James Laska 2010-05-05 12:25:13 EDT
Description of problem:

The iscsi-initiator-utils-6.2.0.870-13.fc13 package included in Fedora 13 does not work for iSCSI root installs.  It fails to boot post-install, and it was determined that the iscsistart command was failing.

Repeating the test, using a scratch build [1] works fine.  Can iscsi-initiator-utils-6.2.0.872-3 be built for Fedora 13 please?

[1] http://koji.fedoraproject.org/koji/taskinfo?taskID=2165057
Comment 1 Mike Christie 2010-05-05 12:50:59 EDT
Hans, I got this one.

The iscsi scripts in F13 are newer than RHEL 6 right?
Comment 2 Hans de Goede 2010-05-05 13:46:10 EDT
(In reply to comment #1)
> Hans, I got this one.
> 

Ok.

> The iscsi scripts in F13 are newer than RHEL 6 right?    

Not entirely, they are identical except that the RHEL-6 iscsid.init script has some stuff related to the partial offload cards (some modprobes and rmmods), and
seems to not kill iscsid ?
Comment 3 Harald Hoyer 2010-05-05 14:06:14 EDT
it's iscsistart in dracut, what is failing
Comment 4 Mike Christie 2010-05-06 16:02:38 EDT
I think I can replicate this here. I get a:


iscsistart: Logging into iqn.2008-09.com.max:tgtd 20.15.0.7:3260,1
iscsistart: can not connect to iSCSI daemon (111)!
iscsistart: initiator reported error (18 - could not communicate to iscsid)
iscsistart: can not connect to iSCSI daemon (111)!
iscsistart: initiator reported error (18 - could not communicate to iscsid)
iscsistart: Could not stop event_loop

This is fixed in iscsi-initiator-utils-6.2.0.872-3.fc13.
Comment 5 Fedora Update System 2010-05-06 17:27:54 EDT
iscsi-initiator-utils-6.2.0.872-4.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/iscsi-initiator-utils-6.2.0.872-4.fc13
Comment 6 Fedora Update System 2010-05-07 01:47:30 EDT
iscsi-initiator-utils-6.2.0.872-4.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update iscsi-initiator-utils'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/iscsi-initiator-utils-6.2.0.872-4.fc13
Comment 7 James Laska 2010-05-07 08:50:45 EDT
Confirmed fix using iscsi-initiator-utils-6.2.0.872-4.fc13
Comment 8 Fedora Update System 2010-05-26 17:39:06 EDT
iscsi-initiator-utils-6.2.0.872-4.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Hans de Goede 2010-06-07 05:59:30 EDT
*** Bug 600481 has been marked as a duplicate of this bug. ***
Comment 10 prashantwakchaure 2010-07-26 05:05:51 EDT
Hi,

1. I tried to install fedora 13 (32bits) on iscsi target and it get successfully  installed. But when I tried to boot it, it gives me error "no root devices found"

2. After lots of search I found Bugzilla issue same as above. And they advised to enable the Fedora 13 Updates while installing Fedora 13, but it gives error as following:
"Error: Cannot retrieve repository metadata (repomd.xml) for repository: fedora Updates"

3. To resolve this problem I installed the "rpmfusion" repository while installing Fedora 13. And then updated all package lists and installed all packages related to "iscsi" and pkg version is "iscsi-initiator-utils-6.2.0.872-4.fc13". Everything was well. But When I tried to boot the same it gives me same error i.e. "no root device found" 


Anybody help me out what went wrong???