Bug 589312

Summary: After running updates on base image, Attach-device fails and seg faults guests.
Product: [Fedora] Fedora Reporter: steve <steven765>
Component: qemuAssignee: Justin M. Forbes <jforbes>
Status: CLOSED WONTFIX QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: low    
Version: 12CC: amit.shah, berrange, dwmw2, ehabkost, gcosta, itamar, jaswinder, jforbes, knoel, markmc, scottt.tw, virt-maint
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-12-03 10:02:39 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
qemu log output none

Description steve 2010-05-05 15:54:32 EDT
Created attachment 411721 [details]
qemu log output

Description of problem:  After installing updates on FC12 I tried to re-run my script to attach network interfaces to live guests on KVM.  Attch-device now seg faults guest.  Tired on multiple guests with the same results. Both guests were FC 12.  It worked previously on my other FC12 install.

Interface is defined as:
<interface type="network">
      <mac address="52:54:00:5c:fe:a8"/>
      <source network="fedora"/>
</interface>

 
Version-Release number of selected component (if applicable):
python-virtinst-0.500.1-2.fc12.noarch
libvirt-python-0.7.1-15.fc12.x86_64
virt-viewer-0.2.0-1.fc12.x86_64
libvirt-client-0.7.1-15.fc12.x86_64
libvirt-0.7.1-15.fc12.x86_64
virt-manager-0.8.2-3.fc12.noarch

qemu 0.12.3-4.fc12.x86_64
KVM 0.12.3-4.fc12.x86_64


How reproducible:


Steps to Reproduce:
1. Create guest and definition for interface xml, as well as network defined and running
2. attempt to use attach-device on the inteface definiton. 
3.
  
Actual results:
virsh # attach-device fed_base fed_net.xml
error: Failed to attach device from fed_net.xml
error: operation failed: failed to add NIC with 'pci_add pci_addr=auto nic macaddr=52:54:00:5c:fe:a8,vlan=0,name=nic.0'



Expected results:  Device should attach and work happily. 


Additional info:
Comment 1 Bug Zapper 2010-11-03 11:33:25 EDT
This message is a reminder that Fedora 12 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 12.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '12'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 12's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 12 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Bug Zapper 2010-12-03 10:02:39 EST
Fedora 12 changed to end-of-life (EOL) status on 2010-12-02. Fedora 12 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.