Bug 589761

Summary: regression: iscsi script does not start and stop correctly
Product: Red Hat Enterprise Linux 6 Reporter: Mike Christie <mchristi>
Component: iscsi-initiator-utilsAssignee: Andy Grover <agrover>
Status: CLOSED CURRENTRELEASE QA Contact: Storage QE <storage-qe>
Severity: medium Docs Contact:
Priority: low    
Version: 6.0CC: bdonahue, borgan, coughlan, danken, mchristi, syeghiay
Target Milestone: rc   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: iscsi-initiator-utils-6.2.0.872-4.el6 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-11-10 20:42:03 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Mike Christie 2010-05-06 20:19:04 UTC
Description of problem:

There are two bugs:

1. rh_status does not detect offload drivers like be2iscsi, cxgb3i and bnx2i

2. the iscsi script does not start/stop due to output being sent to stderr
and the script detecting this as an indication of failure.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Dan Kenigsberg 2010-05-14 08:44:07 UTC
3. If iscsid was force-started and then restart'ed, it ends up stopped. "restart" should use force-start if the service was running when "restart" was issued.

Comment 2 Mike Christie 2010-05-19 11:54:38 UTC
Fixed in iscsi-initiator-utils-6.2.0.872-4.

Comment 4 Barry Donahue 2010-08-17 15:12:13 UTC
verified in RHEL6.0-20100811.2

Comment 5 releng-rhel@redhat.com 2010-11-10 20:42:03 UTC
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.