Bug 589839

Summary: After installing from the F13 alpha livecd, there is a lot of garbage in /srv/pungi
Product: [Fedora] Fedora Reporter: Joachim Backes <joachim.backes>
Component: livecd-toolsAssignee: David Huff <dhuff>
Status: CLOSED WORKSFORME QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 13CC: dcantrell, dex.mbox, dhuff, Jasper.Hartline, katzj, notting, wtogami
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-05-07 21:01:07 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 507684    
Attachments:
Description Flags
contents of "ls -laR /srv/pungi" none

Description Joachim Backes 2010-05-07 04:32:00 UTC
Created attachment 412221 [details]
contents of "ls -laR /srv/pungi"

Description of problem:
I installed my first F13 version from the R14 alpha live DVD (on february 26).
Now I found that in the directory /srv/pungi there is a lot of garbage (i think, unused and unneeded). It seems that the installator forgot to cleanup this directory.

Version-Release number of selected component (if applicable):
F13 alpha

How reproducible:
I did not try

Steps to Reproduce:
1.Start the box from the F13 alpha dvd (x86)
2.Install from Live media to HD
3.
  
Actual results:
See description

Expected results:
No garbage

Additional info:

Comment 1 Jesse Keating 2010-05-07 04:35:39 UTC
Hrm, putting this on the livecd-tools, but I need to look into it.  Could be a blocker, will check.

Comment 2 dex 2010-05-07 13:19:04 UTC
some data,
Yeah I'm seeing something I think related to this on the livecd's I've been spinning lately, and completely forgot about it :-( till reading the lists.
Investigating...

Comment 3 Joachim Backes 2010-05-07 14:50:09 UTC
(In reply to comment #0)
> Created an attachment (id=412221) [details]
> contents of "ls -laR /srv/pungi"
> 
> Description of problem:
> I installed my first F13 version from the R14 alpha live DVD (on february 26).
> Now I found that in the directory /srv/pungi there is a lot of garbage (i
> think, unused and unneeded). It seems that the installator forgot to cleanup
> this directory.
> 
> Version-Release number of selected component (if applicable):
> F13 alpha
> 
> How reproducible:
> I did not try
> 
> Steps to Reproduce:
> 1.Start the box from the F13 alpha dvd (x86)
> 2.Install from Live media to HD
> 3.
> Actual results:
> See description
> 
> Expected results:
> No garbage
> 
> Additional info:    
Sorry: I meant F13 alpha live DVD [and not  R14 alpha live DVD :-) ]

Comment 4 Fedora Admin XMLRPC Client 2010-05-07 15:41:21 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 5 Jesse Keating 2010-05-07 21:01:07 UTC
I'm not able to reproduce here, I've just done a livecd compose and there wasn't anything in /srv/ once the image was created.

Comment 6 Joachim Backes 2010-05-08 05:59:51 UTC
(In reply to comment #5)
> I'm not able to reproduce here, I've just done a livecd compose and there
> wasn't anything in /srv/ once the image was created.    

For testing puposes I installed again F13 alpha from the F13 alpha live DVD,
and I checked the behaviour again: If I'm prompted to reboot after having installed the OS to some HD partition, I mounted that partition, and I found again  that srv/pungi had *not* been cleaned up.

Then I booted to my running Fedora, mounted that partition, and I found again  that srv/pungi had *not* been cleaned up.

That's my experience!

Comment 7 Jesse Keating 2010-05-08 06:14:53 UTC
It's possible that there was a bug at Alpha time, however there isn't currently a bug in the images being produced for F13 release candidate.