Bug 590265

Summary: intel arrandale graphics (T410s) hangs with desktop-effects
Product: [Fedora] Fedora Reporter: Volker Braun <vbraun.name>
Component: xorg-x11-drv-intelAssignee: Adam Jackson <ajax>
Status: CLOSED NEXTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 13CC: ajax, ggear, mcepl, xgl-maint
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-05-28 18:18:06 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Volker Braun 2010-05-08 08:48:16 EDT
Description of problem:

On my i5-520m (Arrandale) integrated graphics (Thinkpad T410s) the 2D graphics works fine, but when I turn on desktop-effects/compiz then X freezes after a short while. I can still SSH into the laptop, but I cannot kill X.


Version-Release number of selected component (if applicable):

kernel-2.6.33.3-85.fc13.x86_64
xorg-x11-server-Xorg-1.8.0-12.fc13.x86_64
xorg-x11-drv-intel-2.11.0-4.fc13.x86_64
mesa-libGL-7.8.1-6.fc13.x86_64
mesa-dri-drivers-7.8.1-6.fc13.x86_64
mesa-libGLU-7.8.1-6.fc13.x86_64

How reproducible:

Freeze is not immediate, but happens always.

Steps to Reproduce:
1. Enable desktop-effects.
2. Keep using the system for about 1 minute
3. X freezes
  

Additional info:


The following error is recorded in /var/log/messages:

May  8 08:21:42 localhost kernel: INFO: task i915:177 blocked for more than 120 seconds.
May  8 08:21:42 localhost kernel: "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this
 message.
May  8 08:21:42 localhost kernel: i915          D 0000000000000000     0   177      2 0x00000000
May  8 08:21:42 localhost kernel: ffff88022dc39d20 0000000000000046 0000000000000000 00000000ffffff00
May  8 08:21:42 localhost kernel: 0000000000000000 ffff88000900fb00 0000000000000400 ffff88022dc39fd8
May  8 08:21:42 localhost kernel: ffff88022dc39fd8 000000000000f9b0 00000000000157c0 ffff88022e886108
May  8 08:21:42 localhost kernel: Call Trace:
May  8 08:21:42 localhost kernel: [<ffffffff81429f6b>] __mutex_lock_common+0x135/0x19c
May  8 08:21:42 localhost kernel: [<ffffffff814296b8>] ? schedule+0x850/0x8e6
May  8 08:21:42 localhost kernel: [<ffffffff81429fe6>] __mutex_lock_slowpath+0x14/0x16
May  8 08:21:42 localhost kernel: [<ffffffff8142a0ed>] mutex_lock+0x31/0x4b
May  8 08:21:42 localhost kernel: [<ffffffffa00863fb>] intel_idle_update+0x35/0x1f7 [i915]
May  8 08:21:42 localhost kernel: [<ffffffff810ad6c7>] ? probe_workqueue_execution+0xb1/0xcd
May  8 08:21:42 localhost kernel: [<ffffffff81060d3d>] worker_thread+0x1a4/0x232
May  8 08:21:42 localhost kernel: [<ffffffffa00863c6>] ? intel_idle_update+0x0/0x1f7 [i915]
May  8 08:21:42 localhost kernel: [<ffffffff81064817>] ? autoremove_wake_function+0x0/0x34
May  8 08:21:42 localhost kernel: [<ffffffff81060b99>] ? worker_thread+0x0/0x232
May  8 08:21:42 localhost kernel: [<ffffffff810643c7>] kthread+0x7a/0x82
May  8 08:21:42 localhost kernel: [<ffffffff8100a924>] kernel_thread_helper+0x4/0x10
May  8 08:21:42 localhost kernel: [<ffffffff8106434d>] ? kthread+0x0/0x82
May  8 08:21:42 localhost kernel: [<ffffffff8100a920>] ? kernel_thread_helper+0x0/0x10

May  8 08:21:42 localhost kernel: INFO: task Xorg:1792 blocked for more than 120 seconds.
May  8 08:21:42 localhost kernel: "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.
May  8 08:21:42 localhost kernel: Xorg          D 0000000000000000     0  1792   1789 0x00400004
May  8 08:21:42 localhost kernel: ffff8802319abc38 0000000000000082 0000000000000000 ffffffff810d845e
May  8 08:21:42 localhost kernel: ffff8802319abc98 00007ff82390e000 0000000000000000 ffff8802319abfd8
May  8 08:21:42 localhost kernel: ffff8802319abfd8 000000000000f9b0 00000000000157c0 ffff88022f8549b8
May  8 08:21:42 localhost kernel: Call Trace:
May  8 08:21:42 localhost kernel: [<ffffffff810d845e>] ? zap_page_range+0xc0/0xd3
May  8 08:21:42 localhost kernel: [<ffffffff81429f6b>] __mutex_lock_common+0x135/0x19c
May  8 08:21:42 localhost kernel: [<ffffffff81429fe6>] __mutex_lock_slowpath+0x14/0x16
May  8 08:21:42 localhost kernel: [<ffffffff8142a0ed>] mutex_lock+0x31/0x4b
May  8 08:21:42 localhost kernel: [<ffffffffa007ae38>] i915_gem_mmap_gtt_ioctl+0x64/0x249 [i915]
May  8 08:21:42 localhost kernel: [<ffffffffa002b19b>] drm_ioctl+0x254/0x365 [drm]
May  8 08:21:42 localhost kernel: [<ffffffffa007add4>] ? i915_gem_mmap_gtt_ioctl+0x0/0x249 [i915]
May  8 08:21:42 localhost kernel: [<ffffffff811015b7>] ? fsnotify_modify+0x67/0x6f
May  8 08:21:42 localhost kernel: [<ffffffff8110e0ab>] vfs_ioctl+0x2d/0xa1
May  8 08:21:42 localhost kernel: [<ffffffff8110e614>] do_vfs_ioctl+0x47e/0x4c4
May  8 08:21:42 localhost kernel: [<ffffffff8110e6ab>] sys_ioctl+0x51/0x74
May  8 08:21:42 localhost kernel: [<ffffffff81102516>] ? sys_writev+0x5c/0x8e
May  8 08:21:42 localhost kernel: [<ffffffff81009b02>] system_call_fastpath+0x16/0x1b
[...]

Similar to, but not quite the same as #582426.
Comment 1 Volker Braun 2010-05-16 08:02:48 EDT
Retried with kernel-2.6.33.4-95.fc13 and it took a lot longer until X froze, maybe 10 minutes this time. Getting better, but still not there.

Upstream bug: https://bugzilla.kernel.org/show_bug.cgi?id=15671
Comment 2 Volker Braun 2010-05-20 07:16:46 EDT
Seems to be fixed in kernel-2.6.34-2.fc14, I haven't seen any X freezes with desktop-effects in a day of testing.
Comment 3 Matěj Cepl 2010-05-28 18:18:06 EDT
Thank you for letting us know.