Bug 592595

Summary: jqplot missing AsynchronousJQPlotWidget
Product: Red Hat Enterprise Linux 6 Reporter: Josh <joshkayse>
Component: distributionAssignee: Dave Malcolm <dmalcolm>
Status: CLOSED WONTFIX QA Contact: qe-baseos-daemons
Severity: medium Docs Contact:
Priority: low    
Version: 6.0CC: azelinka, lmacken, riek, syeghiay
Target Milestone: rcKeywords: FutureFeature, Rebase
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-06-09 19:54:51 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Josh 2010-05-15 12:29:47 EDT
Description of problem:
the jqplot widget does not include the AsynchronousJQPLotWidget, additionally the version of jqplot included with python-tw-jquery is old.

Version-Release number of selected component (if applicable):
0.9.5-1.el6

How reproducible:
Always

Steps to Reproduce:
1. Install python-tw-jquery
2. Try to import tw.jquery.jqplot.AsynchronousJQPLotWidget
3.
  
Actual results:
no class found

Expected results:
imported

Additional info:
Comment 2 Dave Malcolm 2010-05-17 12:14:49 EDT
tw.jquery.jqplot.AsynchronousJQPLotWidget was added in this upstream commit:
http://toscawidgets.org/trac/tw.jquery/changeset/98:316dd22c2144
which appears to be in 0.9.8, but not in 0.9.5

The latest upstream release is 0.9.9
Comment 3 Luke Macken 2010-05-21 23:54:53 EDT
$ python -c 'from tw.jquery.jqplot import AsynchronousJQPlotWidget as x; print x'
<class 'tw.jquery.jqplot.AsynchronousJQPlotWidget'>
$ rpm -q python-tw-jquery
python-tw-jquery-0.9.9-1.fc13.noarch

I pushed 0.9.9 from rawhide all the way down to EPEL-5 a while ago.  It looks like the RHEL6 package needs to be updated.
Comment 5 Dave Malcolm 2010-05-24 13:50:12 EDT
Luke: I only see 0.9.8 at:
http://toscawidgets.org/trac/tw.jquery/browser/.hgtags

Is upstream missing a tag?
Comment 6 Luke Macken 2010-05-25 14:34:13 EDT
(In reply to comment #5)
> Luke: I only see 0.9.8 at:
> http://toscawidgets.org/trac/tw.jquery/browser/.hgtags
> 
> Is upstream missing a tag?    

Ah, yes.  I had tagged it locally, but didn't do an `hg push` until just now.
Comment 7 RHEL Product and Program Management 2010-06-07 12:12:15 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 9 RHEL Product and Program Management 2010-07-15 10:51:26 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 14 RHEL Product and Program Management 2011-06-09 19:54:51 EDT
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request.