Bug 593572

Summary: Bluetooth Internet sharing fails
Product: [Fedora] Fedora Reporter: Misha Shnurapet <zayzayats>
Component: gnome-bluetoothAssignee: Bastien Nocera <bnocera>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 12CC: bnocera
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-05-19 07:59:43 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Misha Shnurapet 2010-05-19 07:52:40 UTC
I bind my netbook to my PC having a broadband Internet connection and check the option to use the PC for networking. I then open the NetworkManager applet menu and see the connection created. But it's not useable as I click to connect. 

gnome-bluetooth-libs-2.28.6-2.fc12.i686
gnome-bluetooth-2.28.6-2.fc12.i686
bluez-libs-4.58-1.fc12.i686
bluez-4.58-1.fc12.i686
bluez-cups-4.58-1.fc12.i686
NetworkManager-openvpn-0.7.996-4.git20090923.fc12.i686
NetworkManager-vpnc-0.7.996-4.git20090921.fc12.i686
NetworkManager-0.8.0-6.git20100408.fc12.i686
NetworkManager-pptp-0.7.997-3.git20100120.fc12.i686
NetworkManager-glib-0.8.0-6.git20100408.fc12.i686
NetworkManager-gnome-0.8.0-6.git20100408.fc12.i686

I tried it several times with same result.

Steps to Reproduce:
1. Bind a notebook to a PC having a USB bluetooth dongle installed; 
2. Choose the newly created Internet connection in the NetworkManager applet.
  
The NetworkManager icon twirls for a while showing it is working on the command, but then goes back to "disconnected". No connection actually established. When doing same action with a mobile phone it connects well and changes its icon to "wireless connection".

I have also tried to do the same with Blueman and it also failed saying "Failed to obtain an IP address on bnep0". I'm not sure if it's related, though, as these are different software.

I have googled for the error message, but it seems to be a rare issue. I have also asked on IRC, but I assume noone got interested to answer.

Comment 1 Misha Shnurapet 2010-05-19 07:59:43 UTC
Sorry, couldn't post it several times.

*** This bug has been marked as a duplicate of bug 593574 ***