Bug 595897

Summary: Kickstart install using NFS fails on s390x
Product: Red Hat Enterprise Linux 6 Reporter: Kenneth Hall <kenneth.j.hall>
Component: anacondaAssignee: David Cantrell <dcantrell>
Status: CLOSED DUPLICATE QA Contact: Release Test Team <release-test-team>
Severity: medium Docs Contact:
Priority: low    
Version: 6.0CC: herrold, notting
Target Milestone: rc   
Target Release: ---   
Hardware: s390x   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-05-26 23:28:38 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Kenneth Hall 2010-05-25 21:11:43 UTC
Description of problem:

Kickstart install fails with ERROR   : iface_ip2str returned NULL  
followed by "Error downloading kickstart file"

Version-Release number of selected component (if applicable):

RHEL 6.0 beta

How reproducible:

Every time

Steps to Reproduce:
1. Punch kernel, parm file, and initrd to VM reader
2. Boot from Reader
3. 
  
Actual results:

Error messages above, followed by drop to text mode install, with ANSI escape characters on 3270 session

Expected results:
Automatic install.

Additional info:

Using the following REDHAT CONF file:

HOSTNAME="vzd0004.bankofamerica.com"       
DASD="100-103,200-4b9"                     
NETTYPE="qeth"                             
IPADDR="171.176.0.4"                       
SUBCHANNELS="0.0.9b10,0.0.9b11,0.0.9b12"   
PORTNAME="FOOBAR"                          
# NETWORK="171.176.0.0"                    
NETMASK="255.255.254.0"                    
# BROADCAST="171.176.1.255"                
LAYER2=0                                   
PORTNO=0                                   
SEARCHDNS="bankofamerica.com"              
GATEWAY="171.176.1.254"                    
DNS="171.174.3.251"                        
MTU="1500"                                 
RUNKS=1                                    

PARM file as follows:

root=/dev/ram0 ro ip=off ramdisk_size=40000               
CMSDASD=3191 CMSCONFFILE=REDHAT.CONF RUNKS=1 cmdline      
ks=nfs:171.176.0.1:/rhel6/ks/ks60beta.cfg                 

Kickstart file is present on server.  Directory is exported and can be mounted from other guests on the same subnet:

/rhel6          <world>

Once kickstart fetch fails, install drops to a character mode screen containing ANSI escape characters (cmdline is specified).  In this state, the guest is pingable and reachable as root via ssh, so network is active and working.

I have tried using a variation of ks=url: instead of NFS to fetch the file, but this does not work either.  Installation of RHEL5.3, 5.4, and 5.5 systems using virtually identical configuration works perfectly.

Kickstart is mentioned in install doc and release notes, but there is no link to the kickstart document I have previously used, or updated version.  Actual procedure for invoking kickstart on s390x is very poorly documented.

Comment 2 RHEL Product and Program Management 2010-05-26 23:26:52 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 3 David Cantrell 2010-05-26 23:28:38 UTC

*** This bug has been marked as a duplicate of bug 541873 ***