Bug 596018

Summary: [abrt] crash in duplicity-0.6.08b-1.fc13: duplicity:474:incremental_backup:AssertionError: time not moving forward at appropriate pace - system clock issues?
Product: [Fedora] Fedora Reporter: Justin Willmert <justin>
Component: duplicityAssignee: Robert Scheck <redhat-bugzilla>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 13CC: adlorenz, a_wheeler, barsteadr, bernie+fedora, bugzilla, cade, c.cerbo, dakshay, dinyar.rabady+spam, elcajeme, eric, gerard, hughesjm80, ikke+redhat, michael.mccarrin, mrblack, palango, redhat, redhat-bugzilla, redhat, redhat, richmattes, rodd, usaywot, wellspring3
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard: abrt_hash:57ca0d48
Fixed In Version: duplicity-0.6.09-1.el5 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-09-23 04:53:08 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
File: backtrace none

Description Justin Willmert 2010-05-26 06:49:38 UTC
abrt 1.1.0 detected a crash.

architecture: x86_64
cmdline: /usr/bin/python /usr/bin/duplicity --exclude=/media/Win7/Users/Justin/AppData/Roaming/Thunderbird/Profiles/jbz2e3i9.default/ImapMail --exclude=/media/Win7/Users/Justin/AppData/Local/Temp --exclude=/media/Win7/Users/Justin/AppData/Local/Mozilla/Firefox/Profiles/lkcmjws2.default/Cache '--exclude=/media/Win7/Users/Justin/AppData/Local/Google/Chrome/User Data/Default/Cache' '--exclude=/media/Win7/Users/Justin/AppData/Local/Microsoft/Windows/Temporary Internet Files' --exclude=/media/Win7/Users/Justin/AppData/Local/Adobe/CameraRaw/Cache '--exclude=/media/Win7/Users/Justin/Pictures/Lightroom/Lightroom 2 Catalog Previews.lrdata' --exclude=/media/Win7/Users/Justin/Pictures/Lightroom/Backups --include=/media/Win7/Users/Justin --exclude=/home/justin/.thumbnails --exclude=/home/justin/.mozilla/firefox/m0flj587.default/Cache --exclude=/home/justin/.thunderbird/5iugw93d.default/ImapMail --exclude=/home/justin/.local/share/Trash --exclude=/home/justin/.Private --exclude=/home/justin/.recent-applications.xbel --exclude=/home/justin/.recently-used.xbel --exclude=/home/justin/.xsession-errors --exclude=/home/justin/.gvfs --exclude=/home/justin/.thumbnails --exclude=/home/justin/.cache --include=/home/justin --exclude=/sys --exclude=/proc --exclude=/tmp --exclude=** --dry-run --gio --volsize=10 / sftp://justin@delta.jdjlab.com/mnt/data/backups/justin --verbosity=9 '--gpg-options= ' --archive-dir=/home/justin/.cache/deja-dup --log-file=/tmp/deja-dup-TDWBDV
component: duplicity
executable: /usr/bin/duplicity
kernel: 2.6.33.4-95.fc13.x86_64
package: duplicity-0.6.08b-1.fc13
reason: duplicity:474:incremental_backup:AssertionError: time not moving forward at appropriate pace - system clock issues?
release: Fedora release 13 (Goddard)

backtrace
-----
duplicity:474:incremental_backup:AssertionError: time not moving forward at appropriate pace - system clock issues?

Traceback (most recent call last):
  File "/usr/bin/duplicity", line 1239, in <module>
    with_tempdir(main)
  File "/usr/bin/duplicity", line 1232, in with_tempdir
    fn()
  File "/usr/bin/duplicity", line 1214, in main
    incremental_backup(sig_chain)
  File "/usr/bin/duplicity", line 474, in incremental_backup
    assert dup_time.curtime != dup_time.prevtime, "time not moving forward at appropriate pace - system clock issues?"
AssertionError: time not moving forward at appropriate pace - system clock issues?

Local variables in innermost frame:
sig_chain: <duplicity.collections.SignatureChain instance at 0x1d257a0>

How to reproduce
-----
1. Configured Deja-dup
2. Performed backup
3. Logged out
4. Logged in
5. Tried to perform backup again with more directories

Comment 1 Justin Willmert 2010-05-26 06:49:40 UTC
Created attachment 416685 [details]
File: backtrace

Comment 2 Justin Willmert 2010-05-26 19:03:47 UTC
Deleting previous backup solved the issue. Backups were stored on a remote server connected with ssh/sftp. The system times did not appear to differ, but maybe duplicity is more sensitive than I could determine. Would this be an error much like 'make' warns when working with remote file systems? I have configured ntpd on both the client and remote server to see if that will resolve this issue upon running the next backup.

Comment 3 Justin Willmert 2010-06-02 06:32:42 UTC
Second backup worked without an error. NTP keeping clocks well synchronized may be an essential part of getting duplicity to work correctly.

Comment 4 Gerard Ryan 2010-06-10 01:35:24 UTC
Package: duplicity-0.6.08b-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. I was editing the preferences in Déjà Dup. I selected 'Automatically backup on a regular schedule' and set it to daily.
2. A box appeared saying the backup had failed
3. Also, backup location was a remote sftp folder

Comment 5 Dawid Lorenz 2010-06-10 10:01:53 UTC
Package: duplicity-0.6.08b-1.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----



Comment
-----
I made a full backup to remote drive (windows share) - worked OK.
For each consequent incremental backup fails like this.

Comment 6 J. v/d Kooij 2010-06-19 09:48:09 UTC
Package: duplicity-0.6.08b-1.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1.boot system
2.
3.


Comment
-----
after logging in, the crash occured

Comment 7 Robert Scheck 2010-06-20 23:36:08 UTC
I've sent an e-mail to upstream and pointed to this issue.

Comment 8 Tony C 2010-06-21 05:54:05 UTC
Package: duplicity-0.6.08b-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1.open the back-up tool
2.click on the "Back-up" icon
3.wait for it to 'scan' - crash !


Comment
-----
I don't know why it failed, this is the first crash, after 4 back-ups

Comment 9 Tony C 2010-06-21 05:56:24 UTC
Package: duplicity-0.6.08b-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1.open the back-up tool
2.click on the "Back-up" icon
3.wait for it to 'scan' - crash !


Comment
-----
I don't know why it failed, this is the first crash, after 4 back-ups.

and now it has crashed again

Comment 10 Bernie Innocenti 2010-06-22 19:44:29 UTC
Package: duplicity-0.6.08b-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
Simply retry a failed backup.

Note, time has _not_ moved backwards. Could it be an issue with TZ handling?

Comment 11 Bernie Innocenti 2010-06-22 20:09:44 UTC
The problem seems to be in /usr/lib64/python2.6/site-packages/duplicity/dup_time.py:

>>> from duplicity import dup_time
>>> dup_time.setcurtime()
>>> dup_time.curtime
1277236224L
>>> dup_time.setcurtime()
>>> dup_time.curtime
1277236224L
>>> dup_time.setcurtime()
>>> dup_time.curtime
1277236224L

Comment 12 dinyar.rabady+spam 2010-06-23 21:36:28 UTC
Package: duplicity-0.6.08b-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. Ran scheduled update after a crash.

Comment 13 Michael 2010-06-25 04:58:11 UTC
Package: duplicity-0.6.08b-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1.Open Dejai Dup
2.Click Backup
3."Failed with an unknown error"
4. Duplicity crashes.

Comment 14 Andrew Wheeler 2010-06-25 17:37:27 UTC
Package: duplicity-0.6.08b-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. run deja dup connected to amazon s3 message pops up
2.
3.


Comment
-----
Message just keeps appearing have rebooted but still happens

Comment 15 Andrew Wheeler 2010-06-27 14:06:45 UTC
I found a thread that talked about removing some part files in a temp directory and after deleting the files I was able to back up with out problem.

The part files can be found in ~/.cache/deja-dup/(a random looking sub directory)

rm *.part 

hope this helps

Andrew Wheeler

Comment 16 eric 2010-06-28 16:18:25 UTC
Package: duplicity-0.6.08b-1.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. Manually started the backup process.
2. Noted "processing" on the screen.
3. Failed with "unknown error" showing.

Comment 17 eric 2010-06-30 22:37:39 UTC
Package: duplicity-0.6.08b-1.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. Manually started the backup process.
2. Noted "processing" on the screen.
3. Failed with "unknown error" showing.

Comment 18 barsteadr 2010-07-07 13:22:36 UTC
Package: duplicity-0.6.08b-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1.This error is triggererd either when duplicity is set to backup on a schedule or manually. The error happens in the "scanning" phase of the backup.
2.
3.

Comment 19 barsteadr 2010-07-07 13:29:28 UTC
After reporting the error I did as suggested in comment 15. The backup now works.

Comment 20 FAZ 2010-07-08 15:20:39 UTC
Package: duplicity-0.6.08b-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. My backup is on a windows share server... This server is nor using ntp...
2. I Had automatic schedule Backup but couldnt backup because i was not online. Well i was online on another network...
3. It did backup successfully just one time....

Comment 21 eric 2010-07-09 13:13:46 UTC
Package: duplicity-0.6.08b-1.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. Stopped broken incremental backup.
2. Started incremental backup.
3. Fail

Comment 22 Rodd Clarkson 2010-07-10 00:56:49 UTC
Package: duplicity-0.6.08b-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1.  
2.
3.


Comment
-----
I've backed up with duplicity a few times and so far it's been fine.

The last backup I didn't finish, but clicked the button to stop the backup and resume at a later date.  Now it doesn't seem to want to work.

Comment 23 Jephir 2010-07-22 00:11:08 UTC
Package: duplicity-0.6.08b-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. Set Deja-Dup to backup every day
2. Wait for a daily backup


Comment
-----
Deja-Dup reported this error when it tried to do a daily backup. The backup is being done to a Windows share over the network.

Comment 24 Jephir 2010-07-22 21:43:18 UTC
Package: duplicity-0.6.08b-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. Set Deja-Dup to backup every day
2. Wait for a daily backup


Comment
-----
Deja-Dup reported this error when it tried to do a daily backup. The backup is being done to a Windows share over the network.

Comment 25 Rich Mattes 2010-08-01 23:23:21 UTC
I encountered this error while using Deja-dup.  The workaround in comment #15 solved the issue for me.

Comment 26 Costantino Cerbo 2010-08-12 16:18:10 UTC
Package: duplicity-0.6.08b-1.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. Incremental backup started automatically
2. PC shutdown
3. PR restart


Comment
-----
The problem occurs with the auto-backup.

Comment 27 Andreas Müller 2010-08-17 18:08:15 UTC
I've encountered the bug as well. It seems to happen when duplicity tries to resume a previously failed backup (which I really want to do, so the mentioned workaround isn't an option for me).

The upstream fix for this seems to be here:
http://bazaar.launchpad.net/~duplicity-team/duplicity/0.6-series/revision/653

Applying this patch fixes the problem for me.

Regards,
Andreas.

Comment 28 Robert Hoekstra 2010-08-26 06:33:40 UTC
Package: duplicity-0.6.08b-1.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. deja dup is scheduled for weekly back-up
2. system just came from suspend mode
3. perhaps a backup was just active when I suspended the system?, would explain the clock issues being reported

Comment 29 Joshua M. Hughes 2010-09-02 02:41:13 UTC
Package: duplicity-0.6.08b-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1.Open backup app.
2.Click on backup.
3.Click on show details.


Comment
-----
Open the backup application and click on backup. When the backup starts click on show details.

Comment 30 Fedora Update System 2010-09-12 23:49:33 UTC
duplicity-0.6.09-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/duplicity-0.6.09-1.fc14

Comment 31 Fedora Update System 2010-09-12 23:50:16 UTC
duplicity-0.6.09-1.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/duplicity-0.6.09-1.fc13

Comment 32 Fedora Update System 2010-09-12 23:50:21 UTC
duplicity-0.6.09-1.fc12 has been submitted as an update for Fedora 12.
https://admin.fedoraproject.org/updates/duplicity-0.6.09-1.fc12

Comment 33 Fedora Update System 2010-09-12 23:50:37 UTC
duplicity-0.6.09-1.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/duplicity-0.6.09-1.el5

Comment 34 Fedora Update System 2010-09-12 23:50:43 UTC
duplicity-0.6.09-1.el4 has been submitted as an update for Fedora EPEL 4.
https://admin.fedoraproject.org/updates/duplicity-0.6.09-1.el4

Comment 35 Fedora Update System 2010-09-13 16:27:54 UTC
duplicity-0.6.09-1.el4 has been pushed to the Fedora EPEL 4 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update duplicity'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/duplicity-0.6.09-1.el4

Comment 36 Fedora Update System 2010-09-13 16:28:01 UTC
duplicity-0.6.09-1.el5 has been pushed to the Fedora EPEL 5 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update duplicity'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/duplicity-0.6.09-1.el5

Comment 37 mrblack 2010-09-17 17:51:12 UTC
Package: duplicity-0.6.08b-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1.execute la sauvegarde dja dump

2. sauvegarde
3.

Comment 38 mrblack 2010-09-20 08:16:05 UTC
Package: duplicity-0.6.08b-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1.execute la sauvegarde dja dump

2. sauvegarde
3.

Comment 39 Fedora Update System 2010-09-23 04:53:02 UTC
duplicity-0.6.09-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 40 Fedora Update System 2010-09-23 04:59:23 UTC
duplicity-0.6.09-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 41 Fedora Update System 2010-09-23 13:04:03 UTC
duplicity-0.6.09-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 42 Fedora Update System 2010-09-28 18:33:02 UTC
duplicity-0.6.09-1.el4 has been pushed to the Fedora EPEL 4 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 43 Fedora Update System 2010-09-28 18:35:46 UTC
duplicity-0.6.09-1.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.