Bug 597880

Summary: SELinux is preventing /var/lib/boinc/slots/3/freeze "getattr" access on /proc/<pid>/net/tcp.
Product: [Fedora] Fedora Reporter: Daniel Stripes <dlstripes-fedorabugs>
Component: selinux-policyAssignee: Daniel Walsh <dwalsh>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 13CC: dwalsh, mgrepl
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard: setroubleshoot_trace_hash:de44bb5796f97b39c5227e14eaa42cf5f92735f58ed19b70cf6fe509c2569615
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-05-31 10:06:35 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Daniel Stripes 2010-05-30 21:31:28 UTC
Summary:

SELinux is preventing /var/lib/boinc/slots/3/freeze "getattr" access on /proc//net/tcp.

Detailed Description:

[freeze has a permissive type (boinc_t). This access was not denied.]

SELinux denied access requested by freeze. It is not expected that this access
is required by freeze and this access may signal an intrusion attempt. It is
also possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:boinc_t:s0
Target Context                system_u:object_r:proc_net_t:s0
Target Objects                /proc/<pid>/net/tcp [ file ]
Source                        freeze
Source Path                   /var/lib/boinc/slots/3/freeze
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.7.19-21.fc13
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.33.4-95.fc13.i686.PAE #1
                              SMP Thu May 13 05:38:26 UTC 2010 i686 i686
Alert Count                   10
First Seen                    Sat 29 May 2010 10:43:39 PM EDT
Last Seen                     Sun 30 May 2010 05:20:05 PM EDT
Local ID                      e914e6da-141a-4500-a89e-4b380f6d9191
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1275254405.183:47): avc:  denied  { getattr } for  pid=3364 comm="freeze" path="/proc/3364/net/tcp" dev=proc ino=4026531955 scontext=system_u:system_r:boinc_t:s0 tcontext=system_u:object_r:proc_net_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1275254405.183:47): arch=40000003 syscall=197 per=400000 success=yes exit=0 a0=8 a1=bfa2ab08 a2=d96ff4 a3=9961688 items=0 ppid=3303 pid=3364 auid=4294967295 uid=492 gid=486 euid=492 suid=492 fsuid=492 egid=486 sgid=486 fsgid=486 tty=(none) ses=4294967295 comm="freeze" exe="/var/lib/boinc/slots/3/freeze" subj=system_u:system_r:boinc_t:s0 key=(null)



Hash String generated from  catchall,freeze,boinc_t,proc_net_t,file,getattr
audit2allow suggests:

#============= boinc_t ==============
allow boinc_t proc_net_t:file getattr;

Comment 1 Miroslav Grepl 2010-05-31 10:06:35 UTC

*** This bug has been marked as a duplicate of bug 597879 ***