Bug 600024

Summary: FTBFS Django-1.2.1-1.fc14
Product: [Fedora] Fedora Reporter: FTBFS <ftbfs>
Component: DjangoAssignee: Steve Milner <smilner>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: high    
Version: rawhideCC: dmalcolm, michel, smilner
Target Milestone: ---Keywords: Triaged
Target Release: ---   
Hardware: All   
OS: Linux   
URL: http://linux.dell.com/files/fedora/FixBuildRequires/mock-results/
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-06-05 11:44:49 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 596849    
Attachments:
Description Flags
root.log
none
build.log
none
mock.log
none
root.log
none
build.log
none
mock.log none

Description FTBFS 2010-06-03 17:17:55 EDT
Django-1.2.1-1.fc14.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2010-06-03 17:17:57 EDT
Created attachment 420958 [details]
root.log

root.log for i386
Comment 2 FTBFS 2010-06-03 17:17:59 EDT
Created attachment 420959 [details]
build.log

build.log for i386
Comment 3 FTBFS 2010-06-03 17:18:00 EDT
Created attachment 420960 [details]
mock.log

mock.log for i386
Comment 4 FTBFS 2010-06-03 17:18:01 EDT
Created attachment 420961 [details]
root.log

root.log for x86_64
Comment 5 FTBFS 2010-06-03 17:18:03 EDT
Created attachment 420962 [details]
build.log

build.log for x86_64
Comment 6 FTBFS 2010-06-03 17:18:04 EDT
Created attachment 420963 [details]
mock.log

mock.log for x86_64
Comment 7 Dave Malcolm 2010-06-03 17:24:35 EDT
Error seems to be in docs creation, possibly due to the new sphinx: http://lists.fedoraproject.org/pipermail/devel/2010-May/136686.html


/builddir/build/BUILD/Django-1.2.1/docs/_ext/djangodocs.py:91: DeprecationWarning: xfileref_role is deprecated, use XRefRole
  xrefs = sphinx.roles.xfileref_role('ref', linktext, linktext, lineno, state)
Exception occurred:
  File "/builddir/build/BUILD/Django-1.2.1/docs/_ext/djangodocs.py", line 103, in parse_version_directive
    env.note_versionchange(node['type'], node['version'], node, lineno)
AttributeError: BuildEnvironment instance has no attribute 'note_versionchange'
The full traceback has been saved in /tmp/sphinx-err-V6gMOb.log, if you want to report the issue to the developers.
Please also report this if it was a user error, so that a better error message can be provided next time.
Either send bugs to the mailing list at <http://groups.google.com/group/sphinx-dev/>,
or report them in the tracker at <http://bitbucket.org/birkenfeld/sphinx/issues/>. Thanks!
make: *** [html] Error 1
Comment 8 Steve Milner 2010-06-04 09:29:31 EDT
1.2.1-3 and 1.2.1-4 _should_ fix these issues.
Comment 9 Michel Alexandre Salim 2010-06-05 11:44:49 EDT
Indeed, 1.2.1-4 is now in the mirrors.