Bug 601363

Summary: cross reference not jumping to figures, tables
Product: [Community] Publican Reporter: Kinman Cheung <kcheung>
Component: publicanAssignee: Jeff Fearn <jfearn>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 1.6CC: jfearn, mmcallis, publican-list, r.landmann
Target Milestone: ---   
Target Release: ---   
Hardware: alpha   
OS: Linux   
Whiteboard:
Fixed In Version: 2.0 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-08-05 00:16:20 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Kinman Cheung 2010-06-07 15:13:16 EDT
Description of problem:
The xref element generates the text for a figure or title correctly, but does not jump to that section of the html document when the link is clicked. Xref works as expected when used on sections.


Version-Release number of selected component (if applicable):


How reproducible:
Open or edit an XML file and add a xref for a section, figure, and table. Add filler text, a subsection, image, and table that gets referenced. Build with publican and view the HTML.

Steps to Reproduce:
1. Open / edit a XML file
2. Add cross reference links: <xref linkend='foo1' />, <xref linkend='foo2' />, and <xref linkend='foo3' />
3. Add filler text (<para>whatever</para>) to stretch the page vertically
4. Add a diagram with <figure>:
  <figure id='foo1'><title>My Diagram</title>
    <mediaobject>
      <imageobject>
        <imagedata contentwidth='100px' contentdepth='100px' align='center' fileref='images/my_diagram.png' format='PNG' />
      </imageobject>
    </mediaobject>
  </figure>
5. Add a table:
  <table id='foo2'><title>My Table</title><tgroup cols='2'><tbody>
    <row>
      <entry>1</entry>
      <entry>2</entry>
    </row>
    <row>
      <entry>3</entry>
      <entry>4</entry>
    </row>
  </tbody></tgroup></table>
6. Add a subsection: <section id='foo3'><title>My Section</title><para>whatever</para></section>
7. build the HTML with publican
  
Actual results:
The links are generated with the correct text (Figure 1, "My Diagram", Table 1, "My Table", Section 1, "My Section") but only the link to the section actually jumps to the target.

Expected results:
The link to the table and the figure should also jump to their targets.

Additional info:
Tested with both double and single qoutes for linkend and id, bugged with both.
Actual file: file:///home/remote/kcheung/cc/RHCS8_CommonCriteria/Evidence_Documents/en-US/life-cycle/life-cycle_FLR.xml
Comment 1 Jeff Fearn 2010-06-09 00:07:30 EDT
ID's were not being set in the output for some formal objects.

Fixed in build 1.6.3-0.t99
Comment 2 Jeff Fearn 2010-06-14 20:45:03 EDT
*** Bug 603950 has been marked as a duplicate of this bug. ***