Bug 603786

Summary: alt-shift-! wedges keyboard in tigervnc remote session
Product: [Fedora] Fedora Reporter: Jonathan Kamens <jik>
Component: tigervncAssignee: Adam Tkac <atkac>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 13CC: atkac, m_pupil, ovasik
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: tigervnc-1.0.90-0.16.20100420svn4030.fc13 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-01-31 14:51:48 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Jonathan Kamens 2010-06-14 11:11:56 EDT
Using VNC Viewer Free Edition 4.1.3 on Windows 7, talking to tigervnc server in current Fedora 13, when I am typing into an Emacs window in my VNC session and hit alt-shift-!, my keyboard wedges and I can't type any more input into the VNC session, and I can't find any way to unwedge it, even by disconnecting and opening a new VNC session.
Comment 1 Jonathan Kamens 2010-06-14 11:13:21 EDT
Does not happen with Vino server.
Comment 2 Adam Tkac 2010-06-14 11:25:55 EDT
Which version of tigervnc-server package do you use?
Comment 3 Jonathan Kamens 2010-06-14 14:51:24 EDT
I am using the server module.

jik2:~/public_html!1027$ rpm -q tigervnc-server-module
tigervnc-server-module-1.0.90-0.11.20100420svn4030.fc13.x86_64
Comment 4 Kai.Fan 2010-06-22 12:17:28 EDT
do you have ibus installed? If so, is there any Input-method activated when you press alt-shift?
Comment 5 Jonathan Kamens 2010-06-22 13:49:08 EDT
I do have ibus, but alt-shift isn't bound to anything.  I have alt-capslock bound to switching keyboard layouts (in my case from USA to Isr), but like I said, alt-shift doesn't do anything.  I can hit alt-shift-! on the console and through vino with no trouble.
Comment 6 Adam Tkac 2010-09-02 07:59:38 EDT
Can you test http://atkac.fedorapeople.org/tigervnc/tigervnc-server-module-1.0.90-0.13.20100420svn4030.fc13.1.x86_64.rpm, please? Although I
haven't reproduced this bug, in theory this package should fix this issue.
Thank you in advance.
Comment 7 Jonathan Kamens 2010-09-02 08:39:51 EDT
The problem is still there, but now it's intermittent. When I type Alt-Shift-! date RET into Emacs repeatedly when remotely connected to the X server through the tigervnc server module, eventually the server gets into a confused state (I think the Alt modifier gets stuck on) and the only way for me to unconfuse it is to log out so the X server restarts (which is somewhat difficult to do when the Alt modifier is stuck on, of course).
Comment 8 Adam Tkac 2010-09-24 09:07:50 EDT
I've just created improved patch for this issue, can you please test http://atkac.fedorapeople.org/tigervnc/tigervnc-server-module-1.0.90-0.15.20100420svn4030.fc13.1.x86_64.rpm? Thank you in advance.
Comment 9 Jonathan Kamens 2010-09-25 12:52:46 EDT
	package tigervnc-server-module-1.0.90-0.22.20100813svn4123.fc14.x86_64 (which is newer than tigervnc-server-module-1.0.90-0.15.20100420svn4030.fc13.1.x86_64) is already installed
Comment 10 Adam Tkac 2010-10-29 09:59:41 EDT
(In reply to comment #9)
>  package tigervnc-server-module-1.0.90-0.22.20100813svn4123.fc14.x86_64 (which
> is newer than tigervnc-server-module-1.0.90-0.15.20100420svn4030.fc13.1.x86_64)
> is already installed

Ok, another attempt:
http://atkac.fedorapeople.org/tigervnc/tigervnc-server-module-1.0.90-0.22.20100813svn4123.fc14.2.x86_64.rpm.

Can you please check if this package is fine?
Comment 11 Fedora Update System 2011-01-14 09:04:22 EST
tigervnc-1.0.90-0.16.20100420svn4030.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/tigervnc-1.0.90-0.16.20100420svn4030.fc13
Comment 12 Fedora Update System 2011-01-14 09:04:34 EST
tigervnc-1.0.90-0.24.20100813svn4123.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/tigervnc-1.0.90-0.24.20100813svn4123.fc14
Comment 13 Fedora Update System 2011-01-14 15:31:32 EST
tigervnc-1.0.90-0.16.20100420svn4030.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update tigervnc'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/tigervnc-1.0.90-0.16.20100420svn4030.fc13
Comment 14 Fedora Update System 2011-01-31 14:51:37 EST
tigervnc-1.0.90-0.24.20100813svn4123.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 15 Fedora Update System 2011-01-31 14:54:12 EST
tigervnc-1.0.90-0.16.20100420svn4030.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.