Bug 603962

Summary: [abrt] crash in java-1.6.0-openjdk-devel-1:1.6.0.0-39.b18.fc13: Process /usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0/bin/java was killed by signal 6 (SIGABRT)
Product: [Fedora] Fedora Reporter: Dan Irwin <rummymobile>
Component: java-1.6.0-openjdkAssignee: Omair Majid <omajid>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 13CC: aph, dbhole, dlila, jon.vanalten, langel, lkundrak, mark, mmatejov, ptisnovs
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard: abrt_hash:7ddd0e44704d43c291f4717b4672521070587adf
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-07-15 14:09:31 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
File: backtrace
none
a tiny reproducer none

Description Dan Irwin 2010-06-14 22:46:40 EDT
abrt 1.1.1 detected a crash.

architecture: i686
Attached file: backtrace
cmdline: /usr/lib/jvm/java-1.6.0-openjdk/bin/java -Djdk.home=/usr/lib/jvm/java-1.6.0-openjdk -classpath /usr/share/netbeans/6.8/platform11/lib/boot.jar:/usr/share/netbeans/6.8/platform11/lib/org-openide-modules.jar:/usr/share/netbeans/6.8/platform11/lib/org-openide-util.jar:/usr/lib/jvm/java-1.6.0-openjdk/lib/dt.jar:/usr/lib/jvm/java-1.6.0-openjdk/lib/tools.jar -Dnetbeans.system_http_proxy=DIRECT -Dnetbeans.system_http_non_proxy_hosts= -Dnetbeans.dirs=/usr/share/netbeans/6.8/nb6.8:/usr/share/netbeans/6.8/bin/../ergonomics2:/usr/share/netbeans/6.8/ide12:/usr/share/netbeans/6.8/java3:/usr/share/netbeans/6.8/bin/../xml2:/usr/share/netbeans/6.8/apisupport1:/usr/share/netbeans/6.8/bin/../webcommon1:/usr/share/netbeans/6.8/bin/../websvccommon1:/usr/share/netbeans/6.8/bin/../enterprise6:/usr/share/netbeans/6.8/bin/../mobility8:/usr/share/netbeans/6.8/bin/../profiler3:/usr/share/netbeans/6.8/bin/../ruby2:/usr/share/netbeans/6.8/bin/../python1:/usr/share/netbeans/6.8/bin/../php1:/usr/share/netbeans/6.8/bin/../visualweb2:/usr/share/netbeans/6.8/bin/../soa2:/usr/share/netbeans/6.8/bin/../identity2:/usr/share/netbeans/6.8/bin/../uml6:/usr/share/netbeans/6.8/harness:/usr/share/netbeans/6.8/bin/../cnd3:/usr/share/netbeans/6.8/bin/../dlight2:/usr/share/netbeans/6.8/bin/../groovy2:/usr/share/netbeans/6.8/bin/../extra:/usr/share/netbeans/6.8/bin/../javafx2:/usr/share/netbeans/6.8/bin/../javacard1: -Dnetbeans.home=/usr/share/netbeans/6.8/platform11 -Dnetbeans.importclass=org.netbeans.upgrade.AutoUpgrade -Xmx512m -client -Xverify:none -Xss2m -Xms32m -XX:PermSize=32m -XX:MaxPermSize=200m -Dapple.laf.useScreenMenuBar=true -Dsun.java2d.noddraw=true -XX:+HeapDumpOnOutOfMemoryError -XX:HeapDumpPath=/home/dan/.netbeans/6.8/var/log/heapdump.hprof org.netbeans.Main --userdir /home/dan/.netbeans/6.8 --branding nb
component: java-1.6.0-openjdk
executable: /usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0/bin/java
global_uuid: 7ddd0e44704d43c291f4717b4672521070587adf
kernel: 2.6.33.5-112.fc13.i686.PAE
package: java-1.6.0-openjdk-devel-1:1.6.0.0-39.b18.fc13
rating: 3
reason: Process /usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0/bin/java was killed by signal 6 (SIGABRT)
release: Fedora release 13 (Goddard)

comment
-----
Repeatidly resizing windows in Netbeans 6.8 seems to make openjdk crash. Have had several openjdk crashes today, and each time was related to resizing a window.

Cannot reproduce using Sun 1.6.20.

How to reproduce
-----
1. Run Netbeans 6.8 from Fedora 13
2. Open a Project
3. Right click on project, show the project properties window
4. Resize the window
5. Resize the window again
6. Before Swing repaints the UI, resize the window again
7. Repeat 6
8. OpenJDK will crash, as will netbeans
Comment 1 Dan Irwin 2010-06-14 22:46:43 EDT
Created attachment 424014 [details]
File: backtrace
Comment 2 Denis Lila 2010-06-15 12:53:51 EDT
I was able to reproduce this.

I tried to reproduce it twice by resizing the properties window, and I was successful.
Then I tried 4 times to reproduce it by resizing the main netbeans window, without any projects open. I succeeded 2 of those times, and I had to move the mouse faster and for longer than in the cases where I was resizing the properties window. On the 2 other times I couldn't reproduce it. My arm got tired, so I stopped trying.
I could not reproduce the bug with any small, trivial swing programs (though, I didn't try very much). So I thought that this might be related to how quickly the window can be repainted relative to how many repaint requests there are.
So I ran two instances of a while(1) program to load the CPU as much as possible, but even in this case I was not able to reproduce the bug by resizing the main netbeans window.
Comment 3 Pavel Tisnovsky 2010-06-16 07:49:26 EDT
I'm able, like Denis, to reproduce this issue.

I also tried to change appearance of window borders and title bars using Gnome configuration tools, but it does not prevents crashes of Netbeans & JVM.

It is also possible to reproduce this bug using OpenJDK VisualVM tool which is installed with OpenJDK itself (so you don't have to install Netbeans). Because VisualVM's window contains fewer widgets than Netbeans Project Window, it takes longer to crash JVM by resizing it's window.

Tested on:

Fedora 13 i686, kernel 2.6.34-20
IcedTea6 1.8 (fedora-39.b18.fc13-i386)
latest X.org installed
Comment 4 Jon VanAlten 2010-06-16 13:11:51 EDT
Possible clue:

I reproduce this on my F12 box (as expected from previous comments).  But, I have tried this with upstream openjdk7 and after spending several minutes resizing Properties window I get no crash.  I also notice that in general the display updates are snappier.  For example if I shrink the Properties window the initially grey background is very quickly replaced with the display of the main window behind it, but with the icedtea6 installed on my system there is much more lag.

I do, however, still get the crash using builds from IcedTea6 HEAD or upstream openjdk6.
Comment 5 Denis Lila 2010-06-18 10:36:16 EDT
I tried to reproduce this a few times on a distribution of F13 using icedtea6 and running xfce instead of gnome, and no matter how long or how quickly I resized, I couldn't get it to crash.
Comment 6 Omair Majid 2010-06-25 10:52:10 EDT
Created attachment 426903 [details]
a tiny reproducer

This is a tiny java program that can reproduce the issue. Simply resize the window fast enough (it may take a few tries) to get the crash.

A few observations:
1. The crash only seems to happen with the gtk look and feel. Using swing's cross platform look and feel, the problem disappears
2. The NOISY_AWT environment variable can be used to make the program print out a stack trace as soon as awt sees an x error (the problem can be observed as soon as the window is made large enough): 
NOISY_AWT=abort java ResizeCrasher
3. The problem does not happen under a virtual machine. This program runs fine under gnome and xfce (under kvm).
Comment 7 Omair Majid 2010-07-15 14:09:31 EDT

*** This bug has been marked as a duplicate of bug 551835 ***