This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 607360

Summary: I cant get the packages and errata to update on my system; keep getting dependency issues
Product: Red Hat Enterprise Linux 5 Reporter: Nancy <nancy.eustice>
Component: yumAssignee: packaging-team-maint
Status: CLOSED NOTABUG QA Contact: BaseOS QE Security Team <qe-baseos-security>
Severity: urgent Docs Contact:
Priority: low    
Version: 5.5CC: james.antill, theo_nra
Target Milestone: rc   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-03-12 16:52:53 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
yum.conf none

Description Nancy 2010-06-23 17:58:44 EDT
Description of problem:  Multiple recursive dependency issues; I have 97 errata and 76 packages on the red hat network but none of them will install.  Recursive dependency issues such as when I try to update xulrunner it says xulrunner-devel depends on it and when I try to update xulrunner-devel it says xulrunner depends on it. 


Version-Release number of selected component (if applicable):
Redhat 5.5

How reproducible:

yum update or yum update --skip-broken or yum update xulrunner or yum update xulrunner-devel or yum update any of the packages on RHN or yum install any packages on RHN 
Steps to Reproduce:
  
Actual results:
[root@riw-lw-ito ~]# yum install xulrunner --skip-broken
Loaded plugins: rhnplugin, security
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package xulrunner.i386 0:1.9.2.4-9.el5 set to be updated
--> Processing Conflict: xulrunner conflicts firefox < 3.6
--> Restarting Dependency Resolution with new changes.
--> Running transaction check
---> Package firefox.i386 0:3.6.4-8.el5 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package         Arch       Version              Repository                Size
================================================================================
Updating:
 firefox         i386       3.6.4-8.el5          rhel-i386-client-5        14 M
 xulrunner       i386       1.9.2.4-9.el5        rhel-i386-client-5        12 M

Transaction Summary
================================================================================
Install       0 Package(s)
Upgrade       2 Package(s)

Total size: 26 M
Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
xulrunner is needed by (installed) xulrunner-devel
Complete!
(1, [u'Please report this error in https://bugzilla.redhat.com/enter_bug.cgi?product=Red%20Hat%20Enterprise%20Linux%205&component=yum'])


yum update gives back
.
.
.
Error: Missing Dependency: pcsc-lite-libs = 1.4.4-0.1.el5 is needed by package pcsc-lite-devel-1.4.4-0.1.el5.i386 (installed)
Error: Missing Dependency: libgcj = 4.1.2-42.el5 is needed by package libgcj-src-4.1.2-42.el5.i386 (installed)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest


Expected results:
yum updates all of my package resolving dependency issues

Additional info:  none of that "you could try"  works;  keep getting dependency issues
Comment 1 James Antill 2010-06-24 08:16:27 EDT
What does: "package-cleanup --problems" say?

Also: yum list xulrunner xulrunner-devel
Comment 2 Nancy 2010-06-24 10:11:45 EDT
[root@riw-lw-ito ~]# package-cleanup --problems
Setting up yum
Reading local RPM database
Processing all local requires
Missing dependencies:
Package openldap-devel requires openldap = 2.3.27-8.el5_1.3
Package libsepol-devel requires libsepol = 1.15.2-1.el5
Package nss-devel requires nss = 3.11.99.5-2.el5
Package libselinux-devel requires libselinux = 1.33.4-5.el5
Package xulrunner-devel requires xulrunner = 1.9-0.beta5.6.el5
Package gnutls-devel requires gnutls = 1.4.1-2
Package ruby-devel requires ruby-libs = 1.8.5-5.el5_1.1
Package hal-devel requires hal = 0.5.8.1-35.el5
Package nspr-devel requires nspr = 4.7.0.99.2-1.el5
Package freetype-devel requires freetype = 2.2.1-19.el5
[root@riw-lw-ito ~]# 

[root@riw-lw-ito ~]# yum list xulrunner xulrunner-devel
Loaded plugins: rhnplugin, security
rhel-i386-client-5                                       | 1.3 kB     00:00     
Installed Packages
xulrunner.i386                  1.9.0.19-1.el5_5              installed         
xulrunner-devel.i386            1.9-0.beta5.6.el5             installed         
Available Packages
xulrunner.i386                  1.9.2.4-9.el5                 rhel-i386-client-5
xulrunner-devel.i386            1.9.2.4-9.el5                 rhel-i386-client-5
[root@riw-lw-ito ~]# 

Thank you for your help!!
Comment 3 seth vidal 2010-06-24 10:17:15 EDT
Did you recently forcibly remove or install any pkgs?

Could you run the following and post the output:

echo 'n' |  yum remove xulrunner-devel gnutls-devel openldap-devel libsepol-devel nss-devel libselinux-devel ruby-devel hal-devel nspr-devel freetype-devel


thanks
Comment 4 Nancy 2010-06-24 10:33:14 EDT
No I did not forcibly remove or install anything; this time.  I had this problem before removed a qt-devel program; my system crashed and I reinstalled the OS and registered with RHN and allowed my system to update with it.  I first had over 700 errata and over 200 packages.  My system updated to this point with 97 errata and 76 package updates left; that will not install. 
[root@riw-lw-ito ~]# echo 'n' | yum remove xulrunner-devel gnutls-devel openldap-devel libsepol-devel nss-devel libselinux-devel ruby-devel hal-devel nspr-devel freetype-devel
Loaded plugins: rhnplugin, security
Setting up Remove Process
Resolving Dependencies
--> Running transaction check
---> Package freetype-devel.i386 0:2.2.1-19.el5 set to be erased
--> Processing Dependency: freetype-devel >= 2.1.3-3 for package: pango-devel
--> Processing Dependency: freetype-devel >= 2.1.9-2 for package: libXft-devel
--> Processing Dependency: freetype-devel >= 2.1.3-3 for package: cairo-devel
--> Processing Dependency: freetype-devel for package: qt-devel
--> Processing Dependency: freetype-devel >= 2.1.4 for package: fontconfig-devel
--> Processing Dependency: freetype-devel for package: gd-devel
--> Processing Dependency: freetype-devel >= 2.0.1 for package: librsvg2-devel
---> Package gnutls-devel.i386 0:1.4.1-2 set to be erased
--> Processing Dependency: gnutls-devel for package: libsoup-devel
---> Package hal-devel.i386 0:0.5.8.1-35.el5 set to be erased
--> Processing Dependency: hal-devel >= 0.5.7 for package: gnome-vfs2-devel
---> Package libselinux-devel.i386 0:1.33.4-5.el5 set to be erased
--> Processing Dependency: libselinux-devel for package: rpm-devel
--> Processing Dependency: libselinux-devel for package: krb5-devel
---> Package libsepol-devel.i386 0:1.15.2-1.el5 set to be erased
---> Package nspr-devel.i386 0:4.7.0.99.2-1.el5 set to be erased
---> Package nss-devel.i386 0:3.11.99.5-2.el5 set to be erased
---> Package openldap-devel.i386 0:2.3.27-8.el5_1.3 set to be erased
---> Package ruby-devel.i386 0:1.8.5-5.el5_1.1 set to be erased
---> Package xulrunner-devel.i386 0:1.9-0.beta5.6.el5 set to be erased
--> Running transaction check
---> Package cairo-devel.i386 0:1.2.4-5.el5 set to be erased
--> Processing Dependency: cairo-devel >= 1.2.0-1 for package: gtk2-devel
--> Processing Dependency: cairo-devel for package: pycairo-devel
---> Package fontconfig-devel.i386 0:2.4.1-7.el5 set to be erased
---> Package gd-devel.i386 0:2.0.33-9.4.el5_1.1 set to be erased
---> Package gnome-vfs2-devel.i386 0:2.16.2-6.el5_5.1 set to be erased
--> Processing Dependency: gnome-vfs2-devel >= 2.7.91 for package: eel2-devel
--> Processing Dependency: gnome-vfs2-devel >= 2.5.3 for package: libgnomeui-devel
--> Processing Dependency: gnome-vfs2-devel >= 2.5.3 for package: libgnome-devel
--> Processing Dependency: gnome-vfs2-devel for package: libgsf-devel
--> Processing Dependency: gnome-vfs2-devel >= 2.2.0 for package: gnome-desktop-devel
---> Package krb5-devel.i386 0:1.6.1-36.el5_5.4 set to be erased
--> Processing Dependency: krb5-devel for package: openssl-devel
---> Package libXft-devel.i386 0:2.1.10-1.1 set to be erased
---> Package librsvg2-devel.i386 0:2.16.1-1.el5 set to be erased
---> Package libsoup-devel.i386 0:2.2.98-2.el5 set to be erased
--> Processing Dependency: libsoup-devel for package: evolution-data-server-devel
---> Package pango-devel.i386 0:1.14.9-3.el5 set to be erased
--> Processing Dependency: pango-devel >= 1.5.0 for package: libgnomeprint22-devel
---> Package qt-devel.i386 1:3.3.6-23.el5 set to be erased
--> Processing Dependency: qt-devel >= 1:3.3.6 for package: kdelibs-devel
--> Processing Dependency: qt-devel = 1:3.3.6-23.el5 for package: qt-designer
---> Package rpm-devel.i386 0:4.4.2-48.el5 set to be erased
--> Running transaction check
---> Package eel2-devel.i386 0:2.16.1-1.el5 set to be erased
---> Package evolution-data-server-devel.i386 0:1.12.3-6.el5 set to be erased
---> Package gnome-desktop-devel.i386 0:2.16.0-1.fc6 set to be erased
---> Package gtk2-devel.i386 0:2.10.4-20.el5 set to be erased
--> Processing Dependency: gtk2-devel >= 2.3.0 for package: at-spi-devel
--> Processing Dependency: gtk2-devel >= 2.3.5 for package: gail-devel
--> Processing Dependency: gtk2-devel >= 2.1.2 for package: libgnomecanvas-devel
--> Processing Dependency: gtk2-devel >= 2.5.0 for package: libglade2-devel
--> Processing Dependency: gtk2-devel >= 2.4.0 for package: libgnomeprintui22-devel
--> Processing Dependency: gtk2-devel >= 2.2.0 for package: libbonoboui-devel
--> Processing Dependency: gtk2-devel >= 2.7.1 for package: gnome-panel-devel
---> Package kdelibs-devel.i386 6:3.5.4-16.el5 set to be erased
--> Processing Dependency: kdelibs-devel for package: kdnssd-avahi-devel
--> Processing Dependency: kdelibs-devel for package: kdenetwork-devel
--> Processing Dependency: kdelibs-devel >= 3.5.4 for package: kdebase-devel
--> Processing Dependency: kdelibs-devel >= 6:3.5.4 for package: kdepim-devel
--> Processing Dependency: kdelibs-devel >= 6:3.5.4 for package: kdevelop
---> Package libgnome-devel.i386 0:2.16.0-6.el5 set to be erased
---> Package libgnomeprint22-devel.i386 0:2.12.1-10.el5 set to be erased
---> Package libgnomeui-devel.i386 0:2.16.0-5.el5 set to be erased
--> Processing Dependency: libgnomeui-devel for package: gnome-pilot-devel
--> Processing Dependency: libgnomeui-devel for package: libcroco-devel
---> Package libgsf-devel.i386 0:1.14.1-6.1 set to be erased
---> Package openssl-devel.i386 0:0.9.8b-10.el5 set to be erased
--> Processing Dependency: openssl-devel for package: curl-devel
--> Processing Dependency: openssl-devel >= 0.9.6 for package: xmlsec1-devel
---> Package pycairo-devel.i386 0:1.2.0-1.1 set to be erased
--> Processing Dependency: pycairo-devel for package: pygtk2-devel
---> Package qt-designer.i386 1:3.3.6-23.el5 set to be erased
--> Running transaction check
---> Package at-spi-devel.i386 0:1.7.11-3.el5 set to be erased
---> Package curl-devel.i386 0:7.15.5-2.el5 set to be erased
---> Package gail-devel.i386 0:1.9.2-1.fc6 set to be erased
---> Package gnome-panel-devel.i386 0:2.16.1-7.el5 set to be erased
---> Package gnome-pilot-devel.i386 0:2.0.13-16 set to be erased
---> Package kdebase-devel.i386 6:3.5.4-18.el5 set to be erased
--> Processing Dependency: kdebase-devel for package: kdeutils-devel
---> Package kdenetwork-devel.i386 7:3.5.4-4.fc6 set to be erased
---> Package kdepim-devel.i386 6:3.5.4-4.fc6 set to be erased
---> Package kdevelop.i386 9:3.3.4-1.fc6 set to be erased
---> Package kdnssd-avahi-devel.i386 0:0.1.3-0.1.20060713svn.fc6 set to be erased
---> Package libbonoboui-devel.i386 0:2.16.0-1.fc6 set to be erased
---> Package libcroco-devel.i386 0:0.6.1-2.1 set to be erased
---> Package libglade2-devel.i386 0:2.6.0-2 set to be erased
---> Package libgnomecanvas-devel.i386 0:2.14.0-4.1 set to be erased
---> Package libgnomeprintui22-devel.i386 0:2.12.1-6 set to be erased
---> Package pygtk2-devel.i386 0:2.10.1-12.el5 set to be erased
---> Package xmlsec1-devel.i386 0:1.2.9-8.1 set to be erased
--> Running transaction check
---> Package kdeutils-devel.i386 6:3.5.4-5.fc6 set to be erased
--> Finished Dependency Resolution

Dependencies Resolved

==================================================================================
 Package                      Arch  Version                      Repository  Size
==================================================================================
Removing:
 freetype-devel               i386  2.2.1-19.el5                 installed  890 k
 gnutls-devel                 i386  1.4.1-2                      installed  1.7 M
 hal-devel                    i386  0.5.8.1-35.el5               installed   39 k
 libselinux-devel             i386  1.33.4-5.el5                 installed  275 k
 libsepol-devel               i386  1.15.2-1.el5                 installed  474 k
 nspr-devel                   i386  4.7.0.99.2-1.el5             installed  509 k
 nss-devel                    i386  3.11.99.5-2.el5              installed  994 k
 openldap-devel               i386  2.3.27-8.el5_1.3             installed  5.6 M
 ruby-devel                   i386  1.8.5-5.el5_1.1              installed  1.5 M
 xulrunner-devel              i386  1.9-0.beta5.6.el5            installed   35 M
Removing for dependencies:
 at-spi-devel                 i386  1.7.11-3.el5                 installed  1.4 M
 cairo-devel                  i386  1.2.4-5.el5                  installed  827 k
 curl-devel                   i386  7.15.5-2.el5                 installed  637 k
 eel2-devel                   i386  2.16.1-1.el5                 installed  221 k
 evolution-data-server-devel  i386  1.12.3-6.el5                 installed  1.4 M
 fontconfig-devel             i386  2.4.1-7.el5                  installed  554 k
 gail-devel                   i386  1.9.2-1.fc6                  installed   62 k
 gd-devel                     i386  2.0.33-9.4.el5_1.1           installed  326 k
 gnome-desktop-devel          i386  2.16.0-1.fc6                 installed  173 k
 gnome-panel-devel            i386  2.16.1-7.el5                 installed  170 k
 gnome-pilot-devel            i386  2.0.13-16                    installed  412 k
 gnome-vfs2-devel             i386  2.16.2-6.el5_5.1             installed  2.4 M
 gtk2-devel                   i386  2.10.4-20.el5                installed   17 M
 kdebase-devel                i386  6:3.5.4-18.el5               installed  6.7 M
 kdelibs-devel                i386  6:3.5.4-16.el5               installed  6.6 M
 kdenetwork-devel             i386  7:3.5.4-4.fc6                installed  2.3 M
 kdepim-devel                 i386  6:3.5.4-4.fc6                installed  1.1 M
 kdeutils-devel               i386  6:3.5.4-5.fc6                installed  891 k
 kdevelop                     i386  9:3.3.4-1.fc6                installed   34 M
 kdnssd-avahi-devel           i386  0.1.3-0.1.20060713svn.fc6    installed   27 k
 krb5-devel                   i386  1.6.1-36.el5_5.4             installed  4.3 M
 libXft-devel                 i386  2.1.10-1.1                   installed   23 k
 libbonoboui-devel            i386  2.16.0-1.fc6                 installed  962 k
 libcroco-devel               i386  0.6.1-2.1                    installed  110 k
 libglade2-devel              i386  2.6.0-2                      installed  334 k
 libgnome-devel               i386  2.16.0-6.el5                 installed  429 k
 libgnomecanvas-devel         i386  2.14.0-4.1                   installed  487 k
 libgnomeprint22-devel        i386  2.12.1-10.el5                installed  537 k
 libgnomeprintui22-devel      i386  2.12.1-6                     installed  577 k
 libgnomeui-devel             i386  2.16.0-5.el5                 installed  2.2 M
 libgsf-devel                 i386  1.14.1-6.1                   installed  1.0 M
 librsvg2-devel               i386  2.16.1-1.el5                 installed   96 k
 libsoup-devel                i386  2.2.98-2.el5                 installed  883 k
 openssl-devel                i386  0.9.8b-10.el5                installed  4.3 M
 pango-devel                  i386  1.14.9-3.el5                 installed  1.6 M
 pycairo-devel                i386  1.2.0-1.1                    installed  7.0 k
 pygtk2-devel                 i386  2.10.1-12.el5                installed   10 M
 qt-designer                  i386  1:3.3.6-23.el5               installed  4.7 M
 qt-devel                     i386  1:3.3.6-23.el5               installed   36 M
 rpm-devel                    i386  4.4.2-48.el5                 installed  3.5 M
 xmlsec1-devel                i386  1.2.9-8.1                    installed  3.5 M

Transaction Summary
==================================================================================
Remove       51 Package(s)
Reinstall     0 Package(s)
Downgrade     0 Package(s)

Is this ok [y/N]: Exiting on user Command
Complete!
[root@riw-lw-ito ~]#
Comment 5 seth vidal 2010-06-24 10:43:02 EDT
Here's my suggestion given what I've seen so far:

1. run the yum remove command I suggested before but this time don't put the 'echo n|' at the beginning. So you'd be removing a lot of devel packages and kdevelop.

2. run: package-cleanup --problems again and see if it still lists any problems

3. continue your updating.
Comment 6 Nancy 2010-06-24 10:57:44 EDT
I ran the yum remove without the echo n| and then did the package-cleanup --problems which came back with no problems;  then I ran the yum update and got a bunch of dependency issues;  Here is a copy of that;  Its quite long;
Complete!
[root@riw-lw-ito ~]# package-cleanup -problems
usage: package-cleanup [options]

package-cleanup: error: no such option: -p
[root@riw-lw-ito ~]# package-cleanup --problems
Setting up yum
Reading local RPM database
Processing all local requires
No problems found
[root@riw-lw-ito ~]# yum update
Loaded plugins: rhnplugin, security
Skipping security plugin, no data
Setting up Update Process
Resolving Dependencies
Skipping security plugin, no data
--> Running transaction check
---> Package NetworkManager.i386 1:0.7.0-10.el5 set to be updated
--> Processing Dependency: dnsmasq for package: NetworkManager
---> Package NetworkManager-glib.i386 1:0.7.0-10.el5 set to be updated
---> Package NetworkManager-gnome.i386 1:0.7.0-10.el5 set to be updated
--> Processing Dependency: alsa-lib = 1.0.14 for package: alsa-lib-devel
---> Package alsa-lib.i386 0:1.0.17-1.el5 set to be updated
---> Package autofs.i386 1:5.0.1-0.rc2.143.el5 set to be updated
---> Package cpp.i386 0:4.1.2-48.el5 set to be updated
---> Package curl.i386 0:7.15.5-9.el5 set to be updated
---> Package cyrus-sasl.i386 0:2.1.22-5.el5_4.3 set to be updated
--> Processing Dependency: cyrus-sasl-lib = 2.1.22-4 for package: cyrus-sasl-devel
---> Package cyrus-sasl-lib.i386 0:2.1.22-5.el5_4.3 set to be updated
---> Package cyrus-sasl-md5.i386 0:2.1.22-5.el5_4.3 set to be updated
---> Package cyrus-sasl-plain.i386 0:2.1.22-5.el5_4.3 set to be updated
--> Processing Dependency: db4 = 4.3.29-9.fc6 for package: db4-devel
---> Package db4.i386 0:4.3.29-10.el5 set to be updated
--> Processing Dependency: libdbus-1.so.3 for package: NetworkManager-gnome
--> Processing Dependency: libdbus-1.so.3 for package: evolution
--> Processing Dependency: libdbus-1.so.3 for package: gnome-session
--> Processing Dependency: libdbus-1.so.3 for package: oddjob-libs
--> Processing Dependency: libdbus-1.so.3 for package: oddjob
--> Processing Dependency: libdbus-1.so.3 for package: totem
--> Processing Dependency: libdbus-1.so.3 for package: hal-cups-utils
--> Processing Dependency: libdbus-1.so.3 for package: gnome-panel
--> Processing Dependency: libdbus-1.so.3 for package: bluez-utils
--> Processing Dependency: libdbus-1.so.3 for package: kdebase
--> Processing Dependency: libdbus-1.so.3 for package: gnome-mount
--> Processing Dependency: libdbus-1.so.3 for package: gnome-utils
--> Processing Dependency: libdbus-1.so.3 for package: libnotify
--> Processing Dependency: libdbus-1.so.3 for package: nautilus-cd-burner
--> Processing Dependency: libdbus-1.so.3 for package: control-center
--> Processing Dependency: libdbus-1.so.3 for package: dbus
--> Processing Dependency: libdbus-1.so.3 for package: bluez-gnome
--> Processing Dependency: libdbus-1.so.3 for package: dhcdbd
--> Processing Dependency: libdbus-1.so.3 for package: notify-python
--> Processing Dependency: libdbus-1.so.3 for package: cups
--> Processing Dependency: libdbus-1.so.3 for package: dbus-glib
--> Processing Dependency: libdbus-1.so.3 for package: gnome-volume-manager
--> Processing Dependency: libdbus-1.so.3 for package: notification-daemon
--> Processing Dependency: libdbus-1.so.3 for package: pidgin
--> Processing Dependency: libdbus-1.so.3 for package: wpa_supplicant
--> Processing Dependency: libdbus-1.so.3 for package: yelp
--> Processing Dependency: libdbus-1.so.3 for package: evince
--> Processing Dependency: libdbus-1.so.3 for package: gnome-screensaver
--> Processing Dependency: libdbus-1.so.3 for package: sound-juicer
--> Processing Dependency: libdbus-1.so.3 for package: NetworkManager-glib
--> Processing Dependency: libdbus-1.so.3 for package: xulrunner
--> Processing Dependency: libdbus-1.so.3 for package: dbus-devel
--> Processing Dependency: libdbus-1.so.3 for package: libgnomecups
--> Processing Dependency: libdbus-1.so.3 for package: hal
--> Processing Dependency: libdbus-1.so.3 for package: NetworkManager
--> Processing Dependency: libdbus-1.so.3 for package: gstreamer-plugins-good
--> Processing Dependency: libdbus-1.so.3 for package: krb5-auth-dialog
--> Processing Dependency: libdbus-1.so.3 for package: totem-mozplugin
--> Processing Dependency: libdbus-1.so.3 for package: gnome-applets
--> Processing Dependency: libdbus-1.so.3 for package: rhythmbox
--> Processing Dependency: libdbus-1.so.3 for package: desktop-printing
--> Processing Dependency: libdbus-1.so.3 for package: libpurple
--> Processing Dependency: libdbus-1.so.3 for package: avahi
--> Processing Dependency: libdbus-1.so.3 for package: gnome-media
--> Processing Dependency: libdbus-1.so.3 for package: dbus-python
--> Processing Dependency: libdbus-1.so.3 for package: gnome-power-manager
--> Processing Dependency: libdbus-1.so.3 for package: openoffice.org-core
--> Processing Dependency: libdbus-1.so.3 for package: gnome-vfs2
--> Processing Dependency: dbus = 1.0.0-7.el5 for package: dbus-devel
---> Package dbus.i386 0:1.1.2-14.el5 set to be updated
--> Processing Dependency: dbus-glib = 0.70-5 for package: dbus-glib-devel
---> Package dbus-glib.i386 0:0.73-8.el5 set to be updated
---> Package dbus-x11.i386 0:1.1.2-14.el5 set to be updated
---> Package devhelp.i386 0:0.12-21.el5 set to be updated
---> Package e2fsprogs.i386 0:1.39-23.el5 set to be updated
--> Processing Dependency: e2fsprogs-libs = 1.39-15.el5 for package: e2fsprogs-devel
---> Package e2fsprogs-libs.i386 0:1.39-23.el5 set to be updated
--> Processing Dependency: elfutils-libelf = 0.125-3.el5 for package: elfutils-libelf-devel
--> Processing Dependency: elfutils-libelf = 0.125-3.el5 for package: elfutils
---> Package elfutils-libelf.i386 0:0.137-3.el5 set to be updated
--> Processing Dependency: elfutils-libs = 0.125-3.el5 for package: elfutils
---> Package elfutils-libs.i386 0:0.137-3.el5 set to be updated
---> Package esc.i386 0:1.1.0-12.el5 set to be updated
---> Package evolution-data-server.i386 0:1.12.3-18.el5 set to be updated
--> Processing Dependency: expat = 1.95.8-8.2.1 for package: expat-devel
---> Package expat.i386 0:1.95.8-8.3.el5_4.2 set to be updated
---> Package firefox.i386 0:3.6.4-8.el5 set to be updated
--> Processing Dependency: gcc = 4.1.2-42.el5 for package: gcc-gfortran
--> Processing Dependency: gcc = 4.1.2-42.el5 for package: gcc-java
--> Processing Dependency: gcc = 4.1.2-42.el5 for package: gcc-c++
---> Package gcc.i386 0:4.1.2-48.el5 set to be updated
---> Package gd.i386 0:2.0.33-9.4.el5_4.2 set to be updated
--> Processing Dependency: glib2 = 2.12.3-2.fc6 for package: glib2-devel
---> Package glib2.i386 0:2.12.3-4.el5_3.1 set to be updated
---> Package gnome-python2-extras.i386 0:2.14.2-7.el5 set to be updated
---> Package gnome-python2-gtkhtml2.i386 0:2.14.2-7.el5 set to be updated
---> Package gnome-python2-libegg.i386 0:2.14.2-7.el5 set to be updated
--> Processing Dependency: httpd = 2.2.3-11.el5_1.3 for package: httpd-manual
---> Package httpd.i386 0:2.2.3-43.el5 set to be updated
---> Package kdebase.i386 6:3.5.4-21.el5_5.1 set to be updated
--> Processing Dependency: kdegraphics = 7:3.5.4-6.el5 for package: kdegraphics-devel
---> Package kdegraphics.i386 7:3.5.4-15.el5_4.2 set to be updated
---> Package kdelibs.i386 6:3.5.4-25.el5_4.1 set to be updated
---> Package kdenetwork.i386 7:3.5.4-9.el5 set to be updated
---> Package kdepim.i386 6:3.5.4-6.el5 set to be updated
--> Processing Dependency: libX11 = 1.0.3-9.el5 for package: libX11-devel
---> Package libX11.i386 0:1.0.3-11.el5 set to be updated
--> Processing Dependency: libXi = 1.0.1-3.1 for package: libXi-devel
---> Package libXi.i386 0:1.0.1-4.el5_4 set to be updated
--> Processing Dependency: libXrandr = 1.1.1-3.1 for package: libXrandr-devel
---> Package libXrandr.i386 0:1.1.1-3.3 set to be updated
--> Processing Dependency: libXt = 1.0.2-3.1.fc6 for package: libXt-devel
---> Package libXt.i386 0:1.0.2-3.2.el5 set to be updated
--> Processing Dependency: libgcj = 4.1.2-42.el5 for package: libgcj-src
--> Processing Dependency: libgcj = 4.1.2-42.el5 for package: gcc-java
--> Processing Dependency: libgcj = 4.1.2-42.el5 for package: libgcj-devel
---> Package libgcj.i386 0:4.1.2-48.el5 set to be updated
--> Processing Dependency: libgcrypt = 1.2.3-1 for package: libgcrypt-devel
---> Package libgcrypt.i386 0:1.4.4-5.el5 set to be updated
--> Processing Dependency: libgfortran = 4.1.2-42.el5 for package: gcc-gfortran
---> Package libgfortran.i386 0:4.1.2-48.el5 set to be updated
---> Package libgomp.i386 0:4.4.0-6.el5 set to be updated
--> Processing Dependency: libpng = 2:1.2.10-7.1.el5_0.1 for package: libpng-devel
---> Package libpng.i386 2:1.2.10-7.1.el5_3.2 set to be updated
--> Processing Dependency: libstdc++ = 4.1.2-42.el5 for package: gcc-c++
--> Processing Dependency: libstdc++ = 4.1.2-42.el5 for package: libstdc++-devel
---> Package libstdc++.i386 0:4.1.2-48.el5 set to be updated
--> Processing Dependency: libtiff = 3.8.2-7.el5 for package: libtiff-devel
---> Package libtiff.i386 0:3.8.2-7.el5_3.4 set to be updated
--> Processing Dependency: libuser = 0.54.7-2.el5.5 for package: libuser-devel
---> Package libuser.i386 0:0.54.7-2.1.el5_4.1 set to be updated
--> Processing Dependency: mesa-libGL = 6.5.1-7.5.el5 for package: mesa-libGL-devel
---> Package mesa-libGL.i386 0:6.5.1-7.8.el5 set to be updated
--> Processing Dependency: mesa-libGLU = 6.5.1-7.5.el5 for package: mesa-libGLU-devel
---> Package mesa-libGLU.i386 0:6.5.1-7.8.el5 set to be updated
---> Package mod_ssl.i386 1:2.2.3-43.el5 set to be updated
--> Processing Dependency: netpbm = 10.35-6.fc6 for package: netpbm-devel
---> Package netpbm.i386 0:10.35.58-8.el5 set to be updated
---> Package netpbm-progs.i386 0:10.35.58-8.el5 set to be updated
---> Package openssh.i386 0:4.3p2-41.el5 set to be updated
---> Package openssh-askpass.i386 0:4.3p2-41.el5 set to be updated
---> Package openssh-clients.i386 0:4.3p2-41.el5 set to be updated
---> Package openssh-server.i386 0:4.3p2-41.el5 set to be updated
---> Package openssl.i686 0:0.9.8e-12.el5_4.6 set to be updated
--> Processing Dependency: pam = 0.99.6.2-3.27.el5 for package: pam-devel
---> Package pam.i386 0:0.99.6.2-6.el5_4.1 set to be updated
--> Processing Dependency: pcsc-lite-libs = 1.4.4-0.1.el5 for package: pcsc-lite-devel
---> Package pcsc-lite-libs.i386 0:1.4.4-1.el5 set to be updated
---> Package popt.i386 0:1.10.2.3-18.el5 set to be updated
--> Processing Dependency: python = 2.4.3-21.el5 for package: python-devel
---> Package python.i386 0:2.4.3-27.el5 set to be updated
--> Processing Dependency: rpm = 4.4.2-48.el5 for package: rpm-build
---> Package rpm.i386 0:4.4.2.3-18.el5 set to be updated
---> Package rpm-libs.i386 0:4.4.2.3-18.el5 set to be updated
---> Package rpm-python.i386 0:4.4.2.3-18.el5 set to be updated
--> Processing Dependency: sabayon-apply = 2.12.4-5.el5 for package: sabayon
---> Package sabayon-apply.i386 0:2.12.4-6.el5 set to be updated
---> Package samba-client.i386 0:3.0.33-3.29.el5_5 set to be updated
--> Processing Dependency: libsmbclient.so.0 for package: gnome-vfs2-smb
--> Processing Dependency: libsmbclient.so.0 for package: kdebase
---> Package samba-common.i386 0:3.0.33-3.29.el5_5 set to be updated
--> Processing Dependency: sqlite = 3.3.6-2 for package: sqlite-devel
---> Package sqlite.i386 0:3.3.6-5 set to be updated
--> Processing Dependency: tomcat5-jsp-2.0-api = 5.5.23-0jpp.7.el5 for package: tomcat5-common-lib
--> Processing Dependency: tomcat5-jsp-2.0-api = 5.5.23-0jpp.7.el5 for package: tomcat5-common-lib
---> Package tomcat5-jsp-2.0-api.i386 0:5.5.23-0jpp.7.el5_3.2 set to be updated
--> Processing Dependency: tomcat5-servlet-2.4-api = 5.5.23-0jpp.7.el5 for package: tomcat5-jasper
--> Processing Dependency: tomcat5-servlet-2.4-api = 5.5.23-0jpp.7.el5 for package: tomcat5-common-lib
--> Processing Dependency: tomcat5-servlet-2.4-api = 5.5.23-0jpp.7.el5 for package: tomcat5-common-lib
---> Package tomcat5-servlet-2.4-api.i386 0:5.5.23-0jpp.7.el5_3.2 set to be updated
---> Package totem.i386 0:2.16.7-7.el5 set to be updated
---> Package totem-mozplugin.i386 0:2.16.7-7.el5 set to be updated
---> Package xulrunner.i386 0:1.9.2.4-9.el5 set to be updated
---> Package yelp.i386 0:2.16.0-26.el5 set to be updated
--> Running transaction check
--> Processing Dependency: alsa-lib = 1.0.14 for package: alsa-lib-devel
--> Processing Dependency: cyrus-sasl-lib = 2.1.22-4 for package: cyrus-sasl-devel
--> Processing Dependency: db4 = 4.3.29-9.fc6 for package: db4-devel
--> Processing Dependency: dbus = 1.0.0-7.el5 for package: dbus-devel
--> Processing Dependency: dbus-glib = 0.70-5 for package: dbus-glib-devel
---> Package dbus-libs.i386 0:1.1.2-14.el5 set to be updated
---> Package dnsmasq.i386 0:2.45-1.1.el5_3 set to be updated
--> Processing Dependency: e2fsprogs-libs = 1.39-15.el5 for package: e2fsprogs-devel
--> Processing Dependency: elfutils-libelf = 0.125-3.el5 for package: elfutils-libelf-devel
--> Processing Dependency: elfutils-libelf = 0.125-3.el5 for package: elfutils
--> Processing Dependency: elfutils-libs = 0.125-3.el5 for package: elfutils
--> Processing Dependency: expat = 1.95.8-8.2.1 for package: expat-devel
--> Processing Dependency: gcc = 4.1.2-42.el5 for package: gcc-gfortran
--> Processing Dependency: gcc = 4.1.2-42.el5 for package: gcc-java
--> Processing Dependency: gcc = 4.1.2-42.el5 for package: gcc-c++
--> Processing Dependency: glib2 = 2.12.3-2.fc6 for package: glib2-devel
--> Processing Dependency: httpd = 2.2.3-11.el5_1.3 for package: httpd-manual
--> Processing Dependency: kdegraphics = 7:3.5.4-6.el5 for package: kdegraphics-devel
--> Processing Dependency: libX11 = 1.0.3-9.el5 for package: libX11-devel
--> Processing Dependency: libXi = 1.0.1-3.1 for package: libXi-devel
--> Processing Dependency: libXrandr = 1.1.1-3.1 for package: libXrandr-devel
--> Processing Dependency: libXt = 1.0.2-3.1.fc6 for package: libXt-devel
--> Processing Dependency: libgcj = 4.1.2-42.el5 for package: libgcj-src
--> Processing Dependency: libgcj = 4.1.2-42.el5 for package: gcc-java
--> Processing Dependency: libgcj = 4.1.2-42.el5 for package: libgcj-devel
--> Processing Dependency: libgcrypt = 1.2.3-1 for package: libgcrypt-devel
--> Processing Dependency: libgfortran = 4.1.2-42.el5 for package: gcc-gfortran
--> Processing Dependency: libpng = 2:1.2.10-7.1.el5_0.1 for package: libpng-devel
---> Package libsmbclient.i386 0:3.0.33-3.29.el5_5 set to be updated
--> Processing Dependency: libstdc++ = 4.1.2-42.el5 for package: gcc-c++
--> Processing Dependency: libstdc++ = 4.1.2-42.el5 for package: libstdc++-devel
--> Processing Dependency: libtiff = 3.8.2-7.el5 for package: libtiff-devel
--> Processing Dependency: libuser = 0.54.7-2.el5.5 for package: libuser-devel
--> Processing Dependency: mesa-libGL = 6.5.1-7.5.el5 for package: mesa-libGL-devel
--> Processing Dependency: mesa-libGLU = 6.5.1-7.5.el5 for package: mesa-libGLU-devel
--> Processing Dependency: netpbm = 10.35-6.fc6 for package: netpbm-devel
--> Processing Dependency: pam = 0.99.6.2-3.27.el5 for package: pam-devel
--> Processing Dependency: pcsc-lite-libs = 1.4.4-0.1.el5 for package: pcsc-lite-devel
--> Processing Dependency: python = 2.4.3-21.el5 for package: python-devel
--> Processing Dependency: rpm = 4.4.2-48.el5 for package: rpm-build
--> Processing Dependency: sabayon-apply = 2.12.4-5.el5 for package: sabayon
--> Processing Dependency: sqlite = 3.3.6-2 for package: sqlite-devel
--> Processing Dependency: tomcat5-jsp-2.0-api = 5.5.23-0jpp.7.el5 for package: tomcat5-common-lib
--> Processing Dependency: tomcat5-jsp-2.0-api = 5.5.23-0jpp.7.el5 for package: tomcat5-common-lib
--> Processing Dependency: tomcat5-servlet-2.4-api = 5.5.23-0jpp.7.el5 for package: tomcat5-jasper
--> Processing Dependency: tomcat5-servlet-2.4-api = 5.5.23-0jpp.7.el5 for package: tomcat5-common-lib
--> Processing Dependency: tomcat5-servlet-2.4-api = 5.5.23-0jpp.7.el5 for package: tomcat5-common-lib
--> Finished Dependency Resolution
libgcrypt-devel-1.2.3-1.i386 from installed has depsolving problems
  --> Missing Dependency: libgcrypt = 1.2.3-1 is needed by package libgcrypt-devel-1.2.3-1.i386 (installed)
e2fsprogs-devel-1.39-15.el5.i386 from installed has depsolving problems
  --> Missing Dependency: e2fsprogs-libs = 1.39-15.el5 is needed by package e2fsprogs-devel-1.39-15.el5.i386 (installed)
tomcat5-jasper-5.5.23-0jpp.7.el5.i386 from installed has depsolving problems
  --> Missing Dependency: tomcat5-servlet-2.4-api = 5.5.23-0jpp.7.el5 is needed by package tomcat5-jasper-5.5.23-0jpp.7.el5.i386 (installed)
libuser-devel-0.54.7-2.el5.5.i386 from installed has depsolving problems
  --> Missing Dependency: libuser = 0.54.7-2.el5.5 is needed by package libuser-devel-0.54.7-2.el5.5.i386 (installed)
libgcj-src-4.1.2-42.el5.i386 from installed has depsolving problems
  --> Missing Dependency: libgcj = 4.1.2-42.el5 is needed by package libgcj-src-4.1.2-42.el5.i386 (installed)
gcc-c++-4.1.2-42.el5.i386 from installed has depsolving problems
  --> Missing Dependency: libstdc++ = 4.1.2-42.el5 is needed by package gcc-c++-4.1.2-42.el5.i386 (installed)
2:libpng-devel-1.2.10-7.1.el5_0.1.i386 from installed has depsolving problems
  --> Missing Dependency: libpng = 2:1.2.10-7.1.el5_0.1 is needed by package 2:libpng-devel-1.2.10-7.1.el5_0.1.i386 (installed)
elfutils-0.125-3.el5.i386 from installed has depsolving problems
  --> Missing Dependency: elfutils-libs = 0.125-3.el5 is needed by package elfutils-0.125-3.el5.i386 (installed)
pam-devel-0.99.6.2-3.27.el5.i386 from installed has depsolving problems
  --> Missing Dependency: pam = 0.99.6.2-3.27.el5 is needed by package pam-devel-0.99.6.2-3.27.el5.i386 (installed)
libstdc++-devel-4.1.2-42.el5.i386 from installed has depsolving problems
  --> Missing Dependency: libstdc++ = 4.1.2-42.el5 is needed by package libstdc++-devel-4.1.2-42.el5.i386 (installed)
mesa-libGL-devel-6.5.1-7.5.el5.i386 from installed has depsolving problems
  --> Missing Dependency: mesa-libGL = 6.5.1-7.5.el5 is needed by package mesa-libGL-devel-6.5.1-7.5.el5.i386 (installed)
libXt-devel-1.0.2-3.1.fc6.i386 from installed has depsolving problems
  --> Missing Dependency: libXt = 1.0.2-3.1.fc6 is needed by package libXt-devel-1.0.2-3.1.fc6.i386 (installed)
7:kdegraphics-devel-3.5.4-6.el5.i386 from installed has depsolving problems
  --> Missing Dependency: kdegraphics = 7:3.5.4-6.el5 is needed by package 7:kdegraphics-devel-3.5.4-6.el5.i386 (installed)
libXrandr-devel-1.1.1-3.1.i386 from installed has depsolving problems
  --> Missing Dependency: libXrandr = 1.1.1-3.1 is needed by package libXrandr-devel-1.1.1-3.1.i386 (installed)
gcc-gfortran-4.1.2-42.el5.i386 from installed has depsolving problems
  --> Missing Dependency: gcc = 4.1.2-42.el5 is needed by package gcc-gfortran-4.1.2-42.el5.i386 (installed)
sqlite-devel-3.3.6-2.i386 from installed has depsolving problems
  --> Missing Dependency: sqlite = 3.3.6-2 is needed by package sqlite-devel-3.3.6-2.i386 (installed)
tomcat5-common-lib-5.5.23-0jpp.7.el5.i386 from installed has depsolving problems
  --> Missing Dependency: tomcat5-jsp-2.0-api = 5.5.23-0jpp.7.el5 is needed by package tomcat5-common-lib-5.5.23-0jpp.7.el5.i386 (installed)
cyrus-sasl-devel-2.1.22-4.i386 from installed has depsolving problems
  --> Missing Dependency: cyrus-sasl-lib = 2.1.22-4 is needed by package cyrus-sasl-devel-2.1.22-4.i386 (installed)
gcc-java-4.1.2-42.el5.i386 from installed has depsolving problems
  --> Missing Dependency: libgcj = 4.1.2-42.el5 is needed by package gcc-java-4.1.2-42.el5.i386 (installed)
mesa-libGLU-devel-6.5.1-7.5.el5.i386 from installed has depsolving problems
  --> Missing Dependency: mesa-libGLU = 6.5.1-7.5.el5 is needed by package mesa-libGLU-devel-6.5.1-7.5.el5.i386 (installed)
dbus-glib-devel-0.70-5.i386 from installed has depsolving problems
  --> Missing Dependency: dbus-glib = 0.70-5 is needed by package dbus-glib-devel-0.70-5.i386 (installed)
rpm-build-4.4.2-48.el5.i386 from installed has depsolving problems
  --> Missing Dependency: rpm = 4.4.2-48.el5 is needed by package rpm-build-4.4.2-48.el5.i386 (installed)
db4-devel-4.3.29-9.fc6.i386 from installed has depsolving problems
  --> Missing Dependency: db4 = 4.3.29-9.fc6 is needed by package db4-devel-4.3.29-9.fc6.i386 (installed)
sabayon-2.12.4-5.el5.i386 from installed has depsolving problems
  --> Missing Dependency: sabayon-apply = 2.12.4-5.el5 is needed by package sabayon-2.12.4-5.el5.i386 (installed)
netpbm-devel-10.35-6.fc6.i386 from installed has depsolving problems
  --> Missing Dependency: netpbm = 10.35-6.fc6 is needed by package netpbm-devel-10.35-6.fc6.i386 (installed)
pcsc-lite-devel-1.4.4-0.1.el5.i386 from installed has depsolving problems
  --> Missing Dependency: pcsc-lite-libs = 1.4.4-0.1.el5 is needed by package pcsc-lite-devel-1.4.4-0.1.el5.i386 (installed)
gcc-gfortran-4.1.2-42.el5.i386 from installed has depsolving problems
  --> Missing Dependency: libgfortran = 4.1.2-42.el5 is needed by package gcc-gfortran-4.1.2-42.el5.i386 (installed)
elfutils-libelf-devel-0.125-3.el5.i386 from installed has depsolving problems
  --> Missing Dependency: elfutils-libelf = 0.125-3.el5 is needed by package elfutils-libelf-devel-0.125-3.el5.i386 (installed)
libgcj-devel-4.1.2-42.el5.i386 from installed has depsolving problems
  --> Missing Dependency: libgcj = 4.1.2-42.el5 is needed by package libgcj-devel-4.1.2-42.el5.i386 (installed)
python-devel-2.4.3-21.el5.i386 from installed has depsolving problems
  --> Missing Dependency: python = 2.4.3-21.el5 is needed by package python-devel-2.4.3-21.el5.i386 (installed)
libtiff-devel-3.8.2-7.el5.i386 from installed has depsolving problems
  --> Missing Dependency: libtiff = 3.8.2-7.el5 is needed by package libtiff-devel-3.8.2-7.el5.i386 (installed)
dbus-devel-1.0.0-7.el5.i386 from installed has depsolving problems
  --> Missing Dependency: dbus = 1.0.0-7.el5 is needed by package dbus-devel-1.0.0-7.el5.i386 (installed)
httpd-manual-2.2.3-11.el5_1.3.i386 from installed has depsolving problems
  --> Missing Dependency: httpd = 2.2.3-11.el5_1.3 is needed by package httpd-manual-2.2.3-11.el5_1.3.i386 (installed)
tomcat5-common-lib-5.5.23-0jpp.7.el5.i386 from installed has depsolving problems
  --> Missing Dependency: tomcat5-servlet-2.4-api = 5.5.23-0jpp.7.el5 is needed by package tomcat5-common-lib-5.5.23-0jpp.7.el5.i386 (installed)
elfutils-0.125-3.el5.i386 from installed has depsolving problems
  --> Missing Dependency: elfutils-libelf = 0.125-3.el5 is needed by package elfutils-0.125-3.el5.i386 (installed)
gcc-c++-4.1.2-42.el5.i386 from installed has depsolving problems
  --> Missing Dependency: gcc = 4.1.2-42.el5 is needed by package gcc-c++-4.1.2-42.el5.i386 (installed)
glib2-devel-2.12.3-2.fc6.i386 from installed has depsolving problems
  --> Missing Dependency: glib2 = 2.12.3-2.fc6 is needed by package glib2-devel-2.12.3-2.fc6.i386 (installed)
libXi-devel-1.0.1-3.1.i386 from installed has depsolving problems
  --> Missing Dependency: libXi = 1.0.1-3.1 is needed by package libXi-devel-1.0.1-3.1.i386 (installed)
alsa-lib-devel-1.0.14-1.rc4.el5.i386 from installed has depsolving problems
  --> Missing Dependency: alsa-lib = 1.0.14 is needed by package alsa-lib-devel-1.0.14-1.rc4.el5.i386 (installed)
libX11-devel-1.0.3-9.el5.i386 from installed has depsolving problems
  --> Missing Dependency: libX11 = 1.0.3-9.el5 is needed by package libX11-devel-1.0.3-9.el5.i386 (installed)
expat-devel-1.95.8-8.2.1.i386 from installed has depsolving problems
  --> Missing Dependency: expat = 1.95.8-8.2.1 is needed by package expat-devel-1.95.8-8.2.1.i386 (installed)
gcc-java-4.1.2-42.el5.i386 from installed has depsolving problems
  --> Missing Dependency: gcc = 4.1.2-42.el5 is needed by package gcc-java-4.1.2-42.el5.i386 (installed)
Error: Missing Dependency: glib2 = 2.12.3-2.fc6 is needed by package glib2-devel-2.12.3-2.fc6.i386 (installed)
Error: Missing Dependency: db4 = 4.3.29-9.fc6 is needed by package db4-devel-4.3.29-9.fc6.i386 (installed)
Error: Missing Dependency: netpbm = 10.35-6.fc6 is needed by package netpbm-devel-10.35-6.fc6.i386 (installed)
Error: Missing Dependency: pam = 0.99.6.2-3.27.el5 is needed by package pam-devel-0.99.6.2-3.27.el5.i386 (installed)
Error: Missing Dependency: libgcrypt = 1.2.3-1 is needed by package libgcrypt-devel-1.2.3-1.i386 (installed)
Error: Missing Dependency: expat = 1.95.8-8.2.1 is needed by package expat-devel-1.95.8-8.2.1.i386 (installed)
Error: Missing Dependency: libXt = 1.0.2-3.1.fc6 is needed by package libXt-devel-1.0.2-3.1.fc6.i386 (installed)
Error: Missing Dependency: libgcj = 4.1.2-42.el5 is needed by package gcc-java-4.1.2-42.el5.i386 (installed)
Error: Missing Dependency: python = 2.4.3-21.el5 is needed by package python-devel-2.4.3-21.el5.i386 (installed)
Error: Missing Dependency: libXrandr = 1.1.1-3.1 is needed by package libXrandr-devel-1.1.1-3.1.i386 (installed)
Error: Missing Dependency: tomcat5-jsp-2.0-api = 5.5.23-0jpp.7.el5 is needed by package tomcat5-common-lib-5.5.23-0jpp.7.el5.i386 (installed)
Error: Missing Dependency: sabayon-apply = 2.12.4-5.el5 is needed by package sabayon-2.12.4-5.el5.i386 (installed)
Error: Missing Dependency: alsa-lib = 1.0.14 is needed by package alsa-lib-devel-1.0.14-1.rc4.el5.i386 (installed)
Error: Missing Dependency: libpng = 2:1.2.10-7.1.el5_0.1 is needed by package 2:libpng-devel-1.2.10-7.1.el5_0.1.i386 (installed)
Error: Missing Dependency: libstdc++ = 4.1.2-42.el5 is needed by package gcc-c++-4.1.2-42.el5.i386 (installed)
Error: Missing Dependency: libuser = 0.54.7-2.el5.5 is needed by package libuser-devel-0.54.7-2.el5.5.i386 (installed)
Error: Missing Dependency: libgcj = 4.1.2-42.el5 is needed by package libgcj-devel-4.1.2-42.el5.i386 (installed)
Error: Missing Dependency: rpm = 4.4.2-48.el5 is needed by package rpm-build-4.4.2-48.el5.i386 (installed)
Error: Missing Dependency: elfutils-libelf = 0.125-3.el5 is needed by package elfutils-libelf-devel-0.125-3.el5.i386 (installed)
Error: Missing Dependency: tomcat5-servlet-2.4-api = 5.5.23-0jpp.7.el5 is needed by package tomcat5-jasper-5.5.23-0jpp.7.el5.i386 (installed)
Error: Missing Dependency: elfutils-libelf = 0.125-3.el5 is needed by package elfutils-0.125-3.el5.i386 (installed)
Error: Missing Dependency: libXi = 1.0.1-3.1 is needed by package libXi-devel-1.0.1-3.1.i386 (installed)
Error: Missing Dependency: libgfortran = 4.1.2-42.el5 is needed by package gcc-gfortran-4.1.2-42.el5.i386 (installed)
Error: Missing Dependency: libstdc++ = 4.1.2-42.el5 is needed by package libstdc++-devel-4.1.2-42.el5.i386 (installed)
Error: Missing Dependency: tomcat5-servlet-2.4-api = 5.5.23-0jpp.7.el5 is needed by package tomcat5-common-lib-5.5.23-0jpp.7.el5.i386 (installed)
Error: Missing Dependency: libtiff = 3.8.2-7.el5 is needed by package libtiff-devel-3.8.2-7.el5.i386 (installed)
Error: Missing Dependency: gcc = 4.1.2-42.el5 is needed by package gcc-c++-4.1.2-42.el5.i386 (installed)
Error: Missing Dependency: gcc = 4.1.2-42.el5 is needed by package gcc-gfortran-4.1.2-42.el5.i386 (installed)
Error: Missing Dependency: libX11 = 1.0.3-9.el5 is needed by package libX11-devel-1.0.3-9.el5.i386 (installed)
Error: Missing Dependency: elfutils-libs = 0.125-3.el5 is needed by package elfutils-0.125-3.el5.i386 (installed)
Error: Missing Dependency: e2fsprogs-libs = 1.39-15.el5 is needed by package e2fsprogs-devel-1.39-15.el5.i386 (installed)
Error: Missing Dependency: dbus = 1.0.0-7.el5 is needed by package dbus-devel-1.0.0-7.el5.i386 (installed)
Error: Missing Dependency: dbus-glib = 0.70-5 is needed by package dbus-glib-devel-0.70-5.i386 (installed)
Error: Missing Dependency: gcc = 4.1.2-42.el5 is needed by package gcc-java-4.1.2-42.el5.i386 (installed)
Error: Missing Dependency: sqlite = 3.3.6-2 is needed by package sqlite-devel-3.3.6-2.i386 (installed)
Error: Missing Dependency: kdegraphics = 7:3.5.4-6.el5 is needed by package 7:kdegraphics-devel-3.5.4-6.el5.i386 (installed)
Error: Missing Dependency: cyrus-sasl-lib = 2.1.22-4 is needed by package cyrus-sasl-devel-2.1.22-4.i386 (installed)
Error: Missing Dependency: mesa-libGL = 6.5.1-7.5.el5 is needed by package mesa-libGL-devel-6.5.1-7.5.el5.i386 (installed)
Error: Missing Dependency: httpd = 2.2.3-11.el5_1.3 is needed by package httpd-manual-2.2.3-11.el5_1.3.i386 (installed)
Error: Missing Dependency: mesa-libGLU = 6.5.1-7.5.el5 is needed by package mesa-libGLU-devel-6.5.1-7.5.el5.i386 (installed)
Error: Missing Dependency: pcsc-lite-libs = 1.4.4-0.1.el5 is needed by package pcsc-lite-devel-1.4.4-0.1.el5.i386 (installed)
Error: Missing Dependency: libgcj = 4.1.2-42.el5 is needed by package libgcj-src-4.1.2-42.el5.i386 (installed)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
[root@riw-lw-ito ~]#
Comment 7 Nancy 2010-06-24 11:04:17 EDT
I selected all of the errata on RHN and am doing a rhn_check -v now.  It has processed a few of the 97 and some have failed; it is still in the process so hopefully it will get some of those errata updated.  I will post how many are left when it is complete.
Comment 8 seth vidal 2010-06-24 11:06:13 EDT
okay a couple of more things to run:

rpm -Va --nofiles --nodigest

also - could you attach your /etc/yum.conf file to this bug?
Comment 9 James Antill 2010-06-24 11:09:22 EDT
Also, can you run:

yum repolist
Comment 10 Nancy 2010-06-24 11:16:07 EDT
Created attachment 426612 [details]
yum.conf

yum.conf
Comment 11 Nancy 2010-06-24 11:22:41 EDT
my rhn_check -v did not finish I received this;
Error code: -49
Error Message:
    Abuse of Service detected for server riw-lw-ito (1017864710)
Error Class Code: 49
Error Class Info: 
     You are getting this error because RHN has detected an abuse of
     service from this system and account. This error is triggered when
     your system makes too many connections to Red Hat Network. This
     error can not be triggered under a normal use of the Red Hat Network
     service as configured by default on Red Hat Linux.

     The Red Hat Network services for this system will remain disabled
     until you will reduce the RHN network traffic from your system to
     acceptable limits.

     Please log into RHN and visit https://rhn.redhat.com/help/contact.pxt
     to contact technical support if you think you have received this
     message in error.

[root@riw-lw-ito ~]# 

When I run the repolist I now get this;
[root@riw-lw-ito ~]# yum repolist
Loaded plugins: rhnplugin, security
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in ?
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 309, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 157, in main
    base.getOptionsConfig(args)
  File "/usr/share/yum-cli/cli.py", line 187, in getOptionsConfig
    self.conf
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 664, in <lambda>
    conf = property(fget=lambda self: self._getConfig(),
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 253, in _getConfig
    self.plugins.run('init')
  File "/usr/lib/python2.4/site-packages/yum/plugins.py", line 179, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/yum-plugins/rhnplugin.py", line 127, in init_hook
    svrChannels = rhnChannel.getChannelDetails()
  File "/usr/share/rhn/up2date_client/rhnChannel.py", line 86, in getChannelDetails
    sourceChannels = getChannels()
  File "/usr/share/rhn/up2date_client/rhnChannel.py", line 112, in getChannels
    up2dateChannels = s.up2date.listChannels(up2dateAuth.getSystemId())
  File "/usr/share/rhn/up2date_client/rhnserver.py", line 52, in __call__
    raise self.__exception_from_fault(f)
up2date_client.up2dateErrors.AbuseError: 
Error Message:
    Abuse of Service detected for server riw-lw-ito (1017864710)
Error Class Code: 49
Error Class Info: 
     You are getting this error because RHN has detected an abuse of
     service from this system and account. This error is triggered when
     your system makes too many connections to Red Hat Network. This
     error can not be triggered under a normal use of the Red Hat Network
     service as configured by default on Red Hat Linux.

     The Red Hat Network services for this system will remain disabled
     until you will reduce the RHN network traffic from your system to
     acceptable limits.

     Please log into RHN and visit https://rhn.redhat.com/help/contact.pxt
     to contact technical support if you think you have received this
     message in error.

[root@riw-lw-ito ~]#
Comment 12 Nancy 2010-06-24 13:50:39 EDT
I guess there is a limit to how many times one can access rhn anyways off the subject with a different error that I got fixed and am now coming back and working on my errata and package problems
To let you know what I did to fix this

deleted my system tried to do rhn_register  got errors 
 rhn_register Traceback (most recent call last):   File "/usr/sbin/rhn_register", line 32, in ?     from up2date_client import tui   File "/usr/share/rhn/up2date_client/tui.py", line 20, in ?     import rhnreg, hardware   File "/usr/share/rhn/up2date_client/rhnreg.py", line 21, in ?     import hardware   File "/usr/share/rhn/up2date_client/hardware.py", line 25, in ?     import dbus   File "/usr/lib/python2.4/site-packages/dbus/__init__.py", line 1, in ?     from _dbus import *   File "/usr/lib/python2.4/site-packages/dbus/_dbus.py", line 45, in ?     import dbus_bindings ImportError: /usr/lib/python2.4/site-packages/dbus/dbus_bindings.so: undefined symbol: dbus_watch_get_unix_fd

edited /usr/share/rhn/up2date_client/hardware.py to uncomment following
#import dbus

#        if dev['bus'] == 'scsi':
#            if parent.properties.has_key('scsi.host'):
#                dev['prop1'] = parent.properties['scsi.host']
#            if parent.properties.has_key('scsi.target'):
#                dev['prop2'] = parent.properties['scsi.target']
#            if parent.properties.has_key('scsi.bus'):
#                dev['prop3'] = parent.properties['scsi.bus']
#            if parent.properties.has_key('scsi.lun'):
#                dev['prop4'] = parent.properties['scsi.lun']
re-ran rhn_register which worked


Now that, that fire is put out.  I did a rhn_check -v and did a "yum repolist"
am down to 66 errata and 51 package updates; YEAH I am getting there!!
I am going to attempt doing the packages; the last rhn_check was only for the errata.
Comment 13 Nancy 2010-06-24 13:59:02 EDT
None of my packages update  I received the following
[root@riw-lw-ito ~]# rhn_check -v
libgcrypt-devel-1.2.3-1.i386 from installed has depsolving problems
  --> Missing Dependency: libgcrypt = 1.2.3-1 is needed by package libgcrypt-devel-1.2.3-1.i386 (installed)
e2fsprogs-devel-1.39-15.el5.i386 from installed has depsolving problems
  --> Missing Dependency: e2fsprogs-libs = 1.39-15.el5 is needed by package e2fsprogs-devel-1.39-15.el5.i386 (installed)
tomcat5-jasper-5.5.23-0jpp.7.el5.i386 from installed has depsolving problems
  --> Missing Dependency: tomcat5-servlet-2.4-api = 5.5.23-0jpp.7.el5 is needed by package tomcat5-jasper-5.5.23-0jpp.7.el5.i386 (installed)
libuser-devel-0.54.7-2.el5.5.i386 from installed has depsolving problems
  --> Missing Dependency: libuser = 0.54.7-2.el5.5 is needed by package libuser-devel-0.54.7-2.el5.5.i386 (installed)
libgcj-src-4.1.2-42.el5.i386 from installed has depsolving problems
  --> Missing Dependency: libgcj = 4.1.2-42.el5 is needed by package libgcj-src-4.1.2-42.el5.i386 (installed)
gcc-c++-4.1.2-42.el5.i386 from installed has depsolving problems
  --> Missing Dependency: libstdc++ = 4.1.2-42.el5 is needed by package gcc-c++-4.1.2-42.el5.i386 (installed)
2:libpng-devel-1.2.10-7.1.el5_0.1.i386 from installed has depsolving problems
  --> Missing Dependency: libpng = 2:1.2.10-7.1.el5_0.1 is needed by package 2:libpng-devel-1.2.10-7.1.el5_0.1.i386 (installed)
elfutils-0.125-3.el5.i386 from installed has depsolving problems
  --> Missing Dependency: elfutils-libs = 0.125-3.el5 is needed by package elfutils-0.125-3.el5.i386 (installed)
pam-devel-0.99.6.2-3.27.el5.i386 from installed has depsolving problems
  --> Missing Dependency: pam = 0.99.6.2-3.27.el5 is needed by package pam-devel-0.99.6.2-3.27.el5.i386 (installed)
libstdc++-devel-4.1.2-42.el5.i386 from installed has depsolving problems
  --> Missing Dependency: libstdc++ = 4.1.2-42.el5 is needed by package libstdc++-devel-4.1.2-42.el5.i386 (installed)
mesa-libGL-devel-6.5.1-7.5.el5.i386 from installed has depsolving problems
  --> Missing Dependency: mesa-libGL = 6.5.1-7.5.el5 is needed by package mesa-libGL-devel-6.5.1-7.5.el5.i386 (installed)
libXt-devel-1.0.2-3.1.fc6.i386 from installed has depsolving problems
  --> Missing Dependency: libXt = 1.0.2-3.1.fc6 is needed by package libXt-devel-1.0.2-3.1.fc6.i386 (installed)
7:kdegraphics-devel-3.5.4-6.el5.i386 from installed has depsolving problems
  --> Missing Dependency: kdegraphics = 7:3.5.4-6.el5 is needed by package 7:kdegraphics-devel-3.5.4-6.el5.i386 (installed)
libXrandr-devel-1.1.1-3.1.i386 from installed has depsolving problems
  --> Missing Dependency: libXrandr = 1.1.1-3.1 is needed by package libXrandr-devel-1.1.1-3.1.i386 (installed)
gcc-gfortran-4.1.2-42.el5.i386 from installed has depsolving problems
  --> Missing Dependency: gcc = 4.1.2-42.el5 is needed by package gcc-gfortran-4.1.2-42.el5.i386 (installed)
sqlite-devel-3.3.6-2.i386 from installed has depsolving problems
  --> Missing Dependency: sqlite = 3.3.6-2 is needed by package sqlite-devel-3.3.6-2.i386 (installed)
tomcat5-common-lib-5.5.23-0jpp.7.el5.i386 from installed has depsolving problems
  --> Missing Dependency: tomcat5-jsp-2.0-api = 5.5.23-0jpp.7.el5 is needed by package tomcat5-common-lib-5.5.23-0jpp.7.el5.i386 (installed)
cyrus-sasl-devel-2.1.22-4.i386 from installed has depsolving problems
  --> Missing Dependency: cyrus-sasl-lib = 2.1.22-4 is needed by package cyrus-sasl-devel-2.1.22-4.i386 (installed)
gcc-java-4.1.2-42.el5.i386 from installed has depsolving problems
  --> Missing Dependency: libgcj = 4.1.2-42.el5 is needed by package gcc-java-4.1.2-42.el5.i386 (installed)
mesa-libGLU-devel-6.5.1-7.5.el5.i386 from installed has depsolving problems
  --> Missing Dependency: mesa-libGLU = 6.5.1-7.5.el5 is needed by package mesa-libGLU-devel-6.5.1-7.5.el5.i386 (installed)
dbus-glib-devel-0.70-5.i386 from installed has depsolving problems
  --> Missing Dependency: dbus-glib = 0.70-5 is needed by package dbus-glib-devel-0.70-5.i386 (installed)
rpm-build-4.4.2-48.el5.i386 from installed has depsolving problems
  --> Missing Dependency: rpm = 4.4.2-48.el5 is needed by package rpm-build-4.4.2-48.el5.i386 (installed)
db4-devel-4.3.29-9.fc6.i386 from installed has depsolving problems
  --> Missing Dependency: db4 = 4.3.29-9.fc6 is needed by package db4-devel-4.3.29-9.fc6.i386 (installed)
sabayon-2.12.4-5.el5.i386 from installed has depsolving problems
  --> Missing Dependency: sabayon-apply = 2.12.4-5.el5 is needed by package sabayon-2.12.4-5.el5.i386 (installed)
netpbm-devel-10.35-6.fc6.i386 from installed has depsolving problems
  --> Missing Dependency: netpbm = 10.35-6.fc6 is needed by package netpbm-devel-10.35-6.fc6.i386 (installed)
pcsc-lite-devel-1.4.4-0.1.el5.i386 from installed has depsolving problems
  --> Missing Dependency: pcsc-lite-libs = 1.4.4-0.1.el5 is needed by package pcsc-lite-devel-1.4.4-0.1.el5.i386 (installed)
gcc-gfortran-4.1.2-42.el5.i386 from installed has depsolving problems
  --> Missing Dependency: libgfortran = 4.1.2-42.el5 is needed by package gcc-gfortran-4.1.2-42.el5.i386 (installed)
elfutils-libelf-devel-0.125-3.el5.i386 from installed has depsolving problems
  --> Missing Dependency: elfutils-libelf = 0.125-3.el5 is needed by package elfutils-libelf-devel-0.125-3.el5.i386 (installed)
libgcj-devel-4.1.2-42.el5.i386 from installed has depsolving problems
  --> Missing Dependency: libgcj = 4.1.2-42.el5 is needed by package libgcj-devel-4.1.2-42.el5.i386 (installed)
python-devel-2.4.3-21.el5.i386 from installed has depsolving problems
  --> Missing Dependency: python = 2.4.3-21.el5 is needed by package python-devel-2.4.3-21.el5.i386 (installed)
libtiff-devel-3.8.2-7.el5.i386 from installed has depsolving problems
  --> Missing Dependency: libtiff = 3.8.2-7.el5 is needed by package libtiff-devel-3.8.2-7.el5.i386 (installed)
dbus-devel-1.0.0-7.el5.i386 from installed has depsolving problems
  --> Missing Dependency: dbus = 1.0.0-7.el5 is needed by package dbus-devel-1.0.0-7.el5.i386 (installed)
httpd-manual-2.2.3-11.el5_1.3.i386 from installed has depsolving problems
  --> Missing Dependency: httpd = 2.2.3-11.el5_1.3 is needed by package httpd-manual-2.2.3-11.el5_1.3.i386 (installed)
tomcat5-common-lib-5.5.23-0jpp.7.el5.i386 from installed has depsolving problems
  --> Missing Dependency: tomcat5-servlet-2.4-api = 5.5.23-0jpp.7.el5 is needed by package tomcat5-common-lib-5.5.23-0jpp.7.el5.i386 (installed)
elfutils-0.125-3.el5.i386 from installed has depsolving problems
  --> Missing Dependency: elfutils-libelf = 0.125-3.el5 is needed by package elfutils-0.125-3.el5.i386 (installed)
gcc-c++-4.1.2-42.el5.i386 from installed has depsolving problems
  --> Missing Dependency: gcc = 4.1.2-42.el5 is needed by package gcc-c++-4.1.2-42.el5.i386 (installed)
glib2-devel-2.12.3-2.fc6.i386 from installed has depsolving problems
  --> Missing Dependency: glib2 = 2.12.3-2.fc6 is needed by package glib2-devel-2.12.3-2.fc6.i386 (installed)
libXi-devel-1.0.1-3.1.i386 from installed has depsolving problems
  --> Missing Dependency: libXi = 1.0.1-3.1 is needed by package libXi-devel-1.0.1-3.1.i386 (installed)
alsa-lib-devel-1.0.14-1.rc4.el5.i386 from installed has depsolving problems
  --> Missing Dependency: alsa-lib = 1.0.14 is needed by package alsa-lib-devel-1.0.14-1.rc4.el5.i386 (installed)
libX11-devel-1.0.3-9.el5.i386 from installed has depsolving problems
  --> Missing Dependency: libX11 = 1.0.3-9.el5 is needed by package libX11-devel-1.0.3-9.el5.i386 (installed)
expat-devel-1.95.8-8.2.1.i386 from installed has depsolving problems
  --> Missing Dependency: expat = 1.95.8-8.2.1 is needed by package expat-devel-1.95.8-8.2.1.i386 (installed)
gcc-java-4.1.2-42.el5.i386 from installed has depsolving problems
  --> Missing Dependency: gcc = 4.1.2-42.el5 is needed by package gcc-java-4.1.2-42.el5.i386 (installed)
[root@riw-lw-ito ~]#
Comment 14 Nancy 2010-06-24 14:05:00 EDT
Also ran 
rpm -Va --nofiles --nodigest
 still 66 errata and 51 packages
Comment 15 seth vidal 2010-06-24 14:43:04 EDT
now that rhn is working for you please paste:

yum repolist

output.

thanks
Comment 16 James Antill 2010-06-24 14:49:15 EDT
Also you might want to try:

yum remove '*-devel'

...given that you are having problems with all the -devel packages, also might be worth calling your support person ... so they can run through their normal procedures (as it seems like there might be something wrong with your machine).
Comment 17 Nancy 2010-06-24 15:16:13 EDT
[root@riw-lw-ito ~]# yum repolist
Loaded plugins: rhnplugin, security
repo id            repo name                            status
rhel-i386-client-5 Red Hat Enterprise Linux Desktop (v. enabled: 6,158
repolist: 6,158
[root@riw-lw-ito ~]# 
My computer crashed when I uninstalled the qt-devel.  
I can call DELL and see if they could help me.  
Thanks for all your help.  I have come futher than I was before.  I just wish I knew how to re register my machine (when I got those errors before) before I erased everything off it with the new OS when I had this problem before.  No backup, huge mistake on my part. 
Thanks again.