Bug 60764

Summary: Gnome doesn't start up
Product: [Retired] Red Hat Linux Reporter: Stephen Rasku <redhat>
Component: gnome-coreAssignee: Havoc Pennington <hp>
Status: CLOSED NOTABUG QA Contact: Aaron Brown <abrown>
Severity: medium Docs Contact:
Priority: high    
Version: 7.2CC: stephen
Target Milestone: ---   
Target Release: ---   
Hardware: athlon   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2002-03-06 08:50:32 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
Firewall rules none

Description Stephen Rasku 2002-03-06 00:02:47 EST
Version-Release number of selected component (if applicable):

gnome-core-1.4.0.4-38

How Reproducible:

100%

Steps to Reproduce:
1. switchdesk gnome
2. startx

Actual Results:

All I get is a grey window.

Expected Results:

Gnome should startup

Additional Information:
	
It appears that gnome-session is waiting for gnome-login-check to finish.  An
strace of gnome-login-check gives:

connect(3, {sin_family=AF_INET, sin_port=htons(16001),
sin_addr=inet_addr("127.0.0.1")}}, 16 <unfinished ...>

I am running an iptables firewall on this box and sound is not properly
configured yet.  Gnome used to work on this same box with the same configuration.
Comment 1 Stephen Rasku 2002-03-06 01:38:52 EST
It looks like this is firewall related.  When I disabled the firewall and
disconnected from the Internet, it seemed to work.  I then re-connected to the
Internet and re-enabled the firewall and I had problems again.  This time, it
eventually started up but the window manager didn't start up.  There was also a
dialog box complaining about a non-gnome compatible window manager.
Comment 2 Stephen Rasku 2002-03-06 01:55:27 EST
Created attachment 47562 [details]
Firewall rules
Comment 3 Havoc Pennington 2002-03-06 08:50:27 EST
The strace looks like it can't connect to localhost...
Comment 4 Havoc Pennington 2002-03-06 11:45:14 EST
Opinion voiced by a coworker who knows firewalls better than me is that 
you need to enable loopback (lo), at least for port 16001 which is esound.