Bug 60853

Summary: Perl doesn't look for modules in /usr/local
Product: [Retired] Red Hat Linux Reporter: Need Real Name <arensb+redhat>
Component: perlAssignee: Warren Togami <wtogami>
Status: CLOSED WONTFIX QA Contact: David Lawrence <dkl>
Severity: medium Docs Contact:
Priority: medium    
Version: 7.1CC: dmenest, mathias, perl-devel
Target Milestone: ---Keywords: FutureFeature
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-09-11 07:07:39 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Need Real Name 2002-03-07 17:23:21 EST
Description of Problem:

	According to standard Unix practice, and according to
http://www.redhat.com/docs/manuals/linux/RHL-7.2-Manual/ref-guide/s1-filesystem-
fhs.html
/usr is for the vendor-supplied parts of the OS, and /usr/local is for
site-local additions. This is so that a system administrator can upgrade
by making a backup of /usr/local, upgrading, and restoring /usr/local.
	Therefore, if I install a Perl module for which there is no RPM,
it should go in /usr/local/perl/lib/$VERSION/$ARCHNAME . However,
the standard Perl installed with Red Hat 7.2 (and probably later versions)
doesn't look in /usr/local.

	The following directories ought to be added to Perl's @INC:
/usr/local/perl/lib/$VERSION/$ARCHNAME
/usr/local/perl/lib/$VERSION
/usr/local/perl/lib/site_perl/$APIVERSION/$ARCHNAME
/usr/local/perl/lib/site_perl/$APIVERSION

(where "$VERSION" etc. are from Perl's Config module.)

Version-Release number of selected component (if applicable):


How Reproducible:


Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:
Comment 1 Hypercube 2003-01-08 20:00:14 EST
When will this be fixed?  It is still a problem in Red Hat Linux 8.0

BTW, bugs 60853 and 63121 appear to be duplicates of each other.
Comment 2 Chip Turner 2003-04-11 17:20:40 EDT
*** Bug 63121 has been marked as a duplicate of this bug. ***
Comment 3 Warren Togami 2005-05-28 03:26:20 EDT
Still an issue in FC4?  I think it isn't, but I would like confirmation.
Comment 4 Warren Togami 2005-09-11 07:07:39 EDT
Closing due to lack of response.  There is a newer report somewhere asking for
this elsewhere.