Bug 609673

Summary: ddclient complains of program version mismatch in /var/cache/ddclient/ddclient.cache after update to 3.8.0-2.el5
Product: [Fedora] Fedora EPEL Reporter: Gerrit Slomma <gerrit.slomma>
Component: ddclientAssignee: Robert Scheck <redhat-bugzilla>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: low    
Version: el5CC: redhat-bugzilla, tremble
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard: ActualBug
Fixed In Version: ddclient-3.8.1-9.el5 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-12-27 22:14:02 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Gerrit Slomma 2010-06-30 19:58:36 UTC
Description of problem:

After updating to ddclient-3.8.0-2.el5 ddclient complains of progam version mismatch. Furthermore it updated my dyndns-accounts unnecessary every now and then (seems to me like 5-minute-intervalls) leading to a ban from dyndns. This version is not supported by dyndns.org anyways, 3.7.3 is described here http://www.dyndns.com/support/clients/ as the currently supported version.

Version-Release number of selected component (if applicable):

ddclient-3.8.0-2.el5

How reproducible:



Steps to Reproduce:
1. yum update ddclient (from previous version)
2. experience the /var/log/messages entries and frequent updates
3. get the ban-mail from dyndns.org
  
Actual results:

Jun 30 21:32:31 rr010 ddclient[3852]: WARNING:  file /var/cache/ddclient/ddclient.cache, line 1: program version mismatch; ignoring /var/cache/ddclient/ddclient.cache
Jun 30 21:32:32 rr010 ddclient[3852]: FAILED:   updating repo-itsslomma.dyndns.org: abuse: The hostname specified is blocked for abuse; fill in the form at http://support.dyndns.org/abuse.php to be unblocked
Jun 30 21:32:32 rr010 ddclient[3852]: FAILED:   updating sixnationstate.dyndns.org: abuse: The hostname specified is blocked for abuse; fill in the form at http://support.dyndns.org/abuse.php to be unblocked
Jun 30 21:32:32 rr010 ddclient[3852]: FAILED:   updating englisch-in-friedrichshagen.de: abuse: The hostname specified is blocked for abuse; fill in the form at http://support.dyndns.org/abuse.php to be unblocked
Jun 30 21:32:32 rr010 ddclient[3852]: FAILED:   updating itsslomma.de: abuse: The hostname specified is blocked for abuse; fill in the form at http://support.dyndns.org/abuse.php to be unblocked
Jun 30 21:37:02 rr010 ddclient[7087]: WARNING:  file /var/cache/ddclient/ddclient.cache, line 1: program version mismatch; ignoring /var/cache/ddclient/ddclient.cache
Jun 30 21:37:02 rr010 ddclient[7087]: FAILED:   updating repo-itsslomma.dyndns.org: abuse: The hostname specified is blocked for abuse; fill in the form at http://support.dyndns.org/abuse.php to be unblocked
Jun 30 21:37:02 rr010 ddclient[7087]: FAILED:   updating sixnationstate.dyndns.org: abuse: The hostname specified is blocked for abuse; fill in the form at http://support.dyndns.org/abuse.php to be unblocked
Jun 30 21:37:03 rr010 ddclient[7087]: FAILED:   updating itsslomma.de: abuse: The hostname specified is blocked for abuse; fill in the form at http://support.dyndns.org/abuse.php to be unblocked
Jun 30 21:37:03 rr010 ddclient[7087]: FAILED:   updating englisch-in-friedrichshagen.de: abuse: The hostname specified is blocked for abuse; fill in the form at http://support.dyndns.org/abuse.php to be unblocked
Jun 30 21:37:32 rr010 ddclient[3852]: WARNING:  file /var/cache/ddclient/ddclient.cache, line 1: program version mismatch; ignoring /var/cache/ddclient/ddclient.cache
Jun 30 21:37:33 rr010 ddclient[3852]: FAILED:   updating repo-itsslomma.dyndns.org: abuse: The hostname specified is blocked for abuse; fill in the form at http://support.dyndns.org/abuse.php to be unblocked
Jun 30 21:37:33 rr010 ddclient[3852]: FAILED:   updating sixnationstate.dyndns.org: abuse: The hostname specified is blocked for abuse; fill in the form at http://support.dyndns.org/abuse.php to be unblocked
Jun 30 21:37:33 rr010 ddclient[3852]: FAILED:   updating englisch-in-friedrichshagen.de: abuse: The hostname specified is blocked for abuse; fill in the form at http://support.dyndns.org/abuse.php to be unblocked
Jun 30 21:37:33 rr010 ddclient[3852]: FAILED:   updating itsslomma.de: abuse: The hostname specified is blocked for abuse; fill in the form at http://support.dyndns.org/abuse.php to be unblocked
Jun 30 21:42:03 rr010 ddclient[7087]: WARNING:  file /var/cache/ddclient/ddclient.cache, line 1: program version mismatch; ignoring /var/cache/ddclient/ddclient.cache
Jun 30 21:42:03 rr010 ddclient[7087]: FAILED:   updating repo-itsslomma.dyndns.org: abuse: The hostname specified is blocked for abuse; fill in the form at http://support.dyndns.org/abuse.php to be unblocked
Jun 30 21:42:03 rr010 ddclient[7087]: FAILED:   updating sixnationstate.dyndns.org: abuse: The hostname specified is blocked for abuse; fill in the form at http://support.dyndns.org/abuse.php to be unblocked
Jun 30 21:42:04 rr010 ddclient[7087]: FAILED:   updating itsslomma.de: abuse: The hostname specified is blocked for abuse; fill in the form at http://support.dyndns.org/abuse.php to be unblocked
Jun 30 21:42:04 rr010 ddclient[7087]: FAILED:   updating englisch-in-friedrichshagen.de: abuse: The hostname specified is blocked for abuse; fill in the form at http://support.dyndns.org/abuse.php to be unblocked
Jun 30 21:42:33 rr010 ddclient[3852]: WARNING:  file /var/cache/ddclient/ddclient.cache, line 1: program version mismatch; ignoring /var/cache/ddclient/ddclient.cache

Expected results:

ddclient should work as before the update

Additional info:

No restart done up to now. Would restart ddclient now and unlock my dyndns-account and report back

Comment 1 Robert Scheck 2010-06-30 20:08:58 UTC
May you please provide the content of /var/cache/ddclient/ddclient.cache?

Comment 2 Gerrit Slomma 2010-06-30 20:11:41 UTC
ddclient could not be stoped via /etc/init.d/ddclient.

[root@rr010 ppsesieve]# date
Mi 30. Jun 22:01:12 CEST 2010
[root@rr010 ppsesieve]# /etc/init.d/ddclient stop
ddclient beenden:                                          [FEHLGESCHLAGEN]
[root@rr010 ppsesieve]# ps -ef|grep ddclient
ddclient 13044     1  0 22:00 ?        00:00:00 ddclient - sleeping for 270
seconds
root     13076  6909  0 22:01 pts/0    00:00:00 grep ddclient
[root@rr010 ppsesieve]# pkill -9 ddclient
[root@rr010 ppsesieve]# ps -ef|grep ddclient
root     13081  6909  0 22:02 pts/0    00:00:00 grep ddclient

but even after restart the client can not be stopped via /etc/init.d/ddclient

[root@rr010 ppsesieve]# /etc/init.d/ddclient stop
ddclient beenden:                                          [FEHLGESCHLAGEN]
[root@rr010 ppsesieve]# ps -ef|grep ddclient
ddclient 13118     1  0 22:02 ?        00:00:00 ddclient - sleeping for 180
seconds
root     13263  6909  0 22:09 pts/0    00:00:00 grep ddclient

Comment 3 Gerrit Slomma 2010-06-30 20:15:31 UTC
To late, i deleted it.
It is now:

## ddclient-3.8.0
## last updated at Wed Jun 30 22:07:51 2010 (1277928471)
atime=1277928471,backupmx=0,custom=0,host=xxx.de,ip=,mtime=0,mx=,static=0,status=abuse,warned-min-error-interval=0,warned-min-interval=0,wildcard=1,wtime=0 xxx.de
atime=1277928471,backupmx=0,custom=0,host=xxx.de,ip=,mtime=0,mx=,static=0,status=abuse,warned-min-error-interval=0,warned-min-interval=0,wildcard=1,wtime=0 xxx.de
atime=1277928471,backupmx=0,custom=0,host=xxx.dyndns.org,ip=88.73.9.75,mtime=1277928471,mx=,static=0,status=good,warned-min-error-interval=0,warned-min-interval=0,wildcard=1,wtime=0 xxx.dyndns.org
atime=1277928170,backupmx=0,custom=0,host=xxx.dyndns.org,ip=88.73.9.75,mtime=1277928170,mx=,static=0,status=good,warned-min-error-interval=0,warned-min-interval=0,wildcard=1,wtime=30 xxx.dyndns.org

Before rm-ing it there stood ddclient-3.7.x (the previous release)
I was able to unlock my dyndns.org-defined dns-records but failed for my strato-ones as the do not appear there. Let us see if the update works.

Comment 4 Robert Scheck 2010-06-30 20:18:45 UTC
What does "getenforce" tell?

Comment 5 Gerrit Slomma 2010-06-30 20:21:55 UTC
# getenforce
Disabled

Was disabled due to conflicts back in the days i was working with the libvirt-/kvm-sources.

Comment 6 Gerrit Slomma 2010-06-30 20:26:09 UTC
If i do a start the ddclient is started, afterwards i got 2 ddclients

[root@rr010 ppsesieve]# /etc/init.d/ddclient stop
ddclient beenden:                                          [FEHLGESCHLAGEN]
[root@rr010 ppsesieve]# /etc/init.d/ddclient start
ddclient starten:                                          [  OK  ]
[root@rr010 ppsesieve]# ps -ef|grep ddclient
ddclient 13118     1  0 22:02 ?        00:00:00 ddclient - sleeping for 160 seconds
ddclient 13530     1  0 22:25 ?        00:00:00 ddclient - sleeping for 300 seconds
root     13542  6909  0 22:25 pts/0    00:00:00 grep ddclient
[root@rr010 ppsesieve]# /etc/init.d/ddclient stop
ddclient beenden:                                          [FEHLGESCHLAGEN]
[root@rr010 ppsesieve]# ps -ef|grep ddclient
ddclient 13118     1  0 22:02 ?        00:00:00 ddclient - sleeping for 160 seconds
ddclient 13530     1  0 22:25 ?        00:00:00 ddclient - sleeping for 300 seconds
root     13551  6909  0 22:25 pts/0    00:00:00 grep ddclient
[root@rr010 ppsesieve]# pkill -9 ddclient

Comment 7 Gerrit Slomma 2010-07-02 17:07:00 UTC
looks like the pidfile /var/run/ddclient/ddclient.pid is not created via the init-script:

# ls -l /var/run/ddclient/ddclient.pid
ls: /var/run/ddclient/ddclient.pid: Datei oder Verzeichnis nicht gefunden

however the folder is present:

# ls -al /var/run/ddclient
insgesamt 12
drwxr-xr-x  2 ddclient ddclient 4096 29. Mai 12:58 .
drwxr-xr-x 23 root     root     4096  2. Jul 18:39 ..

Comment 8 Fedora Update System 2013-12-25 22:17:40 UTC
ddclient-3.8.1-9.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/ddclient-3.8.1-9.el6

Comment 9 Fedora Update System 2013-12-25 22:18:28 UTC
ddclient-3.8.1-9.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/ddclient-3.8.1-9.el5

Comment 10 Fedora Update System 2013-12-27 22:14:02 UTC
ddclient-3.8.1-9.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2014-01-11 20:27:39 UTC
ddclient-3.8.1-9.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.