Bug 611725

Summary: Windows XP will not install as a guest on Fedora 13 with qemu-kvm-0.12.3-8.fc13.x86_64
Product: [Fedora] Fedora Reporter: sparrow2867
Component: qemuAssignee: Justin M. Forbes <jforbes>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 13CC: amit.shah, berrange, dwmw2, ehabkost, gcosta, itamar, jaswinder, jeff.raber, jforbes, knoel, markmc, ondrejj, scottt.tw, virt-maint
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-10-03 04:45:46 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description sparrow2867 2010-07-06 05:49:19 EDT
Description of problem:
Trying to install Windows XP as a guest on a Fedora 13 host using 
qemu-kvm-0.12.3-8.fc13.x86_64 gives the problems described here:
https://bugs.launchpad.net/qemu/+bug/477946
On Ubuntu systems this is fixed with QEMU 0.12.3
On Fedora this bug is still present, at least with 
qemu-kvm-0.12.3-8.fc13.x86_64

Version-Release number of selected component (if applicable):
qemu-kvm-0.12.3-8.fc13.x86_64

How reproducible:
install windows XP as a guest on a Fedora 13 host using qemu-kvm


Steps to Reproduce:
1.install qemu-kvm-0.12.3-8.fc13.x86_64
2.try to install Windows XP as a guest
3.choosing ntfs or fat give different errors
  
Actual results:
Windows XP installation fails, reporting either a disk error or a 'missing NTLDR' error

Expected results:
Windows XP successfully installed

Additional info:
I checked:
yum install qemu-kvm
......
Setting up Install Process
Package 2:qemu-kvm-0.12.3-8.fc13.x86_64 already installed and latest version
Nothing to do
Comment 1 Justin M. Forbes 2010-08-12 11:53:56 EDT
Do you have the qemu command line used for this install?  If you were using virt-manager or virt-install for the installation, the command line would be in the logs in /var/log/libvirt/qemu/<guestname>.log
Comment 2 sparrow2867 2010-08-20 14:31:20 EDT
(In reply to comment #1)
> Do you have the qemu command line used for this install?  If you were using
> virt-manager or virt-install for the installation, the command line would be in
> the logs in /var/log/libvirt/qemu/<guestname>.log

Here is that file for qemu-kvm-0.12.5-1.fc13.x86_64

LC_ALL=C PATH=/sbin:/usr/sbin:/bin:/usr/bin QEMU_AUDIO_DRV=none /usr/bin/qemu-kvm -S -M fedora-13 -enable-kvm -m 1024 -smp 1,sockets=1,cores=1,threads=1 -name XPmachine -uuid 3adbaf55-e75b-e69c-09b5-0d0ac66e5091 -nodefaults -chardev socket,id=monitor,path=/var/lib/libvirt/qemu/XPmachine.monitor,server,nowait -mon chardev=monitor,mode=readline -rtc base=localtime -no-reboot -boot d -drive file=/var/lib/libvirt/images/XPmachine.img,if=none,id=drive-ide0-0-0,format=raw -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -drive file=/dev/sr0,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -device rtl8139,vlan=0,id=net0,mac=52:54:00:42:72:fc,bus=pci.0,addr=0x4 -net tap,fd=57,vlan=0,name=hostnet0 -chardev pty,id=serial0 -device isa-serial,chardev=serial0 -usb -device usb-tablet,id=input0 -vnc 127.0.0.1:0 -vga std -device AC97,id=sound0,bus=pci.0,addr=0x5 -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x3 
char device redirected to /dev/pts/0
LC_ALL=C PATH=/sbin:/usr/sbin:/bin:/usr/bin QEMU_AUDIO_DRV=none /usr/bin/qemu-kvm -S -M fedora-13 -enable-kvm -m 1024 -smp 1,sockets=1,cores=1,threads=1 -name XPmachine -uuid 3adbaf55-e75b-e69c-09b5-0d0ac66e5091 -nodefaults -chardev socket,id=monitor,path=/var/lib/libvirt/qemu/XPmachine.monitor,server,nowait -mon chardev=monitor,mode=readline -rtc base=localtime -no-reboot -boot c -drive file=/var/lib/libvirt/images/XPmachine.img,if=none,id=drive-ide0-0-0,boot=on,format=raw -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -drive file=/dev/sr0,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -device rtl8139,vlan=0,id=net0,mac=52:54:00:42:72:fc,bus=pci.0,addr=0x4 -net tap,fd=57,vlan=0,name=hostnet0 -chardev pty,id=serial0 -device isa-serial,chardev=serial0 -usb -device usb-tablet,id=input0 -vnc 127.0.0.1:0 -vga std -device AC97,id=sound0,bus=pci.0,addr=0x5 -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x3 
char device redirected to /dev/pts/0
Comment 3 Jeff Raber 2010-09-14 15:15:40 EDT
Is this the same as bug 579348?
Comment 4 sparrow2867 2010-10-03 04:44:56 EDT
Yep.(In reply to comment #3)
> Is this the same as bug 579348?
Comment 5 sparrow2867 2010-10-03 04:45:46 EDT

*** This bug has been marked as a duplicate of bug 579348 ***