Bug 615689

Summary: Dead Screen after awake from suspend
Product: [Fedora] Fedora Reporter: Jerry LeVan <jerry.levan>
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: low    
Version: 13CC: anton, dougsland, gansalmon, itamar, jonathan, jskala, jskarvad, kernel-maint, madhu.chinakonda, opensource, pknirsch, richard
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: 2.6.34.6-47.fc13 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-09-03 09:17:29 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Jerry LeVan 2010-07-17 22:04:43 EDT
Description of problem:

Black Screen after awake from Suspend

Keyboard seems to work ie ctl-alt-2, type root type passwd
type reboot and system will reboot. (Screen still black)


Version-Release number of selected component (if applicable):


How reproducible:
 Every suspend


Steps to Reproduce:
1. Suspend OS
2. Wake by pressing power key
3.
  
Actual results:
Screen remains unlit

Expected results:
Restoration of screen

Additional info:
This is a recent regression that appeared in
kernel 2.6.33.6-147 pae. Kernels 2.6.33.5.* pae do
not have this problem. I suppose it could be
a Nouveau problem also...

I cannot find any info in the various log files
that indicate a problem.

I am running a HP i7 based laptop with 6GB of memory and I
am using the Nouveau driver.

Here is lspci
00:00.0 Host bridge: Intel Corporation Core Processor DMI (rev 11)
00:03.0 PCI bridge: Intel Corporation Core Processor PCI Express Root Port 1 (rev 11)
00:08.0 System peripheral: Intel Corporation Core Processor System Management Registers (rev 11)
00:08.1 System peripheral: Intel Corporation Core Processor Semaphore and Scratchpad Registers (rev 11)
00:08.2 System peripheral: Intel Corporation Core Processor System Control and Status Registers (rev 11)
00:08.3 System peripheral: Intel Corporation Core Processor Miscellaneous Registers (rev 11)
00:10.0 System peripheral: Intel Corporation Core Processor QPI Link (rev 11)
00:10.1 System peripheral: Intel Corporation Core Processor QPI Routing and Protocol Registers (rev 11)
00:1a.0 USB Controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 05)
00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 05)
00:1c.0 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 1 (rev 05)
00:1c.1 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 2 (rev 05)
00:1c.4 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 5 (rev 05)
00:1c.7 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 8 (rev 05)
00:1d.0 USB Controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 05)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev a5)
00:1f.0 ISA bridge: Intel Corporation Mobile 5 Series Chipset LPC Interface Controller (rev 05)
00:1f.2 SATA controller: Intel Corporation 5 Series/3400 Series Chipset 6 port SATA AHCI Controller (rev 05)
00:1f.3 SMBus: Intel Corporation 5 Series/3400 Series Chipset SMBus Controller (rev 05)
01:00.0 VGA compatible controller: nVidia Corporation GT216 [GeForce GT 230M] (rev a2)
01:00.1 Audio device: nVidia Corporation High Definition Audio Controller (rev a1)
02:00.0 Network controller: Intel Corporation PRO/Wireless 5100 AGN [Shiloh] Network Connection
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 03)
04:00.0 FireWire (IEEE 1394): JMicron Technology Corp. IEEE 1394 Host Controller
04:00.1 System peripheral: JMicron Technology Corp. SD/MMC Host Controller
04:00.2 SD Host controller: JMicron Technology Corp. Standard SD Host Controller
04:00.3 System peripheral: JMicron Technology Corp. MS Host Controller
04:00.4 System peripheral: JMicron Technology Corp. xD Host Controller
ff:00.0 Host bridge: Intel Corporation Core Processor QuickPath Architecture Generic Non-Core Registers (rev 04)
ff:00.1 Host bridge: Intel Corporation Core Processor QuickPath Architecture System Address Decoder (rev 04)
ff:02.0 Host bridge: Intel Corporation Core Processor QPI Link 0 (rev 04)
ff:02.1 Host bridge: Intel Corporation Core Processor QPI Physical 0 (rev 04)
ff:03.0 Host bridge: Intel Corporation Core Processor Integrated Memory Controller (rev 04)
ff:03.1 Host bridge: Intel Corporation Core Processor Integrated Memory Controller Target Address Decoder (rev 04)
ff:03.4 Host bridge: Intel Corporation Core Processor Integrated Memory Controller Test Registers (rev 04)
ff:04.0 Host bridge: Intel Corporation Core Processor Integrated Memory Controller Channel 0 Control Registers (rev 04)
ff:04.1 Host bridge: Intel Corporation Core Processor Integrated Memory Controller Channel 0 Address Registers (rev 04)
ff:04.2 Host bridge: Intel Corporation Core Processor Integrated Memory Controller Channel 0 Rank Registers (rev 04)
ff:04.3 Host bridge: Intel Corporation Core Processor Integrated Memory Controller Channel 0 Thermal Control Registers (rev 04)
ff:05.0 Host bridge: Intel Corporation Core Processor Integrated Memory Controller Channel 1 Control Registers (rev 04)
ff:05.1 Host bridge: Intel Corporation Core Processor Integrated Memory Controller Channel 1 Address Registers (rev 04)
ff:05.2 Host bridge: Intel Corporation Core Processor Integrated Memory Controller Channel 1 Rank Registers (rev 04)
ff:05.3 Host bridge: Intel Corporation Core Processor Integrated Memory Controller Channel 1 Thermal Control Registers (rev 04)
[jerry@bigbox boot]$ 
[jerry@bigbox boot]$ lspci
00:00.0 Host bridge: Intel Corporation Core Processor DMI (rev 11)
00:03.0 PCI bridge: Intel Corporation Core Processor PCI Express Root Port 1 (rev 11)
00:08.0 System peripheral: Intel Corporation Core Processor System Management Registers (rev 11)
00:08.1 System peripheral: Intel Corporation Core Processor Semaphore and Scratchpad Registers (rev 11)
00:08.2 System peripheral: Intel Corporation Core Processor System Control and Status Registers (rev 11)
00:08.3 System peripheral: Intel Corporation Core Processor Miscellaneous Registers (rev 11)
00:10.0 System peripheral: Intel Corporation Core Processor QPI Link (rev 11)
00:10.1 System peripheral: Intel Corporation Core Processor QPI Routing and Protocol Registers (rev 11)
00:1a.0 USB Controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 05)
00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 05)
00:1c.0 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 1 (rev 05)
00:1c.1 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 2 (rev 05)
00:1c.4 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 5 (rev 05)
00:1c.7 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 8 (rev 05)
00:1d.0 USB Controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 05)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev a5)
00:1f.0 ISA bridge: Intel Corporation Mobile 5 Series Chipset LPC Interface Controller (rev 05)
00:1f.2 SATA controller: Intel Corporation 5 Series/3400 Series Chipset 6 port SATA AHCI Controller (rev 05)
00:1f.3 SMBus: Intel Corporation 5 Series/3400 Series Chipset SMBus Controller (rev 05)
01:00.0 VGA compatible controller: nVidia Corporation GT216 [GeForce GT 230M] (rev a2)
01:00.1 Audio device: nVidia Corporation High Definition Audio Controller (rev a1)
02:00.0 Network controller: Intel Corporation PRO/Wireless 5100 AGN [Shiloh] Network Connection
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 03)
04:00.0 FireWire (IEEE 1394): JMicron Technology Corp. IEEE 1394 Host Controller
04:00.1 System peripheral: JMicron Technology Corp. SD/MMC Host Controller
04:00.2 SD Host controller: JMicron Technology Corp. Standard SD Host Controller
04:00.3 System peripheral: JMicron Technology Corp. MS Host Controller
04:00.4 System peripheral: JMicron Technology Corp. xD Host Controller
ff:00.0 Host bridge: Intel Corporation Core Processor QuickPath Architecture Generic Non-Core Registers (rev 04)
ff:00.1 Host bridge: Intel Corporation Core Processor QuickPath Architecture System Address Decoder (rev 04)
ff:02.0 Host bridge: Intel Corporation Core Processor QPI Link 0 (rev 04)
ff:02.1 Host bridge: Intel Corporation Core Processor QPI Physical 0 (rev 04)
ff:03.0 Host bridge: Intel Corporation Core Processor Integrated Memory Controller (rev 04)
ff:03.1 Host bridge: Intel Corporation Core Processor Integrated Memory Controller Target Address Decoder (rev 04)
ff:03.4 Host bridge: Intel Corporation Core Processor Integrated Memory Controller Test Registers (rev 04)
ff:04.0 Host bridge: Intel Corporation Core Processor Integrated Memory Controller Channel 0 Control Registers (rev 04)
ff:04.1 Host bridge: Intel Corporation Core Processor Integrated Memory Controller Channel 0 Address Registers (rev 04)
ff:04.2 Host bridge: Intel Corporation Core Processor Integrated Memory Controller Channel 0 Rank Registers (rev 04)
ff:04.3 Host bridge: Intel Corporation Core Processor Integrated Memory Controller Channel 0 Thermal Control Registers (rev 04)
ff:05.0 Host bridge: Intel Corporation Core Processor Integrated Memory Controller Channel 1 Control Registers (rev 04)
ff:05.1 Host bridge: Intel Corporation Core Processor Integrated Memory Controller Channel 1 Address Registers (rev 04)
ff:05.2 Host bridge: Intel Corporation Core Processor Integrated Memory Controller Channel 1 Rank Registers (rev 04)
ff:05.3 Host bridge: Intel Corporation Core Processor Integrated Memory Controller Channel 1 Thermal Control Registers (rev 04
Comment 1 Jaroslav Škarvada 2010-07-27 11:14:16 EDT
Ok, thanks for your report, but I think that more appropriate would be to reassign this to kernel. For me it doesn't seems to be pm-utils fault. You can also try to invoke pm-suspend with various quirks, e.g. --quirk-reset-brightness or similar (list of available quirks can be obtained as result of /usr/lib/pm-utils/bin/pm-action --help), but it is only temporal solution and if it resolve your issue it should be fixed in kernel or HAL.
Comment 2 Jaroslav Škarvada 2010-07-30 08:18:20 EDT
Also please try if you can change VT (ALT+NUMs or CTRL+ALT+NUMs) or if the video is completely dead.
Comment 3 Jerry LeVan 2010-07-30 09:50:52 EDT
I tried most of the suggestionss about using the quirks but they did no good.

I can <ctl>+<alt>+<num> to get a virtual terminal but the screen is
still completely black. ie no back light...

I know that I have a virtual terminal because I can blind type a user
name and password and then give the reboot command and the
system will reboot.

The screen is simply not powered on after a suspend.

Hope that helps...

Jerry
Comment 4 Jaroslav Škarvada 2010-07-30 10:07:17 EDT
Thanks for info. Another idea: try to comment line 37 in: /usr/lib/pm-utils/sleep.d/98smart-kernel-video, so to have:
#   add_parameters --quirk-no-chvt

If it doesn't help, it is probably Nouveau bug and should be reassigned.
Comment 5 Jerry LeVan 2010-07-30 13:11:07 EDT
Alas,

I commented out the line as requested but waking from
suspend still leaves a dead screen...

The 2.6.33.5.* kernels show three lines of something shortly after
the boot process is started ( I know the last line starts with
nouveau but it flies by so quickly that I can't read the rascal..)

The 2.6.33.6.* kernels show 4 lines and the last two are prefaced
with nouveau...

Can you kick this over to the nouveau group?
Comment 6 Jaroslav Škarvada 2010-07-31 02:05:17 EDT
OK, reassigning to kernel.
Comment 7 Jerry LeVan 2010-08-25 13:36:08 EDT
Sigh, I get the same bad behaviour when I try to hibernate, ie
upon awaking, the screen never powers on.

The last kernel/nouveau combo that worked was
the 2.6.33.5.* kernel set.

Something bad has happened with the 2.6.33.(>5) kernels...

I can't be too hard to find the regression, can it?

Thanks
Comment 8 Chuck Ebbert 2010-08-26 05:15:19 EDT
Can you try a 2.6.34 kernel from koji?

You would need to manually install it with this command:

   yum --nogpg localinstall http://kojipkgs.fedoraproject.org/packages/kernel/2.6.34.6/46.rc1.fc13/i686/kernel-PAE-2.6.34.6-46.rc1.fc13.i686.rpm
Comment 9 Jerry LeVan 2010-08-26 09:36:05 EDT
Bless you my son...

This kernel (2.6.34.6-46.rc1)

Seems to have fixed the problem ie I can suspend/resume
and hibernate/resume and the screen is properly restored.

I did notice that desktop effects are broken. There was
no 3-d available, said the error message

lsmod shows nouveau module is loaded.

Can I get the Kernel developer package. I use
Oracles Virtual Box and need to try to compile
the vbox driver stuff.

Thanks

Jerry
Comment 10 Jerry LeVan 2010-08-26 14:24:05 EDT
Added bonus...

I found the kernel-header and kernel-dev rpms and 
built the Oracle Virtual Box driver.

The good news is that the sound quality in the Win 7 VM
was no longer buzzy and distorted ( but just a short test).

Is there any way to find out what the problem was?

Is there any way to find out when the fix might make it
into the standard distribution?

Thanks 

Jerry
Comment 11 Chuck Ebbert 2010-08-27 12:04:38 EDT
The 2.6.34 kernel is now submitted as an update for F13.

I don't think nouveau supports 3D yet.
Comment 12 Jerry LeVan 2010-08-27 15:02:00 EDT
I think there is support for some 3-d provided one
loads  mesa-dri-drivers-experimental-7.8.1-8.fc13.i686 rpm, which is
loaded on my system.

The experimental mesa drivers do provide enough support to
enable the 'Desktop Effects' configuration. ie the rotating
cube effect when changing workspaces,etc...

I have not had any problems with the effects since they
were introduced with Fedora 13 ( until I tried the 2.6.34 kernel).

As noted earlier with the 2.6.34 the 'Desktop Effects' menu
item fails immediately with the 3-d not available message.

Should I file a bug about this? If so where?

Jerry