Bug 616176

Summary: Yum won't update old version of dhcp doesn't update
Product: [Fedora] Fedora Reporter: Gene Snider <genes1122>
Component: dhcpAssignee: Jiri Popelka <jpopelka>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: low    
Version: rawhideCC: jpopelka
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-07-26 12:12:28 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Gene Snider 2010-07-19 15:26:08 EDT
Description of problem:

NOTE:  This problem should apply to F12 and F13, as well as rawhide.

In June, the version/release numbering scheme of dhcp was temporarily changed.  My system updated to dhcp-4.1.1_P1-2.fc14 in early June, and has not updated dhclient since then.  Yesterday, I forced an update by using "sudo yum --nogpgcheck downgrade dhclient".  I just have the client installed, but the problem should affect all dhcp sub-packages.

Here is the status of dhcp/dhclient on my machine prior to DOWNGRADING dhclient:
[gene@Mobile-PC ~]$ yum list dhclient dhcp
...
Installed Packages
dhclient.x86_64                           12:4.1.1_P1-2.fc14                            @rawhide
Available Packages
dhcp.x86_64                               12:4.1.1-26.P1.fc14                           rawhide
At this point, yum said an update wasn't available for dhclient. However...

Here's some history from the koji dhcp package page:
Page:
1 through 50 of 219 >>>
NVR                     Built by        Finished                State
dhcp-4.1.1-26.P1.fc14 	jpopelka 	2010-07-12 10:37:41 	complete
dhcp-4.1.1-25.P1.fc14 	jpopelka 	2010-07-01 09:45:34 	complete
dhcp-4.1.1-18.P1.fc12 	jpopelka 	2010-06-29 10:33:24 	complete
dhcp-4.1.1-23.P1.fc13 	jpopelka 	2010-06-29 10:31:48 	complete
dhcp-4.1.1-24.P1.fc14 	jpopelka 	2010-06-29 10:31:18 	complete
dhcp-4.1.0p1-6.fc11 	jpopelka 	2010-06-18 12:15:38 	complete
dhcp-4.1.1-17.P1.fc12 	jpopelka 	2010-06-03 10:42:19 	complete
dhcp-4.1.1-22.P1.fc13 	jpopelka 	2010-06-03 10:34:06 	complete
dhcp-4.1.1-23.P1.fc14 	jpopelka 	2010-06-03 10:22:15 	complete
dhcp-4.1.1_P1-1.fc12 	jpopelka 	2010-06-02 15:11:42 	complete
dhcp-4.1.1_P1-1.fc13 	jpopelka 	2010-06-02 15:11:22 	complete
dhcp-4.1.1_P1-2.fc14 	jpopelka 	2010-06-02 14:58:57 	complete

After my system updated to dhcp-4.1.1_P1-2.fc14, I no longer received update notifications from yum. The version/release string for the old package must be lexically greater than it is for the the newer packages.  Notice that this occurred for F12, F13, and F14.

Version-Release number of selected component (if applicable):
dhcp-4.1.1_P1-2.fc14

How reproducible:
I'm thinking not too hard as long as there aren't dependency issues.  The following steps are my best guess.

Steps to Reproduce:
1. Download dhcp-4.1.1_P1-2.fc14 from koji if it's not installed.
2. Use yum to "update" to it.
3. Run yum update and see that yum thinks the older package is up to date.
  
Actual results:
The old package appears to be newer than the new package to yum.

Expected results:
The new package should appear to be newer to yum.

Additional info:
I'm thinking dhcp will need a version bump to clear this up.

Thanks,
Gene
Comment 1 Jiri Popelka 2010-07-20 05:27:48 EDT
Hi Gene,

Yes, I know about this. I'm sorry for that.

The history behind this is that when I was updating dhcp to 4.1.1-P1,
I decided to use N-V-R(name-version-release): name-version_patchrelease-release.
But the next day I found out that Bind is using N-V-R: name-version-release.patchrelease and I did a new update with this N-V-R.
Unfortunately yum refuses to update from name-version_patchrelease-release to name-version-release.patchrelease.

I was hoping that there will be only few of you who updated to name-version_patchrelease-release, because I un-pushed it the very next day.
But I made a comment in
https://admin.fedoraproject.org/updates/dhcp-4.1.1-22.P1.fc13
for those who updated to name-version_patchrelease-release.

In F-12 and F-13 all the updates with bad N-V-R appeared (for a few days) only in testing repositories, so I'll not change anything in F-12 and F-13.

In a few days I'm going to update to dhcp-4.2.0 in rawhide.
I'll close this bug when it reaches rawhide repo.
Comment 2 Gene Snider 2010-07-20 13:25:00 EDT
Thanks!

Gene
Comment 3 Jiri Popelka 2010-07-26 12:12:28 EDT
Definitely my fault, I should have read this
https://fedoraproject.org/wiki/Packaging:NamingGuidelines#Post-Release_packages

Fortunately dhcp-4.2.0 has been just built and is heading to rawhide.