Bug 6162

Summary: ifup-aliases broken on redhat 6.1
Product: [Retired] Red Hat Linux Reporter: victor.tavares
Component: initscriptsAssignee: Bill Nottingham <notting>
Status: CLOSED DUPLICATE QA Contact:
Severity: medium Docs Contact:
Priority: high    
Version: 6.1CC: rvokal, victor.tavares
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-10-20 22:52:04 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description victor.tavares 1999-10-20 22:50:00 UTC
The following is an error with the ifup-aliases script in
/etc/sysconfig/network-scripts

If I add an ip range in ifcfg-eth0:0 like x.x.x.90-100, the
following happens error shows up in /var/log/messages:

ifup-aliases: /etc/sysconfig/network-scripts/ifup-aliases:
ipseen_x_x_x_90-100=ifcfg-eth0:0: command not found
ifup-aliases: error in ifcfg-eth0:0: already seen ipaddr
x.x.x.90-100 in -100

This worked in RedHat 6.0. I got around the problem by
replacing the ifup-aliases script in 6.1 with the script in
6.0, and it worked...

--vt

Comment 1 Bill Nottingham 1999-10-20 22:52:59 UTC
*** This bug has been marked as a duplicate of 5784 ***