Bug 618071

Summary: Description on how to create USB media for installation is vague, doesn't work
Product: [Fedora] Fedora Documentation Reporter: Horst H. von Brand <vonbrand>
Component: install-guideAssignee: Jack Reed <jreed>
Status: CLOSED NEXTRELEASE QA Contact: Ruediger Landmann <rlandman>
Severity: high Docs Contact:
Priority: low    
Version: develCC: amcnabb, anshumandhuliya, duffy, jreed, mike.cloaked, pbokoc
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-05-03 19:07:11 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Horst H. von Brand 2010-07-25 21:54:49 EDT
Description of problem:
I got a netbook (no CD/DVD drive),and had to grope around looking for instructions on how to make a USB pendrive installation.

Version-Release number of selected component (if applicable):
Fedora 13

How reproducible:

Steps to Reproduce:
1. Look at Fedora Installation Guide
2. Try livecd-creator, the dd(1) "recipe," ...
Actual results:
Confusion, no working install media.

Expected results:
Step by step instructions, working install media

Additional info:
What I finally did was to take a Fedora 13 installation DVD, and gave that to make a "live USB":

  livecd-iso-to-disk --format --reset-mbr /dev/dvd /dev/sdb

It took too much time for my confort, but worked.

I suspect now that "dd if=/dev/dvd of=/dev/sdb" (_Not_ the suggested /dev/sdb1!) would have worked too. Correct bs would be nice to give.
Comment 1 Ruediger Landmann 2010-08-16 01:21:02 EDT
*** Bug 624340 has been marked as a duplicate of this bug. ***
Comment 2 Mike C 2010-10-03 09:45:55 EDT
I have been through the pain of this also and I have the solution!

If you have a usbkey that is already partitioned, mounted then the livecd-iso-to-disk command fails, but how do you unmount it?  What I found was that if you right click on the icon for the mounted usbkey, and select eject, then the stick umounts but does not put it in a mode that is correct for the use of the livecd-iso-to-disk command!

However after a lot of messing about I have found that if you umount the
partition of the stick that you want to write to using a terminal, and then as
root do:
# umount /dev/sdb1
and then
# livecd-iso-to-disk --reset-mbr /path-to/Fedora-14-DVD.iso /dev/sdb1

It will likely work fine and result in a bootable key.

Of course if you want to format the usbkey then you will need the command you mention. The documentation is just not clear enough to be easily understandable even by experienced Fedora users (I have been with Fedora since its inception!)

I have just done this using the analogues of the above command from an f13
machine, and written the f14 beta DVD iso. The key had been formatted using
gparted, with a single fat32 partition set with the boot flag. When plugging
the key in it mounted automagically.  Closing the nautilus window and running
the umount command from the cli as I described above makes the preparation of
the key work fine.

One other very important point that is missing from the documentation is the
issue of where grub gets written as part of the install process.

When it gets to the section of the main install where grub gets written it is
vital to click "Switch device" - then make sure that first bios drive is
selected as (typically) /dev/sda and 2nd bios drive is /dev/sdb (if that is the
usbkey device). Then ensure that the installer will write grub to the mba of
/dev/sda.  If this is not done then grub gets written to the mbr of the usbkey
by default and the resulting installed system will not boot (though it can be
fixed post install using a rescue disk)

Then continue with install - and the new system will boot perfectly!

The dd command method to write the iso to the usbkey failed to give a bootable
key for me in this case, so I don't know if there is a bug in the preparation
of the f14 beta iso or if there is some other problem.

Anyway I certainly think that the documentation for f14 needs to be changed to
reflect the correct and reliable methods for creating bootable install or live
usb media.
Comment 3 Andrew McNabb 2011-01-31 12:22:25 EST
I came across a problem that seems to be the same as Horst's.  If I do "dd if=/dev/dvd of=/dev/sdb", the liveusb boots, but if I repartition and do "dd if=/dev/dvd of=/dev/sdb1", the liveusb hangs (with a blinking cursor in the top-left corner).  With the livecd image installed on sdb1, the drive failed to boot in two completely different machines.  This is on 32-bit machines, so it doesn't seem to be platform-dependent.

It's weird that the liveusb works if installed on an unpartitioned usb drive but doesn't work if it's installed on a partition.

By the way, I think this bug should get switched away from the documentation component.  I think that booting from a partition should work, but some bug is making it hang.
Comment 4 Máirín Duffy 2011-09-26 09:55:51 EDT
liveusb is our primary installation method promoted via this website; this bug's been open a year. could we get a status report? 

is there any way we could have a faster fix, eg if someone drafted replacement text?
Comment 5 Ruediger Landmann 2011-09-26 18:50:43 EDT
(In reply to comment #4)
> liveusb is our primary installation method promoted via this website; this
> bug's been open a year. could we get a status report? 
> is there any way we could have a faster fix, eg if someone drafted replacement
> text?

We'll investigate and prioritise this fix for the F16 version of the guide.

Comment 6 Anshuman Dhuliya 2011-09-27 11:04:17 EDT
thats great! i am a fedora fan and i think this is a serious issue. My friend asked me to make a bootable pendrive but i simply failed even after 4 hours of extensive search. Actually there is nearly no place to search for this solution. I tried many ways and the 'dd' command but it all failed. The methods are only for the Live cds. Very earlier versions provided an image specifically for USB(as i found on net).
Can it be done using grub-install ? if yes then how? I am sill trying and will be happy to find a solution myself but i am beginning to loose my patience.
Comment 7 Karsten Wade 2011-12-13 22:46:43 EST
Removing myself for these bug components as I'm either no longer involved in that aspect of the project, or no longer care to watch this particular bug. Sorry if you are caught in a maelstrom of bug changes as a result!
Comment 8 Jack Reed 2012-05-02 23:55:44 EDT
The dd method has inspired a number of bug reports, and it's now been fixed
for F17. See bug 806166.

The procedure has also been updated and verified. See:
Comment 9 Mike C 2012-05-03 06:01:31 EDT
Can this bug be closed now. Thanks.