Bug 618720

Summary: qemu-kvm hangs for about 1 min at start up
Product: [Fedora] Fedora Reporter: Richard W.M. Jones <rjones>
Component: qemuAssignee: Fedora Virtualization Maintainers <virt-maint>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: rawhideCC: amit.shah, berrange, clalance, crobinso, dwmw2, ehabkost, extras-orphan, itamar, jaswinder, jforbes, knoel, notting, ondrejj, quintela, scottt.tw, tburke, virt-maint
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-07-10 08:14:04 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Richard W.M. Jones 2010-07-27 11:23:30 EDT
Description of problem:

Since upgrading the kernel to the latest from Rawhide, qemu-kvm
suddenly hangs for about a minute when it starts up (before apparently
running any part of the guest OS).

The easiest way to see this is to run

  $ libguestfs-test-tool

and observe a very long hang after the command line is printed, and
before the guest appliance boots (at normal speed).

During this time, qemu-kvm consumes 100%, ie. all 4 CPUs.

Version-Release number of selected component (if applicable):

kernel 2.6.35-0.56.rc6.git1
qemu-kvm-0.12.3-7.fc14.x86_64

How reproducible:

Always.

Steps to Reproduce:
1. time guestfish -a /dev/null run
2.
3.
  
Actual results:

Takes about 1m24.

Expected results:

0m08s.

Additional info:
Comment 1 Bug Zapper 2010-07-30 08:53:48 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Richard W.M. Jones 2010-08-03 07:06:20 EDT
Switching back to Rawhide.  Still present in latest kernel-2.6.35-0.57.rc6.git5.fc15.

The issue is fixes itself if I go back to the 2.6.34 kernel.

I also tried upstream qemu compiled from git => same thing.

I also tried stracing qemu and qemu-kvm, but there's nothing that I
can tell that is interesting going on.  Just in a loop doing select and
occasional reads/writes to file descriptors.
Comment 4 Fedora Admin XMLRPC Client 2012-03-15 13:58:36 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 5 Cole Robinson 2012-07-10 08:14:04 EDT
Pretty sure this has long since been improved, so closing
Comment 6 Cole Robinson 2012-07-10 09:24:06 EDT

*** This bug has been marked as a duplicate of bug 730128 ***