Bug 619137

Summary: enable vala language bindings
Product: [Fedora] Fedora Reporter: Peter Robinson <pbrobinson>
Component: telepathy-glibAssignee: Brian Pepple <bdpepple>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: rawhideCC: bdpepple, johnp, yaneti
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: telepathy-glib-0.11.13-1.fc14 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-08-24 21:17:28 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On: 619003    
Bug Blocks: 620556    
Attachments:
Description Flags
spec patch
bdpepple: review-
New attempt to deal with the vala api versioning changes none

Description Peter Robinson 2010-07-28 12:33:24 EDT
telepathy-glib 0.11.6 added support for vala language bindings. Please can you enable them and either include them in the devel sub package or add a telepathy-glib-vala sub package.
Comment 1 Yanko Kaneti 2010-08-02 15:40:36 EDT
Building the bindings seems to require vala 0.9.4
Comment 2 Yanko Kaneti 2010-08-02 15:44:03 EDT
Ugh depends rather than blocks
Comment 3 Yanko Kaneti 2010-08-02 16:29:04 EDT
Created attachment 436124 [details]
spec patch
Comment 4 Peter Robinson 2010-08-02 19:44:31 EDT
I updated vala to 0.9.4 in rawhide and F-14. It didn't compile against F-15 with vala 0.9.4 with my testing. Also I think the vala bindings would be better in its own sub package.
Comment 5 Yanko Kaneti 2010-08-02 20:25:49 EDT
The way I understand it the bindings are purely a development-time addon, i.e not required at runtime for the actual executables that are produced using vala? As such I think its not much use splitting the development options further. 

I also tested the build with vala 0.9.4 and the attached patch on top of rawhide and it went ok.
Comment 6 Peter Robinson 2010-08-03 02:40:47 EDT
(In reply to comment #5)
> The way I understand it the bindings are purely a development-time addon, i.e
> not required at runtime for the actual executables that are produced using
> vala? As such I think its not much use splitting the development options
> further. 

Bindings are normally in separate sub packages as they pull in separate deps. See python/ruby and other such examples.
Comment 7 Yanko Kaneti 2010-08-03 02:59:41 EDT
(In reply to comment #6)
> (In reply to comment #5)
> > The way I understand it the bindings are purely a development-time addon, i.e
> > not required at runtime for the actual executables that are produced using
> > vala? As such I think its not much use splitting the development options
> > further. 
> 
> Bindings are normally in separate sub packages as they pull in separate deps.
> See python/ruby and other such examples.    

For bindings that are used at runtime of and end-user package sure. For bindings that are to be used only during development its just pointless. telepathy-glib-devel depending on vala is a non-issue imho.
If the vala bindings have some other use other than development then I'll concede they need a separate subpackage.
Comment 8 Brian Pepple 2010-08-09 15:53:16 EDT
(In reply to comment #7)
> For bindings that are used at runtime of and end-user package sure. For
> bindings that are to be used only during development its just pointless.
> telepathy-glib-devel depending on vala is a non-issue imho.
> If the vala bindings have some other use other than development then I'll
> concede they need a separate subpackage.    

I believe your correct on this, though I haven't had a chance to look at this very close since I've been on the road the last week. Hopefully, I'll have some time on Wednesday to get to this.
Comment 9 Brian Pepple 2010-08-11 14:45:43 EDT
Hmm, started building the vala bindings for tp-glib todayu, but they seem to be checking  for vala with pkg-config which is a no-no according to upstream (1). I'm on the road the next few days, but once I get a reliable internet connection I'll see if I can talk to tp-glib upstream about fixing this.

(1) http://mail.gnome.org/archives/desktop-devel-list/2010-August/msg00064.html
Comment 10 Brian Pepple 2010-08-11 14:50:18 EDT
Comment on attachment 436124 [details]
spec patch

Latest tp-glib version is 0.11.12, and the patch is missing a BR on vala-tools
Comment 11 Yanko Kaneti 2010-08-12 03:27:25 EDT
Created attachment 438359 [details]
New attempt to deal with the vala api versioning changes
Comment 12 Yanko Kaneti 2010-08-12 04:15:47 EDT
Comment on attachment 438359 [details]
New attempt to deal with the vala api versioning changes

Ok, I am officially vala-confused. If the generated vala bindings are dependent on the internal vala api (now 0.10) then this needs more work and consideration.
Comment 13 Brian Pepple 2010-08-17 09:13:29 EDT
Ok, I've made the changes to the devel branch in git so that the vala bindings are enabled but haven't built it yet since I would like some other eyes to give it a look over.

For now, I've put the vala bindings in a sub-package, but I'm not really convinced they should be. Glancing at how others are packaging them there is no consistent handling, so I'd like some other folks opinions. Here's my spec changes, and comments are welcomed:

http://pkgs.fedoraproject.org/gitweb/?p=telepathy-glib.git;a=blobdiff;f=telepathy-glib.spec;h=3c0dad03783a4e48f5a071931a04d7a1fb75220b;hp=d9f7118d7e735ff67a8619b937f33c662e4528b1;hb=211240a30738daff5e009e09c1d9cac9ec113d84;hpb=596c6b675144ec7f6db3c5f93570359bb7b749fd
Comment 14 Peter Robinson 2010-08-17 09:20:17 EDT
(In reply to comment #13)
> Ok, I've made the changes to the devel branch in git so that the vala bindings
> are enabled but haven't built it yet since I would like some other eyes to give
> it a look over.
> 
> For now, I've put the vala bindings in a sub-package, but I'm not really
> convinced they should be. Glancing at how others are packaging them there is no
> consistent handling, so I'd like some other folks opinions. Here's my spec
> changes, and comments are welcomed:

That looks fine to me for the moment. Vala is now getting enough traction that there should probably be some packaging guidelines for them. I'll look at what is needed to make that happen.
Comment 15 Yanko Kaneti 2010-08-17 09:37:03 EDT
From what I understand the vala bindings for tp-glib (and probably all other gobject libs) are a stopgap measure until vala itself fully groks the already generated gir introspection data.
Comment 16 Fedora Update System 2010-08-17 10:30:46 EDT
telepathy-glib-0.11.13-1.fc14 has been submitted as an update for Fedora 14.
http://admin.fedoraproject.org/updates/telepathy-glib-0.11.13-1.fc14
Comment 17 Fedora Update System 2010-08-17 15:35:30 EDT
telepathy-glib-0.11.13-1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update telepathy-glib'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/telepathy-glib-0.11.13-1.fc14
Comment 18 Fedora Update System 2010-08-24 21:17:23 EDT
telepathy-glib-0.11.13-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.