Bug 619391

Summary: kickstart.KickstartError: Unrecognized ks command: --append=console=tty0 console=ttyS0,115200
Product: [Fedora] Fedora Reporter: Igor Zhang <yugzhang>
Component: cobblerAssignee: Bill Peck <bpeck>
Status: CLOSED DEFERRED QA Contact:
Severity: high Docs Contact:
Priority: high    
Version: 15CC: awood, jimi, kbaker, scott, vanmeeuwen+fedora
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-08-05 13:56:03 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
Job xml which triggers this problem. none

Description Igor Zhang 2010-07-29 09:17:19 EDT
Description of problem:
When testing /distribution/virt/install/install_rhel4u8_x86_64_hvm on intel-s3ea2-03.rhts.eng.bos.redhat.com and installing rhel4u8_x86_64_hvm guest, I got:
Running anaconda, the Red Hat Enterprise Linux system installer - please wait...
Probing for video card:   VESA driver (generic)
Probing for monitor type:   Unknown monitor
Probing for mouse type:   No - mouse
Graphical installation not available...  Starting text mode.
Traceback (most recent call last):
  File "/usr/bin/anaconda", line 1135, in ?
    instClass.setInstallData(id)
  File "/usr/lib/anaconda/kickstart.py", line 1447, in setInstallData
    raise KickstartError, e
kickstart.KickstartError: Unrecognized ks command: --append=console=tty0 console=ttyS0,115200 
On the line:     --append="console=tty0 console=ttyS0,115200 "

Install error:  [14;15H+--------------------------------------------------+ [15;16H    

Job link:
http://rhts.redhat.com/cgi-bin/rhts/jobs.cgi?id=168670
http://rhts.redhat.com/cgi-bin/rhts/jobs.cgi?id=168669

They are i386 Intel SMP and x86_64 Intel SMP machines. I run this many times and they seem not happen on other machine types.

Version-Release number of selected component (if applicable):
Version - 0.5.51

How reproducible:
Every time.

Steps to Reproduce:
1. Just submit my attached job xmls to beaker or rhts and view the results
2.
3.
  
Actual results:
Guest installs fail.

Expected results:
Guest installs succeed as before.

Additional info:
Comment 1 Igor Zhang 2010-07-29 09:19:01 EDT
Created attachment 435277 [details]
Job xml which triggers this problem.
Comment 2 Bill Peck 2010-07-29 09:27:27 EDT
Missed the #slurp on the previous bootloader line.  This is fixed in git.