This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 619806

Summary: [RHEL6][Kernel] WARNING: at net/sched/sch_generic.c:261 dev_watchdog
Product: Red Hat Enterprise Linux 6 Reporter: Jeff Burke <jburke>
Component: kernelAssignee: John Feeney <jfeeney>
Status: CLOSED DUPLICATE QA Contact: Red Hat Kernel QE team <kernel-qe>
Severity: medium Docs Contact:
Priority: low    
Version: 6.1CC: agospoda, arozansk, jolsa, kthiruma, nhorman, pbunyan, prarit, tgraf
Target Milestone: rcKeywords: RHELNAK
Target Release: ---   
Hardware: All   
OS: Linux   
URL: https://rhts.redhat.com/testlogs/2010/07/168792/432709/3550268/console.txt
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-04-05 09:33:29 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Jeff Burke 2010-07-30 11:14:35 EDT
Description of problem:
 While running the kernel tests for 2.6.32-55.el6 we see a WARNING while running scrashme.

Version-Release number of selected component (if applicable):
2.6.32-55.el6.i686 using RHEL6.0-Snapshot-7-Refresh

How reproducible:
Unknown
  
Actual results:
------------[ cut here ]------------
WARNING: at net/sched/sch_generic.c:261 dev_watchdog+0x1ec/0x200() (Not tainted)
Hardware name: Pence
NETDEV WATCHDOG: eth0 (bnx2): transmit queue 6 timed out
Modules linked in: sunrpc ipv6 dm_mirror dm_region_hash dm_log serio_raw i2c_piix4 sg bnx2 ext4 mbcache jbd2 sr_mod cdrom sd_mod crc_t10dif ata_generic pata_acpi pata_atiixp ahci usb_storage radeon ttm drm_kms_helper drm i2c_algo_bit i2c_core dm_mod [last unloaded: blowfish]
Pid: 0, comm: swapper Not tainted 2.6.32-55.el6.i686 #1
Call Trace:
 [<c044fed1>] ? warn_slowpath_common+0x81/0xc0
 [<c0782eec>] ? dev_watchdog+0x1ec/0x200
 [<c0782eec>] ? dev_watchdog+0x1ec/0x200
 [<c044ffa3>] ? warn_slowpath_fmt+0x33/0x40
 [<c0782eec>] ? dev_watchdog+0x1ec/0x200
 [<c0425383>] ? lapic_next_event+0x13/0x20
 [<c047e1fc>] ? clockevents_program_event+0x8c/0x120
 [<c0460359>] ? run_timer_softirq+0x139/0x2c0
 [<c0782d00>] ? dev_watchdog+0x0/0x200
 [<c047f588>] ? tick_program_event+0x28/0x40
 [<c0456f1f>] ? __do_softirq+0x8f/0x1b0
 [<c045707d>] ? do_softirq+0x3d/0x50
 [<c04571d5>] ? irq_exit+0x65/0x70
 [<c0425aa4>] ? smp_apic_timer_interrupt+0x54/0x90
 [<c040a435>] ? apic_timer_interrupt+0x31/0x38
 [<c042e892>] ? native_safe_halt+0x2/0x10
 [<c0410e59>] ? default_idle+0x39/0x90
 [<c0408884>] ? cpu_idle+0x94/0xd0
 [<c0a4596e>] ? start_kernel+0x38d/0x392
 [<c0a4541f>] ? unknown_bootoption+0x0/0x190
---[ end trace fac3744bd448d802 ]---

Additional info:
This was also seen in log:
 bnx2: eth0 DEBUG: intr_sem[0]
 bnx2: eth0 DEBUG: EMAC_TX_STATUS[ffffffff] RPM_MGMT_PKT_CTRL[ffffffff]
 bnx2: eth0 DEBUG: MCP_STATE_P0[ffffffff] MCP_STATE_P1[ffffffff]
 bnx2: eth0 DEBUG: HC_STATS_INTERRUPT_STATUS[ffffffff]
 bnx2: eth0 DEBUG: PBA[ffffffff]
 bnx2: Chip not in correct endian mode
Comment 3 RHEL Product and Program Management 2010-07-30 11:48:06 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 4 RHEL Product and Program Management 2010-08-18 17:28:07 EDT
Thank you for your bug report. This issue was evaluated for inclusion
in the current release of Red Hat Enterprise Linux. Unfortunately, we
are unable to address this request in the current release. Because we
are in the final stage of Red Hat Enterprise Linux 6 development, only
significant, release-blocking issues involving serious regressions and
data corruption can be considered.

If you believe this issue meets the release blocking criteria as
defined and communicated to you by your Red Hat Support representative,
please ask your representative to file this issue as a blocker for the
current release. Otherwise, ask that it be evaluated for inclusion in
the next minor release of Red Hat Enterprise Linux.
Comment 5 Andy Gospodarek 2011-01-14 11:26:50 EST
This smells like what has been reported in bug 615688.  This now brings us to 4 different drivers that see this issue:

r8169
e100
e1000e
bnx2

This doesn't feel like a driver specific issue anymore.
Comment 6 Andy Gospodarek 2011-04-04 16:40:57 EDT
Jeff, can you test this with the latest 6.1 kernel (>117) with and without pcie_aspm=off on the kernel command line?  There are hopes that patches in 117 and later will resolve this.
Comment 8 Jeff Burke 2011-04-05 08:24:19 EDT
Andy,
 Both recipes passed with and without pcie_aspm=off

Jeff
Comment 9 Andy Gospodarek 2011-04-05 09:33:29 EDT
(In reply to comment #8)
> Andy,
>  Both recipes passed with and without pcie_aspm=off
> 
> Jeff

I was just looking at the logs and noticed the same.  That is great.  I'll go ahead and close this as a dup of bug 681017

*** This bug has been marked as a duplicate of bug 681017 ***