Bug 621364

Summary: Memory test failed on RH6 certification
Product: Red Hat Hardware Certification Program Reporter: chau nguyen <chau.nguyen2>
Component: Test Suite (tests)Assignee: Greg Nichols <gnichols>
Status: CLOSED ERRATA QA Contact: Qian Cai <caiqian>
Severity: medium Docs Contact:
Priority: low    
Version: 5.3CC: caiqian, chau.nguyen2, gregg.shick, gwen.lapo, rlandry, ykun
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
A memory test no longer fails on Red Hat Enterprise Linux 6 certification.
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-09-20 12:14:56 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
Memory test outpu
none
Failed Memory Test
none
df files of failled system
none
Passed Memory Test
none
df files of passed system
none
Failed Memory Test On BL685G6
none
Failed Memory Test On BL685G6 df output
none
memory test patch to check for zero swap none

Description chau nguyen 2010-08-04 20:35:37 UTC
Created attachment 436661 [details]
Memory test outpu

Description of problem:
Memory test failed on RH6 certification

Version-Release number of selected component (if applicable):


How reproducible:
Install RH6 snapshot 8 
Install Test kit v7 version 7-1.2-14
Run Memory test 

Steps to Reproduce:
1. Install RH6 snapshot 8 
2. Install Test kit v7 version 7-1.2-14
3. Run Memory test and 

Actual results:
Fail

Expected results:
Pass

Additional info:
Configuration
System:  ML370 G7
System BIOS: P63 05/14/2010
OS:  Rathat 6 snapshot 8
Test version: v7-1.2.14

The test passed on v7-1.2-12 test kit.

Comment 1 Rob Landry 2010-08-04 21:13:56 UTC
The system appears to have no swap configured, is the issue repeatable if some swap is enabled?

Comment 2 chau nguyen 2010-08-04 21:28:50 UTC
We did default partition configuration during OS installation.  I don’t why OS did not create Swap partition.  Same system and same OS passed with previous build (V7-1.2-12).

Comment 3 chau nguyen 2010-08-09 16:18:42 UTC
Rob,
I have two systems that have same RH6 x64 snapshot 9, same test kit (v7-1.2-14) and use default partition configuration during OS install.  One system passed Memory test and other failed.  The log on passing system showed the test see swap partition.  Other, system did not see swap partition.  Please check the logs and df files for both systems.  Thank you

Comment 4 chau nguyen 2010-08-09 16:19:57 UTC
Created attachment 437637 [details]
Failed Memory Test

Comment 5 chau nguyen 2010-08-09 16:20:36 UTC
Created attachment 437639 [details]
df files of failled system

Comment 6 chau nguyen 2010-08-09 16:21:10 UTC
Created attachment 437640 [details]
Passed Memory Test

Comment 7 chau nguyen 2010-08-09 16:21:46 UTC
Created attachment 437641 [details]
df files of passed system

Comment 8 chau nguyen 2010-08-09 18:46:27 UTC
Created attachment 437676 [details]
Failed Memory Test On BL685G6

Comment 9 chau nguyen 2010-08-09 18:46:57 UTC
Created attachment 437677 [details]
Failed Memory Test On BL685G6 df output

Comment 11 Greg Nichols 2010-08-17 18:44:37 UTC
Created attachment 439187 [details]
memory test patch to check for zero swap

Comment 14 chau nguyen 2010-08-20 20:29:52 UTC
This test still failed with RH6 Snapshot 11 and v7-1.2-17 test kit.

Comment 15 Greg Nichols 2010-08-20 21:16:14 UTC
R17 adds a check for zero swap.    The storage test bug 621070 can leave the system in a state where it has no swap (This is fixed in R18).    Try checking via "swapon -s".    If there's no swap, try "swapon -a", and you may find that you need to run mkswap on the partition before the system will use it.

Comment 19 errata-xmlrpc 2010-09-20 12:14:56 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0702.html

Comment 20 Jaromir Hradilek 2010-09-21 09:45:41 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
A memory test no longer fails on Red Hat Enterprise Linux 6 certification.