Bug 622841

Summary: gnome-control-center segfaults
Product: [Fedora] Fedora Reporter: Tom London <selinux>
Component: gnome-power-managerAssignee: Richard Hughes <richard>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: rawhideCC: bnocera, control-center-maint, richard, rstrode
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-08-10 11:16:22 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Tom London 2010-08-10 10:33:14 EDT
Description of problem:
Get segfault with "System->Preferences->Power Management".

See this in ~/.xsession-errors:

(gnome-control-center:4182): libupower-glib-WARNING **: Couldn't enumerate devices: Message did not receive a reply (timeout by message bus)

** (gnome-control-center:4182): WARNING **: failed to get device list: Message did not receive a reply (timeout by message bus)

(gnome-control-center:4182): libupower-glib-CRITICAL **: up_client_get_devices: assertion `client->priv->done_enumerate' failed

System is Rawhide+koji. Here is gdb backtrace:

Core was generated by `gnome-control-center power'.
Program terminated with signal 11, Segmentation fault.
#0  cc_power_panel_init (panel=0x99d110) at cc-power-panel.c:701
701		for (i=0; i<devices->len; i++) {
(gdb) set pagination off
(gdb) bt full
#0  cc_power_panel_init (panel=0x99d110) at cc-power-panel.c:701
        main_window = <value optimized out>
        widget = <value optimized out>
        retval = <value optimized out>
        error = 0xae7e70
        devices = 0x0
        device = <value optimized out>
        kind = <value optimized out>
        brightness = 0xae68e0
        ret = <value optimized out>
        i = <value optimized out>
#1  0x00007fd089638383 in g_type_create_instance (type=11856912) at gtype.c:1887
        node = <value optimized out>
        instance = 0x99d110
        class = <value optimized out>
        i = <value optimized out>
        total_size = <value optimized out>
#2  0x00007fd0896158dc in g_object_constructor (type=<value optimized out>, n_construct_properties=1, construct_params=0xaddae0) at gobject.c:1482
        object = <value optimized out>
#3  0x00007fd089618309 in g_object_newv (object_type=11856912, n_parameters=<value optimized out>, parameters=<value optimized out>) at gobject.c:1347
        cparams = 0xaddae0
        oparams = 0xadda60
        nqueue = 0x0
        object = <value optimized out>
        class = 0x9aa200
        unref_class = 0x9aa200
        slist = <value optimized out>
        n_total_cparams = <value optimized out>
        n_cparams = 1
        n_oparams = <value optimized out>
        n_cvalues = <value optimized out>
        cvalues = <value optimized out>
        clist = <value optimized out>
        newly_constructed = <value optimized out>
        i = <value optimized out>
        __PRETTY_FUNCTION__ = "g_object_newv"
#4  0x00007fd089619311 in g_object_new_valist (object_type=11856912, first_property_name=<value optimized out>, var_args=0x7fff4db48f80) at gobject.c:1463
        class = 0x9aa200
        params = 0x9aa530
        name = <value optimized out>
        object = <value optimized out>
        n_params = <value optimized out>
        n_alloced_params = <value optimized out>
        __PRETTY_FUNCTION__ = "g_object_new_valist"
#5  0x00007fd089619541 in g_object_new (object_type=11856912, first_property_name=0x407c63 "shell") at gobject.c:1181
        var_args = {{gp_offset = 32, fp_offset = 48, overflow_arg_area = 0x7fff4db49070, reg_save_area = 0x7fff4db48fa0}}
        __PRETTY_FUNCTION__ = "g_object_new"
#6  0x00000000004058ac in activate_panel (shell=0x99a010, start_id=<value optimized out>, err=<value optimized out>) at gnome-control-center.c:125
        panel = <value optimized out>
        box = <value optimized out>
        i = <value optimized out>
        appinfo = <value optimized out>
        err = 0x0
        ctx = <value optimized out>
        key_file = <value optimized out>
        priv = 0x99a050
        panel_type = <value optimized out>
        panels = <value optimized out>
        l = 0xa3dd80
#7  _shell_set_active_panel_from_id (shell=0x99a010, start_id=<value optimized out>, err=<value optimized out>) at gnome-control-center.c:743
        iter = {stamp = -1239007650, user_data = 0xa09160, user_data2 = 0x0, user_data3 = 0x0}
        iter_valid = <value optimized out>
        name = 0xab9db0 "Power Management"
        desktop = 0x9a9cf0 "/usr/share/applications/gnome-power-preferences.desktop"
        icon_name = 0xadd880 "gnome-power-manager"
        priv = <value optimized out>
#8  0x00000000004049f1 in main (argc=2, argv=0x7fff4db49268) at control-center.c:89
        start_id = 0x7fff4db4a73c "power"
        err = 0x0
        shell = 0x99a010
        application = 0xaf40b0
(gdb) 


Version-Release number of selected component (if applicable):
control-center-2.31.5-2.fc14.x86_64
glib2-2.25.13-2.fc15.x86_64
glib2-2.25.13-2.fc15.i686
glibc-2.12.90-6.x86_64
glibc-2.12.90-6.i686
upower-0.9.5-4.fc14.x86_64


How reproducible:
Every time

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Richard Hughes 2010-08-10 11:16:22 EDT

*** This bug has been marked as a duplicate of bug 622830 ***