Bug 623381

Summary: sugar-moon may need to be rebuilt against Python 2.7 in F14 and rawhide
Product: [Fedora] Fedora Reporter: Dave Malcolm <dmalcolm>
Component: sugar-moonAssignee: Bryan Kearney <bkearney>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 14CC: bkearney, mail
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: sugar-moon-11-2.fc14 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-08-24 01:21:30 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 623233    
Bug Blocks: 619913    

Description Dave Malcolm 2010-08-11 18:36:01 UTC
This is an automatically-filed bug.

sugar-moon-11-1.fc14 contains one or more .pyc files, but has not been rebuilt since Python 2.7 was built for Fedora, and thus the .pyc files presumably are for Python 2.6.  Python 2.7 changed the bytecode format, so usage of those files will typically fail (see e.g. bug 621726).

The package needs to be rebuilt against python 2.7 in both F14 and devel.

Information on the new "dist-git" system can be seen here:
  http://fedoraproject.org/wiki/Using_Fedora_GIT

Information on common difficulties with Python 2.7 rebuilds can be seen here:
  https://fedoraproject.org/wiki/Features/Python_2.7

Once it's been successfully rebuilt for F14, an update needs to be filed to get the rebuild into F14:
  https://admin.fedoraproject.org/updates/new/

Please add this bug to the update, to make it easy to track what's been done, and what's left to do.

I'm sorry that this component was not handled by the mass rebuild.  (This may be due to bug 623233)

Comment 1 Fedora Update System 2010-08-11 23:36:14 UTC
sugar-moon-11-2.fc14 has been submitted as an update for Fedora 14.
http://admin.fedoraproject.org/updates/sugar-moon-11-2.fc14

Comment 2 Dave Malcolm 2010-08-12 00:07:18 UTC
Update has been created (sugar-moon-11-2.fc14) so setting status to MODIFIED

Comment 3 Fedora Update System 2010-08-12 19:49:43 UTC
sugar-moon-11-2.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update sugar-moon'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/sugar-moon-11-2.fc14

Comment 4 Fedora Update System 2010-08-24 01:21:25 UTC
sugar-moon-11-2.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.