Bug 623420

Summary: yofrankie-bge may need to be rebuilt against Python 2.7 in F14 and rawhide
Product: [Fedora] Fedora Reporter: Dave Malcolm <dmalcolm>
Component: yofrankie-bgeAssignee: Lubomir Rintel <lkundrak>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 14CC: lkundrak
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: yofrankie-bge-1.1b-2.20090907svn Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-08-24 01:53:33 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 623233    
Bug Blocks: 619913    

Description Dave Malcolm 2010-08-11 18:38:12 UTC
This is an automatically-filed bug.

yofrankie-bge-1.1b-1.20090907svn contains one or more .pyc files, but has not been rebuilt since Python 2.7 was built for Fedora, and thus the .pyc files presumably are for Python 2.6.  Python 2.7 changed the bytecode format, so usage of those files will typically fail (see e.g. bug 621726).

The package needs to be rebuilt against python 2.7 in both F14 and devel.

Information on the new "dist-git" system can be seen here:
  http://fedoraproject.org/wiki/Using_Fedora_GIT

Information on common difficulties with Python 2.7 rebuilds can be seen here:
  https://fedoraproject.org/wiki/Features/Python_2.7

Once it's been successfully rebuilt for F14, an update needs to be filed to get the rebuild into F14:
  https://admin.fedoraproject.org/updates/new/

Please add this bug to the update, to make it easy to track what's been done, and what's left to do.

I'm sorry that this component was not handled by the mass rebuild.  (This may be due to bug 623233)

Comment 1 Fedora Update System 2010-08-12 00:54:38 UTC
yofrankie-bge-1.1b-2.20090907svn has been submitted as an update for Fedora 14.
http://admin.fedoraproject.org/updates/yofrankie-bge-1.1b-2.20090907svn

Comment 2 Fedora Update System 2010-08-12 19:46:25 UTC
yofrankie-bge-1.1b-2.20090907svn has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update yofrankie-bge'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/yofrankie-bge-1.1b-2.20090907svn

Comment 3 Fedora Update System 2010-08-24 01:53:29 UTC
yofrankie-bge-1.1b-2.20090907svn has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.