Bug 624120

Summary: certmonger defunct process ipa-submit
Product: [Fedora] Fedora Reporter: Rob Crittenden <rcritten>
Component: certmongerAssignee: Nalin Dahyabhai <nalin>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 12CC: nalin
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: certmonger-0.30-1.fc13 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 624142 (view as bug list) Environment:
Last Closed: 2010-09-04 05:21:50 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 624142    

Description Rob Crittenden 2010-08-13 18:04:06 UTC
Description of problem:

In the context of IPA I was doing more testing on expiring certs. I would do an installation and then set the current date forward to expire the certificates to ensure that certmonger would automaticaly renew them. I messed with the date too far so *everything* was expired, it wasn't pretty.

I reset the date back to now and wanted to fix the certmonger state which was CA_UNREACHABLE b/c the CA was down due to expired certs (it was 2030 after all).

I did ipa-getcert resubmit -i <id>, twice in a row (fat fingers)

Then I ran ipa-getcert list over and over to monitor it generating the CSR, submitting it and finally back to MONITORING.

I happened to run ps -ef and noticed a defunct process. I can only assume it is related to my fat fingering, I don't know for sure.

The process is:

root 4731 0.3 0.0 0 0 ? Z 13:53 0:00 [ipa-submit] <defunct>

Version-Release number of selected component (if applicable):

certmonger-0.24-0.2010081019git8dd6042.fc12.x86_64

Comment 1 Nalin Dahyabhai 2010-08-13 18:13:22 UTC
Literally minutes after I tagged 0.25.  When canceling a child process, the daemon isn't reaping its status, hence zombies.  Targeting 0.26.

Comment 2 Fedora Update System 2010-08-13 19:28:45 UTC
certmonger-0.26-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/certmonger-0.26-1.fc13

Comment 3 Fedora Update System 2010-08-13 19:28:55 UTC
certmonger-0.26-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/certmonger-0.26-1.fc12

Comment 4 Fedora Update System 2010-08-13 19:29:04 UTC
certmonger-0.26-1.fc14 has been submitted as an update for Fedora 14.
http://admin.fedoraproject.org/updates/certmonger-0.26-1.fc14

Comment 5 Fedora Update System 2010-08-17 05:26:00 UTC
certmonger-0.26-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update certmonger'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/certmonger-0.26-1.fc13

Comment 6 Fedora Update System 2010-09-04 05:21:42 UTC
certmonger-0.30-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2010-09-11 08:56:20 UTC
certmonger-0.30-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2010-09-11 09:08:31 UTC
certmonger-0.30-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.