Bug 625969

Summary: SELinux is preventing /usr/sbin/ssmtp "read" access on /etc/aliases.
Product: [Fedora] Fedora Reporter: Tobias Mueller <fedora-bugs>
Component: selinux-policyAssignee: Daniel Walsh <dwalsh>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 13CC: dwalsh, mgrepl
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard: setroubleshoot_trace_hash:527c0498962b260d19f0a9d98dc37c1359576863f1bdd7a57e2f57a4c97d5472
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-08-24 11:51:34 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Tobias Mueller 2010-08-21 01:32:55 UTC
Summary:

SELinux is preventing /usr/sbin/ssmtp "read" access on /etc/aliases.

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by sendmail. It is not expected that this access
is required by sendmail and this access may signal an intrusion attempt. It is
also possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:logwatch_mail_t:s0-s0:c0.c1023
Target Context                system_u:object_r:etc_aliases_t:s0
Target Objects                /etc/aliases [ file ]
Source                        sendmail
Source Path                   /usr/sbin/ssmtp
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           ssmtp-2.61-15.fc13
Target RPM Packages           setup-2.8.20-1.fc13
Policy RPM                    selinux-policy-3.7.19-47.fc13
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.33.6-147.2.4.fc13.x86_64 #1 SMP
                              Fri Jul 23 17:14:44 UTC 2010 x86_64 x86_64
Alert Count                   10
First Seen                    Sa 14 Aug 2010 03:36:09 CEST
Last Seen                     Sa 21 Aug 2010 03:29:26 CEST
Local ID                      6c571ab7-f6e8-454a-aeac-0a643643e6fa
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1282354166.304:4257): avc:  denied  { read } for  pid=32189 comm="sendmail" name="aliases" dev=dm-1 ino=7065720 scontext=system_u:system_r:logwatch_mail_t:s0-s0:c0.c1023 tcontext=system_u:object_r:etc_aliases_t:s0 tclass=file

node=(removed) type=AVC msg=audit(1282354166.304:4257): avc:  denied  { open } for  pid=32189 comm="sendmail" name="aliases" dev=dm-1 ino=7065720 scontext=system_u:system_r:logwatch_mail_t:s0-s0:c0.c1023 tcontext=system_u:object_r:etc_aliases_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1282354166.304:4257): arch=c000003e syscall=2 success=yes exit=4 a0=406c20 a1=0 a2=1b6 a3=0 items=0 ppid=32106 pid=32189 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=688 comm="sendmail" exe="/usr/sbin/ssmtp" subj=system_u:system_r:logwatch_mail_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  catchall,sendmail,logwatch_mail_t,etc_aliases_t,file,read
audit2allow suggests:

#============= logwatch_mail_t ==============
allow logwatch_mail_t etc_aliases_t:file { read open };

Comment 1 Miroslav Grepl 2010-08-24 11:51:34 UTC

*** This bug has been marked as a duplicate of bug 626167 ***