Bug 626082

Summary: SELinux is preventing /usr/sbin/ulogd "connect" access .
Product: [Fedora] Fedora Reporter: Joseph D. Wagner <joe>
Component: selinux-policyAssignee: Miroslav Grepl <mgrepl>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 13CC: dwalsh, mgrepl
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard: setroubleshoot_trace_hash:def7c2c629075d6a3eab0f797c99b6e1f40a24f2fc180b78929403cc188b6120
Fixed In Version: selinux-policy-3.7.19-51.fc13 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-08-31 06:39:36 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Joseph D. Wagner 2010-08-21 19:56:11 UTC
Summary:

SELinux is preventing /usr/sbin/ulogd "connect" access .

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by ulogd. It is not expected that this access is
required by ulogd and this access may signal an intrusion attempt. It is also
possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:ulogd_t:s0
Target Context                system_u:system_r:ulogd_t:s0
Target Objects                None [ tcp_socket ]
Source                        ulogd
Source Path                   /usr/sbin/ulogd
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           ulogd-1.24-13.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.7.19-49.fc13
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed)
                              2.6.33.6-147.2.4.fc13.x86_64 #1 SMP Fri Jul 23
                              17:14:44 UTC 2010 x86_64 x86_64
Alert Count                   4
First Seen                    Sat 21 Aug 2010 09:21:02 AM PDT
Last Seen                     Sat 21 Aug 2010 12:49:41 PM PDT
Local ID                      9fcd8740-290f-4909-9e71-7d625e42a8fb
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1282420181.742:20): avc:  denied  { connect } for  pid=1407 comm="ulogd" scontext=system_u:system_r:ulogd_t:s0 tcontext=system_u:system_r:ulogd_t:s0 tclass=tcp_socket

node=(removed) type=AVC msg=audit(1282420181.742:20): avc:  denied  { name_connect } for  pid=1407 comm="ulogd" dest=5432 scontext=system_u:system_r:ulogd_t:s0 tcontext=system_u:object_r:postgresql_port_t:s0 tclass=tcp_socket

node=(removed) type=SYSCALL msg=audit(1282420181.742:20): arch=c000003e syscall=42 success=yes exit=128 a0=5 a1=7300e0 a2=1c a3=7fff2b0d1704 items=0 ppid=1406 pid=1407 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="ulogd" exe="/usr/sbin/ulogd" subj=system_u:system_r:ulogd_t:s0 key=(null)



Hash String generated from  catchall,ulogd,ulogd_t,ulogd_t,tcp_socket,connect
audit2allow suggests:

#============= ulogd_t ==============
allow ulogd_t postgresql_port_t:tcp_socket name_connect;
allow ulogd_t self:tcp_socket connect;

Comment 1 Miroslav Grepl 2010-08-22 21:59:48 UTC
Will add

allow ulogd_t self:tcp_socket { create_stream_socket_perms connect };
allow ulogd_t self:udp_socket create_socket_perms;

optional_policy(`
 postgresql_tcp_connect(ulogd_t)
')

Comment 2 Miroslav Grepl 2010-08-22 22:00:47 UTC
*** Bug 626078 has been marked as a duplicate of this bug. ***

Comment 3 Miroslav Grepl 2010-08-22 22:02:05 UTC
*** Bug 626075 has been marked as a duplicate of this bug. ***

Comment 4 Miroslav Grepl 2010-08-24 12:42:58 UTC
Fixed in selinux-policy-3.7.19-50.fc13

Comment 5 Fedora Update System 2010-08-25 15:36:29 UTC
selinux-policy-3.7.19-51.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/selinux-policy-3.7.19-51.fc13

Comment 6 Fedora Update System 2010-08-26 00:59:15 UTC
selinux-policy-3.7.19-51.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update selinux-policy'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/selinux-policy-3.7.19-51.fc13

Comment 7 Joseph D. Wagner 2010-08-29 01:03:42 UTC
Tests ok.

Comment 8 Fedora Update System 2010-08-31 06:38:24 UTC
selinux-policy-3.7.19-51.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.