Bug 626844 (CVE-2010-2575)

Summary: CVE-2010-2575 kdegraphics: a boundary error in Okular
Product: [Other] Security Response Reporter: Vincent Danen <vdanen>
Component: vulnerabilityAssignee: Red Hat Product Security <security-response-team>
Status: CLOSED WONTFIX QA Contact:
Severity: low Docs Contact:
Priority: low    
Version: unspecifiedCC: security-response-team, than
Target Milestone: ---Keywords: Security
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard: impact=low,public=20100825,reported=20100824,source=redhat,cvss2=5.8/AV:N/AC:M/Au:N/C:N/I:P/A:P,rhel-6/kdegraphics=wontfix,fedora-all/kdegraphics=affected,fedora-13/kdegraphics=affected
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-06-10 10:57:12 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On: 627289    
Bug Blocks:    
Attachments:
Description Flags
patch from upstream to correct the issue none

Description Vincent Danen 2010-08-24 14:44:33 UTC
An integer overflow flaw that could lead to a heap-based buffer overflow was found in Okular by Secunia.  If a user were to open a malicious PDF or PostScript file, it could cause Okular to crash or, potentially, lead to the execution of arbitrary code with the privileges of the user running Okular.

This issue has been assigned the name CVE-2010-2575 and only affects KDE4.

Comment 1 Vincent Danen 2010-08-24 14:46:26 UTC
Created attachment 440676 [details]
patch from upstream to correct the issue

This patch applies to 4.3, 4.4, and 4.5.

Comment 2 Vincent Danen 2010-08-25 15:10:26 UTC
This is now public:

http://kde.org/info/security/advisory-20100825-1.txt

Comment 3 Vincent Danen 2010-08-25 15:11:13 UTC
Created kdegraphics tracking bugs for this issue

Affects: fedora-all [bug 627289]