Bug 627687

Summary: RFE: kpackagekit : selected / unselected colors too similar for easy identification?
Product: [Fedora] Fedora Reporter: collura
Component: kpackagekitAssignee: Steven M. Parrish <smparrish>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: 13CC: balajig81, collura, kevin, ltinkl, rdieter, rhughes, smparrish
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-09-29 02:05:50 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description collura 2010-08-26 12:56:16 EDT
Description of problem:

summary: make the un_selected-color (medium-dark-grey) of the download arrow much lighter (faint-washed-out-grey) than it is in order to make it easier to differentiate it from the selected-color (medium-dark-blue)?

the default kde colorscheme seems to have colors for the kpackagekit software update list items which might be too similar in color for those of us who are age-ed to sufficiently easily differentiate between Selected-for-download and Not-Selected-for-download 

maybe consider changing the default color scheme to make the differentiation more clear.

(maybe just make the unselected-grey quite a bit lighter and leave the selected blue as it is so the determination could be made on brightness alone and color is extra bonus?)

Version-Release number of selected component (if applicable):

kpackagekit-0.6.0-2.fc13 (x86_86)

How reproducible:


Steps to Reproduce:
1. launch software management program (kpackagekit)
2. select 'software updates' from list along left side of window
3. select refresh from bottom of window
4. when updates are available they will be displayed one per line in the window
5. each update item will have a downward pointing arrow at the right side of the window and will have what seems to be an unselected color of a medium/dark blue/grey until you click on it to select the item for download at which point it would become a medium/dark blue.
6. click on the update item and the arrow changes color from the medium grey to the medium blue 
7. posit whether the color changed or not when/if you clicked on it.

Actual results:

arrow state is harder to differentiate than should be (especially in harsh lit mobile environments)

have to recheck wether each item is/is_not selected because the default colors are so similar (especially hard outdoors on a laptop)

Expected results:

state of arrow should be more easily determined  (more like the firefox back/forward page arrow where one blue is dark and one grey is light but lighter grey still because hopefully dont use software update as much as firefox lol)

Additional info:

i am not colorblind.  no, i said no.  no.  but for those of us who are this might be worse still and might be even more so worth a change? yes? maybe yes?
Comment 1 collura 2010-08-26 23:11:24 EDT
filed this upstream as:

Comment 2 collura 2010-08-27 11:04:23 EDT
upstream reports that this is fixed in kpackagekit-0.6.1 
(which i think was released only a few days ago)

upstream link paraphrased:
   Resolution:   FIXED
   Severity: 	 wishlist 
   Version Fixed In: 	0.6.1 
   -------  Comment #1 From Daniel Nicoletti  2010-08-27 05:51:15  -------
   This was already fixed in the new version.

i can never find the roadmaps when needed but judging from mirrors 0.6.1 is not planned for adoption any time soon?



can someone link me a roadmap so i know when 0.6.1 might make its way into fedora?
Comment 3 Rex Dieter 2010-08-27 11:13:07 EDT
soon (work on packaging up the new version is underway now).
Comment 4 collura 2010-09-29 02:05:50 EDT
oo indeed.

fixed as of kpackagekit-0.6.1-1.fc13 (x86_64)

i can confirm that the arrows of similar color have been replaced with awesome medium gray checkboxes with black checkmarks.

(also the kind of cumbersome click to expand details function has been replaced with a pretty green expander arrow.)

very nice indeed.

closing this bug.

thank you all.