Bug 628258

Summary: dhclient causes permantly huge traffic and log entries
Product: [Fedora] Fedora Reporter: algenib
Component: dhcpAssignee: Jiri Popelka <jpopelka>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 14CC: jpopelka
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: dhcp-4.2.0-6.fc14 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-10-05 09:19:37 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
wireshark log file
none
dhclient-*-eth0.lease
none
wireshark2 log file
none
dhclient2-*-eth0.lease none

Description algenib 2010-08-28 21:09:23 EDT
Description of problem:

--snip--
/var/log/messages

bound to 192.168.1.33 -- renewal in 2147580480 seconds.
Aug 28 21:43:52 localhost dhclient[1955]: DHCPREQUEST on eth0 to 192.168.1.1 port 67
Aug 28 21:43:52 localhost dhclient[1955]: DHCPACK from 192.168.1.1
Aug 28 21:43:52 localhost dhclient[1955]: bound to 192.168.1.33 -- renewal in 2147580480 seconds.
--snap--

192.168.1.1 = dsl-router
192.168.1.33 = eth0

summary = the amount in /var/log/messages is growing so huge, because of many many entrys *per second*.

Version-Release number of selected component (if applicable):

Fedora 14 Alpha installing via Live-CD (Gnome)

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jiri Popelka 2010-08-30 07:27:39 EDT
I need to know what is the dsl-router sending to the client that makes it crazy.
1) install wireshark-gnome, run wireshark
2) in menu Capture->Options..., select your interface (i.e. eth0), press Start
3) after few seconds stop the capturing
4) save the packet capture (Save as...) and attach it here, thanks
Comment 2 Jiri Popelka 2010-08-30 07:31:20 EDT
Also attach /var/lib/dhclient/dhclient-*-eth0.lease
Or only a few
lease {
 ...
}
from it if it's too big.
Comment 3 algenib 2010-08-30 08:39:35 EDT
Created attachment 441943 [details]
wireshark log file
Comment 4 algenib 2010-08-30 08:41:52 EDT
Created attachment 441944 [details]
dhclient-*-eth0.lease
Comment 5 algenib 2010-08-30 08:43:02 EDT
done
Comment 6 Jiri Popelka 2010-08-30 10:31:12 EDT
thanks

It seems that the dsl-router is really sending some values that the client doesn't like.
The sent lease time is 3 days, that's all right.
But moreover the router sends renewal-time (70 years) and rebindig-time (90 years) even client didn't requested them. These are probably the values that our client doesn't like.
I'm not sure because I'm not able to reproduce it at the moment, because sending of renewal-time and rebindig-time options is not user configurable (they are calculated automatically from lease-time).
So it probably would need some hacking on server side.
Comment 7 algenib 2010-08-30 15:02:14 EDT
Ok. I just wonder why my dsl-router works fine with Fedora 13 and other distributions I had before. On the other hand this router is about seven years old. So a good reason to buy a new one in November ;-) .

But I must be sure that the problem is the router and not the dhclient.

I succeeded in accessing the router menu via local telnet. Perhaps there are useful hints:

---snip----
ras> ip dhcp enif0 st
DHCP on iface enif0 is server
     Start assigned IP address: 192.168.1.33/24
     Number of IP addresses reserved: 32
     Hostname prefix: dhcppc
     DNS server: 127.0.0.1 127.0.0.1
     Domain Name : 
     Default gateway: 192.168.1.1
     Lease time: 259200 seconds
     Renewal time: 129600 seconds
     Rebind time: 226800 seconds
     Probing count: 4
---snap---
Comment 8 Jiri Popelka 2010-08-31 03:47:18 EDT
(In reply to comment #7)
> Ok. I just wonder why my dsl-router works fine with Fedora 13 and other
> distributions I had before.
There's dhcp-4.1.1 in F-13. Other distributions use either dhcp-3.1.3 or dhcp-4.1.1. We have dhcp-4.2.0 in F-14. So maybe there's some bug in 4.2.0.
 
> But I must be sure that the problem is the router and not the dhclient.
I think the router sends some weird values,
but the client should somehow sanitize them and not go mad.

>      Lease time: 259200 seconds
>      Renewal time: 129600 seconds
>      Rebind time: 226800 seconds
This is different from what your router really sends.
See the values in leases file:
option dhcp-lease-time 259200;
option dhcp-renewal-time 2147580480;
option dhcp-rebinding-time 2692928880;
In the packet capture you can see that these huge values of renewal and rebinding time really comes from the router.
Comment 9 Jiri Popelka 2010-09-01 07:26:09 EDT
Hi.
Good news is that I found some parts that could cause the problems you are seeing. I fixed it and it would be great if you can test it.
Bad news is that the same code is in F13's dhcp-4.1.1,
so you should have seen the same behaviour also with F13.
Are both Fedoras the same architecture, i.e. x86_64 ?
Comment 10 Fedora Update System 2010-09-01 07:42:09 EDT
dhcp-4.2.0-5.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/dhcp-4.2.0-5.fc14
Comment 11 algenib 2010-09-01 09:37:22 EDT
(In reply to comment #10)
> dhcp-4.2.0-5.fc14 has been submitted as an update for Fedora 14.
> https://admin.fedoraproject.org/updates/dhcp-4.2.0-5.fc14

Hi,

I've made the update and there is no difference. It is the identical hardware and x86_64 architecture I use for Fedora 13. Only the hard disk is different (which should actually not be the reason).

Same attachments as last time.
Comment 12 algenib 2010-09-01 09:40:02 EDT
Created attachment 442414 [details]
wireshark2 log file
Comment 13 algenib 2010-09-01 09:43:19 EDT
Created attachment 442415 [details]
dhclient2-*-eth0.lease
Comment 14 algenib 2010-09-01 09:54:52 EDT
(In reply to comment #11)
> (In reply to comment #10)
> > dhcp-4.2.0-5.fc14 has been submitted as an update for Fedora 14.
> > https://admin.fedoraproject.org/updates/dhcp-4.2.0-5.fc14
> 
> Hi,
> 
> I've made the update and there is no difference. It is the identical hardware
> and x86_64 architecture I use for Fedora 13.

... where I've really no problems at all.
Comment 15 Fedora Update System 2010-09-01 23:33:28 EDT
dhcp-4.2.0-5.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update dhcp'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/dhcp-4.2.0-5.fc14
Comment 16 algenib 2010-09-02 11:12:52 EDT
(In reply to comment #15)
> dhcp-4.2.0-5.fc14 has been pushed to the Fedora 14 testing repository.  If
> problems still persist, please make note of it in this bug report.
>  If you want to test the update, you can install it with 
>  su -c 'yum --enablerepo=updates-testing update dhcp'. 

Done. No changes. Wireshark-> Ethernet [Malformed Packet] Execption occured (like before).
Comment 17 Jiri Popelka 2010-09-02 12:04:09 EDT
Working on it.
It's really some problem with dhcp-4.2.0, because I can now reproduce (I hacked server to send some huge numbers) it with dhcp-4.2.0 built and running on F13.
Comment 18 Jiri Popelka 2010-09-02 12:59:46 EDT
Another fix is on the way. This time it's gonna fly ;-)
Comment 19 Fedora Update System 2010-09-02 18:08:02 EDT
dhcp-4.2.0-6.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update dhcp'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/dhcp-4.2.0-6.fc14
Comment 20 algenib 2010-09-03 08:10:54 EDT
(In reply to comment #19)
> dhcp-4.2.0-6.fc14 has been pushed to the Fedora 14 testing repository.  If
> problems still persist, please make note of it in this bug report.
>  If you want to test the update, you can install it with 
>  su -c 'yum --enablerepo=updates-testing update dhcp'. 

Great. It works fine now.
Comment 21 Fedora Update System 2010-10-05 09:19:23 EDT
dhcp-4.2.0-6.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.