Bug 631423

Summary: FTBFS qjson-0.7.1-1.fc13
Product: [Fedora] Fedora Reporter: FTBFS <ftbfs>
Component: qjsonAssignee: Eli Wapniarski <eli>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: high    
Version: 14CC: eli, kevin, oget.fedora
Target Milestone: ---Keywords: Triaged
Target Release: ---   
Hardware: All   
OS: Linux   
URL: http://linux.dell.com/files/fedora/FixBuildRequires/mock-results/
Whiteboard:
Fixed In Version: qjson-0.7.1-2.fc13 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-09-23 08:51:45 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On: 631652    
Bug Blocks: 596849    
Attachments:
Description Flags
root.log
none
build.log
none
mock.log
none
root.log
none
build.log
none
mock.log none

Description FTBFS 2010-09-07 14:51:53 EDT
qjson-0.7.1-1.fc13.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2010-09-07 14:51:56 EDT
Created an attachment (id=445510)
root.log

root.log for i386
Comment 2 FTBFS 2010-09-07 14:51:57 EDT
Created an attachment (id=445511)
build.log

build.log for i386
Comment 3 FTBFS 2010-09-07 14:51:59 EDT
Created an attachment (id=445512)
mock.log

mock.log for i386
Comment 4 FTBFS 2010-09-07 14:52:00 EDT
Created an attachment (id=445513)
root.log

root.log for x86_64
Comment 5 FTBFS 2010-09-07 14:52:02 EDT
Created an attachment (id=445514)
build.log

build.log for x86_64
Comment 6 FTBFS 2010-09-07 14:52:03 EDT
Created an attachment (id=445515)
mock.log

mock.log for x86_64
Comment 7 Kevin Kofler 2010-09-08 07:12:21 EDT
Your BuildRequires: qt-devel >= 4.0 is incorrect.

This needs to be:
BuildRequires: qt-devel >= 1:4.0
(note the Epoch), or better:
BuildRequires: qt4-devel >= 4.0
or just:
BuildRequires: qt4-devel
which is what we recommend. (The >= 4.0 is redundant. But are you sure this package will build all the way back to 4.0? I think you might need a higher minimum version.)

(That said, the Provides: qt-devel in qt3-devel is going away as per bug
623106. But your BuildRequires is still wrong because it is missing the Epoch. qt has an Epoch, the virtual qt4 Provides don't, which is another reason to use them.)
Comment 8 Eli Wapniarski 2010-09-08 12:51:55 EDT
I've just looked in:

http://download.fedora.redhat.com/pub/fedora/linux/updates/testing/14/x86_64/

and

http://download.fedora.redhat.com/pub/fedora/linux/updates/13/x86_64

In both locations qt-devel versioning is not prefaced with an epoch
Comment 9 Kevin Kofler 2010-09-08 13:03:14 EDT
The Epoch is NOT reflected in file names! You have to use rpm -q --qf '%{epoch}\n' qt to see that it has Epoch 1. But it IS used for ALL version comparisons. In particular, 1:3.3.8 > 0:4.0, and just 4.0 (without Epoch) is the same as 0:4.0 for RPM.
Comment 10 Fedora Update System 2010-09-12 02:29:51 EDT
qjson-0.7.1-2.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/qjson-0.7.1-2.fc13
Comment 11 Fedora Update System 2010-09-12 02:30:03 EDT
qjson-0.7.1-2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/qjson-0.7.1-2.fc14
Comment 12 Fedora Update System 2010-09-12 02:30:14 EDT
qjson-0.7.1-2.fc12 has been submitted as an update for Fedora 12.
https://admin.fedoraproject.org/updates/qjson-0.7.1-2.fc12
Comment 13 Fedora Update System 2010-09-13 14:12:13 EDT
qjson-0.7.1-2.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update qjson'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/qjson-0.7.1-2.fc14
Comment 14 Fedora Update System 2010-09-23 08:51:35 EDT
qjson-0.7.1-2.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 15 Fedora Update System 2010-09-24 16:35:11 EDT
qjson-0.7.1-2.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 16 Fedora Update System 2010-09-24 16:44:10 EDT
qjson-0.7.1-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.