Bug 631591

Summary: raw img fails on XP install; qcow2 works
Product: [Fedora] Fedora Reporter: sean <seandarcy>
Component: qemuAssignee: Justin M. Forbes <jforbes>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: low    
Version: 14CC: amit.shah, awilliam, berrange, dwmw2, ehabkost, gcosta, itamar, jaswinder, jeff.raber, jforbes, knoel, markmc, ondrejj, ricardo.arguello, scottt.tw, virt-maint, wwoods
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard: RejectedBlocker RejectedNTH
Fixed In Version: qemu-0.13.0-1.fc14 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-10-28 02:12:01 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description sean 2010-09-07 19:52:08 EDT
Description of problem:
'm trying to install XP with virt-manager-0.8.5-1.fc14.noarch. XP
setup gets to the point of copying the files to the .img. Then I get a
quick flash that I think says something like VNC lost connection with
hypervisor.

If I reboot from the disk, I get "Error loading operating system". If
I reboot from the CD, it tells me the .img file is corrupt and needs
to be reformatted. Then I'm back to my original problem.

XP.log shows:

qemu-kvm: block/raw.c:130: raw_aio_writev: Assertion `qiov->iov[i].iov_len >= 51
2' failed.
LC_ALL=C PATH=/sbin:/usr/sbin:/bin:/usr/bin HOME=/ QEMU_AUDIO_DRV=none /usr/bin/
qemu-kvm -S -M pc-0.13 -cpu qemu32 -enable-kvm -m 768 -smp 1,sockets=1,cores=1,t
hreads=1 -name XP -uuid d635f9c4-a226-001c-5ef3-0474c8f2130d -nodefconfig -nodef
aults -chardev socket,id=monitor,path=/var/lib/libvirt/qemu/XP.monitor,server,no
wait -mon chardev=monitor,mode=readline -rtc base=localtime -boot dc -drive file
=/opt/storage/virt/windows/XP.img,if=none,id=drive-ide0-0-0,boot=on,format=raw -
device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -drive file=/opt/storage/virt/windows/Windows-XP-Pro.iso,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -device rtl8139,vlan=0,id=net0,mac=52:54:00:02:c7:1b,bus=pci.0,addr=0x4 -net tap,fd=43,vlan=0,name=hostnet0 -chardev pty,id=serial0 -device isa-serial,chardev=serial0 -usb -device usb-tablet,id=input0 -vnc 127.0.0.1:0 -vga std -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x3 

But if I format XP.img as qcow2 the install proceeds.

Version-Release number of selected component (if applicable):
rpm -qa | grep qemu
qemu-system-x86-0.13.0-0.5.20100809git25fdf4a.fc14.x86_64
qemu-img-0.13.0-0.5.20100809git25fdf4a.fc14.x86_64
qemu-common-0.13.0-0.5.20100809git25fdf4a.fc14.x86_64
qemu-kvm-0.13.0-0.5.20100809git25fdf4a.fc14.x86_64
gpxe-roms-qemu-1.0.1-1.fc14.noarch


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jeff Raber 2010-09-14 15:16:07 EDT
Is this the same as bug 579348?
Comment 2 Will Woods 2010-09-15 17:31:45 EDT
(In reply to comment #1)
> Is this the same as bug 579348?

No. Bug 579348 involves a boot failure *after* the Windows install completes; this bug is caused by triggering an assertion in qemu *during* the installation - specifically, right after the disk is formatted.

This problem was reported to the upstream developers in July:
  http://lists.nongnu.org/archive/html/qemu-devel/2010-07/msg01640.html
Anthony Liguori says "I see the problem.  Working on a patch now." but the patch seems to have been lost somewhere along the way..

I get the same error message:
qemu-kvm: block/raw.c:130: raw_aio_writev: Assertion `qiov->iov[i].iov_len >= 512' failed.

And patching out the offending line in block/raw.c allows the installation to complete successfully.

This prevents Windows installations from completing in libvirt - adding to the F14VirtBlocker list.
Comment 3 Justin M. Forbes 2010-09-28 10:39:30 EDT
Is this still happening with qemu-0.13.0-0.7.rc1.fc14?
Comment 4 Will Woods 2010-09-28 10:55:47 EDT
Yes. Still crashes in the exact same place.
Comment 5 Adam Williamson 2010-10-01 15:11:24 EDT
This was discussed at the 2010-10-01 blocker review meeting. We agreed it does not meet the release criteria or nice-to-have principles, so it is not accepted as a blocker or NTH. Justin does expect that in fact it will be fixed for final release, but it's not blocking.
Comment 6 Fedora Update System 2010-10-19 02:01:33 EDT
qemu-0.13.0-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/qemu-0.13.0-1.fc14
Comment 7 Fedora Update System 2010-10-19 05:09:06 EDT
qemu-0.13.0-1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update qemu'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/qemu-0.13.0-1.fc14
Comment 8 Fedora Update System 2010-10-28 02:11:36 EDT
qemu-0.13.0-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.