Bug 633169

Summary: zh_CN/zh_TW: Use full weekday name in the reply credits line
Product: Red Hat Enterprise Linux 6 Reporter: wang jinghui <jinwang>
Component: evolutionAssignee: Milan Crha <mcrha>
Status: CLOSED ERRATA QA Contact: QE Internationalization Bugs <qe-i18n-bugs>
Severity: medium Docs Contact:
Priority: low    
Version: 6.1CC: lijli, lliu, lovenemesis, mclasen, mcrha, noriko, pwu, smaitra, sshedmak, tlavigne, tpelka, xhuang
Target Milestone: rcKeywords: EasyFix, Translation
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: evolution-2.32.3-35.el6 Doc Type: Bug Fix
Doc Text:
Cause: week day name in reply credits line shown incorrectly for zh_CN and zh_TW translations Consequence: abbreviated week day name is shown instead of a full week day name Fix: show full week day name instead Result: the week day name is shown properly for zh_CN and zh_TW translations
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-05-11 00:42:11 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
The bitmap for comparing eng and zh-CN bitmap
none
Not Fixed on zh_CN and zh_TW
none
Evolution translation updates
none
Screenshot (with evolution-2.32.3-36.el6) showing full weekday name in the reply credits line for zh_CN/zh_TW none

Description wang jinghui 2010-09-13 04:32:33 UTC
Created attachment 446830 [details]
The bitmap for comparing eng and zh-CN bitmap

Description of problem:
Select a message,and hit CTRL-R to reply.Check the email content,translation error of the week 

Version-Release number of selected component (if applicable):
RHEL6.0-RC-3
evolution-2.28.3-10.el6.i686

How reproducible:
100%

Steps to Reproduce:
1.Launch Evolution
2.Select a message,and hit CTRL-R to reply

Comment 2 Matthew Barnes 2010-11-30 03:51:29 UTC
I assume the localization team will provide a patch for this?  Conditional NAK.

Comment 3 Suzanne Yeghiayan 2011-03-28 21:13:43 UTC
Since RHEL 6.1 External Beta has begun, and this bug remains 
unresolved, it has been rejected as it is not proposed as an 
exception or blocker.

Red Hat invites you to ask your support representative to 
propose this request, if appropriate and relevant, in the 
next release of Red Hat Enterprise Linux.

Comment 4 Milan Crha 2013-05-09 17:34:41 UTC
Ankit, would you mind to look on this one too, please?

Comment 6 Ankit Patel 2013-05-14 07:25:36 UTC
(In reply to comment #4)
> Ankit, would you mind to look on this one too, please?

Passing it to Leah, who takes care of zh_CN localization.

Leah, could you please look into this issue and get it fixed.

Thanks,
Ankit

Comment 7 Xi Huang 2013-07-15 00:23:17 UTC
fixed the translation in v6.5

Comment 8 Milan Crha 2013-08-12 11:56:21 UTC
Translation updates applied to evolution-2.32.3-16.el6

Comment 13 Lijun Li 2013-10-29 06:53:03 UTC
Verified it's NOT fixed on build evolution-2.32.3-30.el6 with latest rhel6.5 build.

Please see the attached screenshot.

Moving to ASSIGNED.

Also reproduced on zh_TW.

Comment 14 Lijun Li 2013-10-29 06:57:26 UTC
Created attachment 816978 [details]
Not Fixed on zh_CN and zh_TW

Comment 18 Ankit Patel 2013-11-12 09:53:16 UTC
Created attachment 822802 [details]
Evolution translation updates

I have already sent (on 3rd September) this translation updates to Milan who applied it to evolution-2.32.3-16.el6 as per comment #8 and I have verified the changes as well. Not sure how the update got removed from latest built (that's evolution-2.32.3-30.el6)!

For the record I have attached translation updates here now.

Thanks,
Ankit

Comment 19 Milan Crha 2013-11-13 13:53:41 UTC
Ouch, this is embarrassing, I updated translations on Wed Aug 14 2013 at version 2.32.3-18.el6, which I committed as related to bug #630314 and this bug.

There was also another update of translations at version 2.32.3-20, which covered only bn_IN translation. It was for bug #996109.

Finally, version 2.32.3-24 adds translation update for newly added string from another evolution patch (I committed it as related to general rebase bug #883010.

There were no other translation changes otherwise. I might accidentally drop something what I didn't want to. I'm sorry for that.

Comment 20 Milan Crha 2013-11-13 15:14:06 UTC
(In reply to Ankit Patel from comment #18)
> Created attachment 822802 [details]
> Evolution translation updates

I checked content of the .po files after all patch applications and they are the same as those attached. That makes me think that something else broke.

Comment 21 Milan Crha 2013-11-13 16:25:59 UTC
(In reply to Lijun Li from comment #14)
> Created attachment 816978 [details]
> Not Fixed on zh_CN and zh_TW

From the code, the highlighted text
   "On ${AbbrevWeekdayName}, ${Year}-${Month}-${Day} at ${24Hour}:${Minute} "
   "${TimeZone}, ${Sender} wrote:"

is translated as:
   "在 ${Year}-${Month}-${Day}${AbbrevWeekdayName}的 ${24Hour}:${Minute} "
   "${TimeZone},${Sender}写道:"

which looks like the red-squared word belongs to "${AbbrevWeekdayName}". This is not taken from evolution, but is translated to '%a' and passed to strftime, which returns localized value. It is in zh_CN/zh_TW:
   Mon 一
   Tue 二
   Wed 三
   Thu 四
   Fri 五
   Sat 六
   Sun 日

So from the screenshot I suppose the message which was replied to was composed on Monday. That means that the localizations work as expected, only the string itself in these two languages might not be the right one, as expected by you?

Comment 22 Lijun Li 2013-11-14 02:36:43 UTC
(In reply to Milan Crha from comment #21)
> (In reply to Lijun Li from comment #14)
> > Created attachment 816978 [details]
> > Not Fixed on zh_CN and zh_TW
> 
> From the code, the highlighted text
>    "On ${AbbrevWeekdayName}, ${Year}-${Month}-${Day} at ${24Hour}:${Minute} "
>    "${TimeZone}, ${Sender} wrote:"
> 
> is translated as:
>    "在 ${Year}-${Month}-${Day}${AbbrevWeekdayName}的 ${24Hour}:${Minute} "
>    "${TimeZone},${Sender}写道:"
> 
> which looks like the red-squared word belongs to "${AbbrevWeekdayName}".
> This is not taken from evolution, but is translated to '%a' and passed to
> strftime, which returns localized value. It is in zh_CN/zh_TW:
>    Mon 一
>    Tue 二
>    Wed 三
>    Thu 四
>    Fri 五
>    Sat 六
>    Sun 日
> 
> So from the screenshot I suppose the message which was replied to was
> composed on Monday. That means that the localizations work as expected, only
> the string itself in these two languages might not be the right one, as
> expected by you?
Yes, the righ translation should be like this '星期一, 星期二,... '.

Comment 23 Milan Crha 2013-11-14 07:10:52 UTC
(In reply to Lijun Li from comment #22)
> (In reply to Milan Crha from comment #21)
> > is translated as:
> >    "在 ${Year}-${Month}-${Day}${AbbrevWeekdayName}的 ${24Hour}:${Minute} "
> >    "${TimeZone},${Sender}写道:"
> > ...
>
> Yes, the righ translation should be like this '星期一, 星期二,... '.

Okay. I know this is for translators, though I'm wondering what the right translation should look like in the .po file, simply by changing the above quoted two-line text.

Comment 26 Noriko Mizumoto 2015-11-23 03:48:39 UTC
(In reply to Milan Crha from comment #23)
> (In reply to Lijun Li from comment #22)
> > (In reply to Milan Crha from comment #21)
> > > is translated as:
> > >    "在 ${Year}-${Month}-${Day}${AbbrevWeekdayName}的 ${24Hour}:${Minute} "
> > >    "${TimeZone},${Sender}写道:"
> > > ...
> >
> > Yes, the righ translation should be like this '星期一, 星期二,... '.
> 
> Okay. I know this is for translators, though I'm wondering what the right
> translation should look like in the .po file, simply by changing the above
> quoted two-line text.

Milan
Yes, correct. it should read '星期一,星期二,星期三,星期四,星期五,星期六,星期日'.
Could you mind to apply them on your side?

Comment 27 Milan Crha 2015-11-23 15:32:58 UTC
I'm sorry, I'm still confused. The glibc library returns only values as noted in comment #21. Which is basically only the last "character" from the "three-characters-long strings" from the comment #26. It seems to me that the preceding two "characters" are the same for all 7 days.

The question is (and what I'm confused with):
* is it the glibc, whose translation should be changed to not return one
  "character" long string, but those "three-characters-long" strings instead,
* or it's the evolution, whose translation of
   "在 ${Year}-${Month}-${Day}${AbbrevWeekdayName}的 ..."
  is not correct and it should rather read:
   "在 ${Year}-${Month}-${Day}星期${AbbrevWeekdayName}的 ..."
?

Loking into RHEL7 translation file, the strings look the same as in RHEL6 for zh_CN. The zh_TW translation is slightly different, it reads:
   "於 ${AbbrevWeekdayName},${Year}-${Month}-${Day} 於 ${24Hour}:${Minute}..."

Event the current upstream translation in zh_CN looks the same as in the both RHEL-s.

Comment 28 Jens Petersen 2015-11-24 05:18:21 UTC
Peng Wu, can you please help to answer Milan's question?

Comment 29 Peng Wu 2015-11-24 05:34:25 UTC
It seems reproducible on Fedora 23.

Comment 30 Peng Wu 2015-11-24 05:50:32 UTC
CC Tommy He. any comments?

Comment 31 Milan Crha 2015-11-24 08:00:31 UTC
(In reply to Peng Wu from comment #29)
> It seems reproducible on Fedora 23.

The question wasn't whether it's reproducible in the current Fedora, the question is what is correct. See comment #27, please.

Comment 32 Peng Wu 2015-11-25 07:40:11 UTC
Maybe we can use "${WeekdayName}" instead of "${AbbrevWeekdayName}",
like:

"在 ${Year}-${Month}-${Day}${WeekdayName}的 ${24Hour}:${Minute} "
   "${TimeZone},${Sender}写道:"

Comment 33 Milan Crha 2015-11-25 11:01:42 UTC
Sure. If it's it, then I'll create the patch for this.

You can try yourself too, it's in GSettings, org.gnome.evolution.mail, key composer-message-attribution, which is empty by default, to use the value from the current translation.

Comment 34 Peng Wu 2015-12-02 08:05:31 UTC
I tried on RHEL 6.7, it seems work.

I used msgunfmt/msgfmt tool to update translation manually.

$msgunfmt /usr/share/locale/zh_CN/LC_MESSAGES/evolution-2.32.mo > evolution.po

edit file evolution.po

$msgfmt evolution.po
$sudo cp messages.mo /usr/share/locale/zh_CN/LC_MESSAGES/evolution-2.32.mo

Comment 35 Milan Crha 2015-12-02 12:30:58 UTC
Okay, nice. What was your final change in the translation file then, please?

Comment 36 Peng Wu 2015-12-03 01:24:24 UTC
I used "${WeekdayName}" instead of "${AbbrevWeekdayName}" for Chinese translation.

See comment #32.

Comment 37 Milan Crha 2015-12-03 09:40:31 UTC
Thanks. I changed it upstream [1] for 3.19.3+. It can be easily backported to any RHEL.

[1] https://git.gnome.org/browse/evolution/commit/?id=fd8ee34

Comment 38 Milan Crha 2016-01-11 13:53:25 UTC
I committed the backported upstream fix into the sources for
the evolution-2.32.3-35.el6.

Comment 49 Satyabrata Maitra 2016-02-15 05:40:58 UTC
Hi Tomas

Sure, we will verify it from erratum itself an provide the test result. Thanks for providing the Fixed in Version information really!

Regards
Satya

Comment 50 Tomas Pelka 2016-03-02 18:25:41 UTC
(In reply to Satyabrata Maitra from comment #49)
> Hi Tomas
> 
> Sure, we will verify it from erratum itself an provide the test result.
> Thanks for providing the Fixed in Version information really!
> 
> Regards
> Satya

Satya,

any progress here?

Thanks
-Tom

Comment 51 Satyabrata Maitra 2016-03-09 10:50:37 UTC
Hi Tomas

Sandeep Shedmake is working on this bug, and he will verify this bug in a short while. Sorry, I was on leave for few days.

Regards
Satya

Comment 52 sandeep shedmake 2016-03-09 12:15:24 UTC
Created attachment 1134492 [details]
Screenshot (with evolution-2.32.3-36.el6) showing full weekday name in the reply credits line for zh_CN/zh_TW

Comment 55 errata-xmlrpc 2016-05-11 00:42:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0927.html