Bug 633409

Summary: [6.1 FEAT] FCP SAN utilities (Trace, ping, ...)
Product: Red Hat Enterprise Linux 6 Reporter: IBM Bug Proxy <bugproxy>
Component: s390utilsAssignee: Dan Horák <dhorak>
Status: CLOSED ERRATA QA Contact: qe-baseos-daemons
Severity: high Docs Contact:
Priority: high    
Version: 6.1CC: azelinka, borgan, cward, ebenes, gmuelas, jjarvis, jtakahas, rvokal, sbest
Target Milestone: alphaKeywords: FutureFeature, OtherQA, Rebase
Target Release: 6.1   
Hardware: s390x   
OS: All   
Whiteboard:
Fixed In Version: s390utils-1.8.2-29.el6 Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-05-19 09:17:32 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 538808, 580566    

Description IBM Bug Proxy 2010-09-13 13:51:31 EDT
1. Feature Overview:
Feature Id: [67055]
a. Name of Feature: [6.1 FEAT] FCP SAN utilities (Trace, ping, ...)
b. Feature Description
This feature provides two utilities:
The first utility, zfcp_ping, sends a request to a specified destination and expects an answer to
verify the existence of that destination. 
The second utility, zfcp_show, provides almost all available information about the connected SAN.
This includes all involved interconnect elements (e.g. switches), the number and status of their
ports and a potentially connected node port.

2. Feature Details:
Sponsor: LTC zSeries BOE
Architectures:  zSeries - 64 native, 

Arch Specificity: purely arch specific code
Affects Kernel Modules: Field does not exist
Delivery Mechanism: Backport
Category: system management
Request Type: Package - Feature from IBM
d. Upstream Acceptance: Field does not exist
Sponsor Priority P1
f. Severity: ship issue
IBM Confidential: No
Code Contribution: IBM code
g. Component Version Target:---

3. Business Case
Setting up a storage area network (SAN) can be cumbersome and error-prone. The zfcp_san_utility
package provides two utilities. These can help when the reason of a malfunctioning SAN is not obvious.

This feature will improve the usability and system management capabilities on a SAN infrastructure,
which will result on a better service and customer satisfaction.

4. Primary contact at Red Hat:
John Jarvis jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Hans-Georg Markgraf, mgrf@de.ibm.com

Technical contact(s):
Gonzalo Muelas Serrano, gmuelas@de.ibm.com
Comment 2 John Jarvis 2010-09-21 17:28:25 EDT
What is the component for this and is it upstream?  Please provide more details
about is being requested here.
Comment 3 Gonzalo Muelas Serrano 2010-09-22 10:23:16 EDT
Hello John,
this will be part of HBA API library and be provided as a backport to existing
RHEL 6.0 version.
It is upstream with libzfcphbaapi 2.1
http://www.ibm.com/developerworks/linux/linux390/zfcp-hbaapi-2.1.html

Unfortunately through the mirroring this information got lost. I have updated
the component here directly.

I have created a tracker for zfcp hba api requests (kernel+library):
Bug 633890 - Feature Tracker - HBA API Completition
Comment 4 IBM Bug Proxy 2010-10-04 11:14:44 EDT
------- Comment From rsisk@us.ibm.com 2010-10-04 10:36 EDT-------
Code Upstream Status: Accepted
Comment 5 IBM Bug Proxy 2010-11-18 04:51:27 EST
------- Comment From mgrf@de.ibm.com 2010-11-18 04:41 EDT-------
as discussed in yesterdays call.
- the code for this feature is the only change between libzfcphbaapi-2.0
contained in RHEL6 and the upstream version of libzfcphbaapi-2.1.

Therefore it is not useful to backport the code for this feature

Question:
Can the libzfcphbaapi be enhanced from 2.0 to 2.1 for RHEL6.1 ?
Comment 7 John Jarvis 2010-12-01 10:41:39 EST
IBM is signed up to test and provide feedback, setting OtherQA.
Comment 10 John Jarvis 2010-12-01 10:59:57 EST
This enhancement request was evaluated by the full Red Hat Enterprise Linux 
team for inclusion in a Red Hat Enterprise Linux minor release.   As a 
result of this evaluation, Red Hat has tentatively approved inclusion of 
this feature in the next Red Hat Enterprise Linux Update minor release.   
While it is a goal to include this enhancement in the next minor release 
of Red Hat Enterprise Linux, the enhancement is not yet committed for 
inclusion in the next minor release pending the next phase of actual 
code integration and successful Red Hat and partner testing.
Comment 12 IBM Bug Proxy 2010-12-08 09:51:15 EST
------- Comment From mgrf@de.ibm.com 2010-12-08 09:45 EDT-------
Just got confirmation per mail from John
- Red Hat approved to enhance the version of the library from 2.0 to 2.1

Since the only diff from libzfcphbaapi version 2.0 to 2.1 is the code for the R 6.1  feature request it is useless to backport that code
Comment 13 IBM Bug Proxy 2010-12-08 10:52:10 EST
------- Comment From mgrf@de.ibm.com 2010-12-08 10:41 EDT-------
Please down load libzfcphbaapi 2.1 from
http://www.ibm.com/developerworks/linux/linux390/zfcp-hbaapi.html
Comment 15 Petr Šabata 2011-01-12 09:59:28 EST
libzfcphbaapi is part of s390utils; changing component
Comment 19 Chris Ward 2011-04-06 07:14:26 EDT
~~ Partners and Customers ~~

This bug was included in RHEL 6.1 Beta. Please confirm the status of this request as soon as possible.

If you're having problems accessing 6.1 bits, are delayed in your test execution or find in testing that the request was not addressed adequately, please let us know.

Thanks!
Comment 20 IBM Bug Proxy 2011-04-11 11:41:37 EDT
------- Comment From mgrf@de.ibm.com 2011-04-11 11:31 EDT-------
This is verified on R 6.1 snapshots - set to verified  Thx
Comment 21 errata-xmlrpc 2011-05-19 09:17:32 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0601.html