Bug 633574

Summary: [6.1 FEAT] Update to latest stable binutils version available
Product: Red Hat Enterprise Linux 6 Reporter: IBM Bug Proxy <bugproxy>
Component: binutilsAssignee: Andreas Schwab <schwab>
Status: CLOSED WONTFIX QA Contact: qe-baseos-tools
Severity: high Docs Contact:
Priority: high    
Version: 6.1CC: jan.kratochvil, jjarvis, jtakahas, riek, sbest, snagar
Target Milestone: betaKeywords: FutureFeature, Rebase
Target Release: 6.1   
Hardware: s390x   
OS: All   
Fixed In Version: Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-11-29 13:44:38 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 538808, 580566, 614443    

Description IBM Bug Proxy 2010-09-13 20:22:08 EDT
1. Feature Overview:
Feature Id: [67027]
a. Name of Feature: [6.1 FEAT] Update to latest stable binutils version available
b. Feature Description
This feature requests to update to the latest stable version of binutils if a version >=2.21 is
available at the time of code cut-off for the distribution release. The reason for that is that
there is a couple of feature needing small enhancements provided by 2.21, so that if it is update,
there is no need to have backports.

2. Feature Details:
Sponsor: LTC zSeries BOE
Architectures:   zSeries - 64 native, 

Arch Specificity: both
Affects Kernel Modules: Field does not exist
Delivery Mechanism: LDP Deliverable
Category: other
Request Type: Toolchain - Enhancement from Upstream
d. Upstream Acceptance: In Progress
Sponsor Priority P1
f. Severity: ship issue
IBM Confidential: No
Code Contribution: 3rd party code
g. Component Version Target:---

3. Business Case
This feature will improve the serviceability having the same version as upstream, without needing to
maintain backport patches.

4. Primary contact at Red Hat:
John Jarvis jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Hans-Georg Markgraf, mgrf@de.ibm.com

Technical contact(s):
Gonzalo Muelas Serrano, gmuelas@de.ibm.com
Comment 2 IBM Bug Proxy 2010-10-04 12:10:37 EDT
------- Comment From rsisk@us.ibm.com 2010-10-04 11:32 EDT-------
Code Upstream Status: In Progress
Comment 3 IBM Bug Proxy 2010-10-12 08:30:47 EDT
------- Comment From gmuelas@de.ibm.com 2010-10-12 08:29 EDT-------
Hello Red Hat,
we are starting now to work on the backports to provide you the code for 14th Dec. 2010.
Could you please let us know if you are planing to update binutils?
If binutils 2.21 is released before 14 Dec. 2010, do you plan to use it for RHEL 6.1?

Please let us know so that we do not work on a backport that later on might not be needed anymore if you update/rebase binutils.

Thank you for your support!
Gonzalo Muelas Serrano.
Comment 7 John Jarvis 2010-11-22 13:09:50 EST
There are no plans to rebase binutils in RHEL 6.1, please proceed with backports for RHBZs 631540, 633377 and 633448.
Comment 9 RHEL Product and Program Management 2010-11-29 13:44:38 EST
Product Management has reviewed and declined this request.  You may appeal this
decision by reopening this request.
Comment 10 IBM Bug Proxy 2010-12-13 12:31:24 EST
------- Comment From mgrf@de.ibm.com 2010-12-13 12:27 EDT-------
Accept the reject for R 6.1 - backports have been provided instead