Bug 635900

Summary: spice client: failed to parse message channel 5 type 101
Product: [Fedora] Fedora Reporter: Tom Horsley <horsley1953>
Component: spiceAssignee: Gerd Hoffmann <kraxel>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 14CC: alexl, cfergeau, jforbes, kraxel
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-04-15 10:44:09 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Tom Horsley 2010-09-20 20:01:22 EDT
Description of problem:

I finally got audio working to some extent in my continuing experiments
with spice and Windows XP KVM, but a few seconds into trying to replay
a randomly selected college football game on espn3.com, I see this
and my spice window disappears:

[tom@zooty ~]$ /usr/bin/spicec -h localhost -p 5930
Warning: failed to parse message channel 5 type 101

I tried to reconnect after filling in this much of this bug report
and got this:

[tom@zooty ~]$ /usr/bin/spicec -h localhost -p 5930
Warning: failed to connect: Connection refused (111)

doing a virsh list showed that the KVM virtual machine apparently
crashed as well.

Version-Release number of selected component (if applicable):

How reproducible:
Seems random. I tried playing the same game again and it didn't
have the problem, in fact I've only seen it happen just the one time
so far.

Steps to Reproduce:
1. boot Windows XP virtual machine with libvirt using wrapper for
   fixing spice options and audio environment variable.
2. play with various things that generate sound
3. see the crash when trying to play wake forest versus stanford
   from espn3.com
Actual results:

Crashed spice and KVM

Expected results:

Normal playback of video and audio

Additional info:

The two lines at the end of the log entry are new and may be related
to the problem:

LC_ALL=C PATH=/sbin:/usr/sbin:/bin:/usr/bin QEMU_AUDIO_DRV=none /usr/bin/qemu-sp
ice-wrapper -S -M pc-0.13 -enable-kvm -m 1024 -smp 2,sockets=2,cores=1,threads=1
 -name newxp -uuid 56bf8244-94fc-c33b-5530-1c88082e992f -nodefconfig -nodefaults
 -chardev socket,id=monitor,path=/var/lib/libvirt/qemu/newxp.monitor,server,nowa
it -mon chardev=monitor,mode=readline -rtc base=localtime -boot c -drive if=none
,media=cdrom,id=drive-ide0-1-0,readonly=on -device ide-drive,bus=ide.1,unit=0,dr
ive=drive-ide0-1-0,id=ide0-1-0 -drive file=/zooty/images/new-winxp.img,if=none,i
d=drive-ide0-0-0,boot=on -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0
,id=ide0-0-0 -device rtl8139,vlan=0,id=net0,mac=52:54:00:89:73:85,bus=pci.0,addr
=0x5 -net tap,fd=46,vlan=0,name=hostnet0 -usb -device usb-tablet,id=input0 -vnc -vga std -device AC97,id=sound0,bus=pci.0,addr=0x4 -device virtio-ba
do_spice_init: starting 0.6.0
spice_server_add_interface: SPICE_INTERFACE_KEYBOARD
spice_server_add_interface: SPICE_INTERFACE_MOUSE
mouse_mode_notifier: absolute pointer: not available
spice_server_add_interface: SPICE_INTERFACE_QXL
red_worker_main: begin
mouse_mode_notifier: absolute pointer: present
spice_server_add_interface: SPICE_INTERFACE_RECORD
spice_server_add_interface: SPICE_INTERFACE_PLAYBACK
handle_dev_input: start
reds_show_new_channel: channel 1:0, connected successfully, over Non Secure link
reds_main_handle_message: net test: invalid values, latency 0 roundtrip 1072. as
suming highbandwidth
reds_show_new_channel: channel 2:0, connected successfully, over Non Secure link
handle_dev_input: connect
handle_new_display_channel: jpeg disabled
handle_new_display_channel: zlib-over-glz disabled
reds_show_new_channel: channel 4:0, connected successfully, over Non Secure link
reds_show_new_channel: channel 6:0, connected successfully, over Non Secure link
reds_show_new_channel: channel 5:0, connected successfully, over Non Secure link
handle_dev_input: cursor connect
reds_show_new_channel: channel 3:0, connected successfully, over Non Secure link
mouse_mode_notifier: absolute pointer: present+active
mouse_mode_notifier: using absolute pointer (client mode)
spice_server_add_interface: SPICE_INTERFACE_TABLET
tablet_set_logical_size: 640x480
handle_dev_input: mouse mode 2
tablet_set_logical_size: 640x480
tablet_set_logical_size: 0x0
tablet_set_logical_size: 1280x1024
Suspension not allowed here
spice_server_remove_interface: remove SPICE_INTERFACE_PLAYBACK
Comment 1 Tom Horsley 2011-04-14 05:26:56 EDT
After using spice for a long while now, this has only happened once, so it is obviously not easy to reproduce and maybe even fixed since I have gotten a few updates since reporting the problem.
Comment 2 Christophe Fergeau 2011-04-15 10:44:09 EDT
I'll mark it as fixed then, someone will report it again if this is just hard to reproduce and not fixed yet. If you're not ok with that approach, feel free to reopen the bug :)