Bug 636715

Summary: Dashboard: Tabbing through elements in Edit/View modes has no discernible order
Product: [Other] RHQ Project Reporter: Corey Welton <cwelton>
Component: Core UIAssignee: RHQ Project Maintainer <rhq-maint>
Status: CLOSED WONTFIX QA Contact: Mike Foley <mfoley>
Severity: low Docs Contact:
Priority: low    
Version: 4.0.0CC: jshaughn, mazz
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-05-02 14:02:01 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 637173, 678340    

Description Corey Welton 2010-09-22 22:01:28 EDT
Description of problem:
If user attempts to tab through elements in either of the view modes for 

Version-Release number of selected component (if applicable):


How reproducible:
Every time

Steps to Reproduce:
1.  Create a new dash and add a bunch of standard portlets across multiple columns.
2.  Place mouse focus somewhere atop the page -- like in the search field, for instance.
3.  Hit tab a good 15-30 times; view results
  
Actual results:
Focus shoots all over the UI in no real understandable order.  Sometimes focus will be in some of the elements, go back up to browser URL bar and then back down into other elements.  In any case, we seem to be navigating through any particular portlet ok (i think) but once we switch away, all bets are off.

Expected results:

Sane tab navigation

Additional info:
If we ever plan(ned) to do any a11y work for JON, this would be pretty significant.
Comment 1 Jay Shaughnessy 2011-03-31 09:55:19 EDT
removing this as a blocker for rhq4. no work planned on this issue.