Bug 637183

Summary: 'systemctl show' and 'systemctl enable' ambiguous results
Product: [Fedora] Fedora Reporter: Valdis Kletnieks <valdis.kletnieks>
Component: systemdAssignee: Lennart Poettering <lpoetter>
Status: CLOSED UPSTREAM QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: rawhideCC: lpoetter, metherid, mschmidt, notting, plautrba
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-11-21 21:42:16 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
output of systemctl commands during testing none

Description Valdis Kletnieks 2010-09-24 14:40:51 UTC
Created attachment 449432 [details]
output of systemctl commands during testing

Description of problem:
I do a 'systemctl enable smartd.service', and it says it can't find it.

'systemctl -a | grep smart' finds it.

I do 'systemctl show smartd.service', and it produces output (which make me wonder why it couldn't find it for 'enable') - but sets $? == 3 which indicates failure (but presumably a different failure than the $? == 1 that the 'enable' threw).

Version-Release number of selected component (if applicable):
systemd-10-4.fc15.x86_64

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Valdis Kletnieks 2010-09-24 15:10:33 UTC
Forgot to include - 'systemctl start smartd.service' will in fact launch smartd

Comment 2 Lennart Poettering 2010-10-08 00:40:18 UTC
"systemctl enable" can only be used for native services for now.

Comment 3 Lennart Poettering 2010-11-21 21:42:16 UTC
systemctl will now redirect "systemctl enable" calls for SysV services to chkconfig. Also, systemctl show will not return any surprising return values anymore (the reason it did was that systemctl show was handled by the same logic as systemctl status which closely followed the LSB semantics for status, which mandate that 3 is returned when a service is not running).

This is in systemd git and soon in rawhide.