Bug 638172
| Summary: | user runs as abrt_helper_t, SELinux is preventing /bin/bash "execute" access on /bin/bash. | ||||||
|---|---|---|---|---|---|---|---|
| Product: | [Fedora] Fedora | Reporter: | Mads Kiilerich <mads> | ||||
| Component: | selinux-policy | Assignee: | Daniel Walsh <dwalsh> | ||||
| Status: | CLOSED DUPLICATE | QA Contact: | Fedora Extras Quality Assurance <extras-qa> | ||||
| Severity: | medium | Docs Contact: | |||||
| Priority: | medium | ||||||
| Version: | 14 | CC: | dwalsh, mads, mgrepl | ||||
| Target Milestone: | --- | Keywords: | Reopened | ||||
| Target Release: | --- | ||||||
| Hardware: | i386 | ||||||
| OS: | Linux | ||||||
| Whiteboard: | setroubleshoot_trace_hash:b0f59ed5f795f2ce7c54da498f9608e70bc2e07fda529843282e97a0a071a04a | ||||||
| Fixed In Version: | Doc Type: | Bug Fix | |||||
| Doc Text: | Story Points: | --- | |||||
| Clone Of: | Environment: | ||||||
| Last Closed: | 2010-09-28 15:50:54 UTC | Type: | --- | ||||
| Regression: | --- | Mount Type: | --- | ||||
| Documentation: | --- | CRM: | |||||
| Verified Versions: | Category: | --- | |||||
| oVirt Team: | --- | RHEL 7.3 requirements from Atomic Host: | |||||
| Cloudforms Team: | --- | Target Upstream Version: | |||||
| Embargoed: | |||||||
| Attachments: |
|
||||||
|
Description
Mads Kiilerich
2010-09-28 12:45:51 UTC
Created attachment 450180 [details]
ps -fZed output, showing lots of abrt_helper_t
After upgrading to f14 I get this and 60 other errors (quickly increasing to 100+) occurs when logging in in Gnome for the first time on a newly created user.
This looks like a candidate for a basic problem, but now I see that xrdb is involved.
And hey, everything runs as abrt_helper_t ?
I recently uninstalled everything abrt and just installed it again.
I would say you have a labeling problem. touch /.autorelabel; reboot Should fix it. Reopen if this does not fix the problem. I agree that it looks like a labelling problem, but I had already done both a autorelabel-on-boot and fixfiles relabel. In both cases I got the git-shell messages from bug 638150. I assume that it is more likely some bad content in the SE database, but I don't know where to look. AFAIK I haven't touched the SE database manually on this machine, so I assume would expect that whatever is in there should be handled correctly when updating. ps -eZ | grep init ps -eZ | grep sshd system_u:system_r:kernel_t:s0 1 ? 00:00:02 init system_u:system_r:kernel_t:s0 1708 ? 00:00:00 sshd (I assume that the ps -fZed output showed the same.) Did you see any error message about failure to load policy? ls -lZ /sbin/upstart -rwxr-xr-x. root root system_u:object_r:init_exec_t:s0 /sbin/upstart Does yum reinstall selinux-policy-targeted complete successfully? caused by incorrectly installed selinux-policy-targeted *** This bug has been marked as a duplicate of bug 638150 *** |