Bug 638963

Summary: Dependency check fail
Product: Red Hat Enterprise Linux 5 Reporter: Tom Kelliher <kelliher>
Component: yumAssignee: packaging-team-maint
Status: CLOSED INSUFFICIENT_DATA QA Contact: BaseOS QE Security Team <qe-baseos-security>
Severity: medium Docs Contact:
Priority: low    
Version: 5.7CC: james.antill
Target Milestone: rc   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-03-12 16:51:55 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Tom Kelliher 2010-09-30 09:56:00 EDT
'yum update' requested that I report the following error:

bluebird:~                                                                      % sudo yum clean all
Loaded plugins: rhnplugin
Cleaning up Everything
                                                                                bluebird:~                                                                      % sudo yum update
Loaded plugins: rhnplugin
rhel-i386-client-5                                       | 1.4 kB     00:00     
rhel-i386-client-5/primary                               | 2.7 MB     00:00     
rhel-i386-client-5                                                    6433/6433
rhel-i386-client-fastrack-5                              | 1.3 kB     00:00     
rhel-i386-client-fastrack-5/primary                      |  55 kB     00:00     
rhel-i386-client-fastrack-5                                             166/166
rhel-i386-client-supplementary-5                         | 1.4 kB     00:00     
rhel-i386-client-supplementary-5/primary                 | 162 kB     00:00     
rhel-i386-client-supplementary-5                                        553/553
rhel-i386-client-vt-5                                    | 1.4 kB     00:00     
rhel-i386-client-vt-5/primary                            |  40 kB     00:00     
rhel-i386-client-vt-5                                                   197/197
rhel-i386-client-workstation-5                           | 1.4 kB     00:00     
rhel-i386-client-workstation-5/primary                   | 700 kB     00:00     
rhel-i386-client-workstation-5                                        2742/2742
rhel-i386-client-workstation-fastrack-5                  | 1.3 kB     00:00     
rhel-i386-client-workstation-fastrack-5/primary          |  17 kB     00:00     
rhel-i386-client-workstation-fastrack-5                                   54/54
rhn-tools-rhel-i386-client-5                             | 1.1 kB     00:00     
rhn-tools-rhel-i386-client-5/primary                     |  33 kB     00:00     
rhn-tools-rhel-i386-client-5                                            428/428
Excluding Packages in global exclude list
Finished
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package device-mapper-multipath.i386 0:0.4.7-34.el5_5.6 set to be updated
---> Package java-1.5.0-ibm.i386 1:1.5.0.12.1-1jpp.1.el5 set to be updated
---> Package java-1.5.0-ibm-devel.i386 1:1.5.0.12.1-1jpp.1.el5 set to be updated
---> Package java-1.5.0-ibm-javacomm.i386 1:1.5.0.12.1-1jpp.1.el5 set to be updated
---> Package java-1.5.0-ibm-plugin.i386 1:1.5.0.12.1-1jpp.1.el5 set to be updated
---> Package kernel.i686 0:2.6.18-194.17.1.el5 set to be installed
---> Package kernel-PAE.i686 0:2.6.18-194.17.1.el5 set to be installed
---> Package kernel-headers.i386 0:2.6.18-194.17.1.el5 set to be updated
---> Package kpartx.i386 0:0.4.7-34.el5_5.6 set to be updated
---> Package python.i386 0:2.4.3-27.el5_5.2 set to be updated
---> Package python-devel.i386 0:2.4.3-27.el5_5.2 set to be updated
---> Package python-tools.i386 0:2.4.3-27.el5_5.2 set to be updated
---> Package tkinter.i386 0:2.4.3-27.el5_5.2 set to be updated
---> Package xorg-x11-server-Xdmx.i386 0:1.1.1-48.76.el5_5.2 set to be updated
---> Package xorg-x11-server-Xnest.i386 0:1.1.1-48.76.el5_5.2 set to be updated
---> Package xorg-x11-server-Xorg.i386 0:1.1.1-48.76.el5_5.2 set to be updated
rhel-i386-client-5/filelists                             |  15 MB     00:05     
rhel-i386-client-fastrack-5/filelists                    | 262 kB     00:00     
rhel-i386-client-supplementary-5/filelists               | 1.1 MB     00:01     
rhel-i386-client-vt-5/filelists                          | 170 kB     00:00     
rhel-i386-client-workstation-5/filelists                 | 4.5 MB     00:01     
rhel-i386-client-workstation-fastrack-5/filelists        |  42 kB     00:00     
rhn-tools-rhel-i386-client-5/filelists                   |  22 kB     00:00     
--> Finished Dependency Resolution
--> Running transaction check
---> Package kernel.i686 0:2.6.18-194.11.1.el5 set to be erased
---> Package kernel-PAE.i686 0:2.6.18-194.11.1.el5 set to be erased
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package                 Arch Version                  Repository          Size
================================================================================
Installing:
 kernel                  i686 2.6.18-194.17.1.el5      rhel-i386-client-5  17 M
 kernel-PAE              i686 2.6.18-194.17.1.el5      rhel-i386-client-5  17 M
Updating:
 device-mapper-multipath i386 0.4.7-34.el5_5.6         rhel-i386-client-5 2.8 M
 java-1.5.0-ibm          i386 1:1.5.0.12.1-1jpp.1.el5  rhel-i386-client-supplementary-5
                                                                           48 M
 java-1.5.0-ibm-devel    i386 1:1.5.0.12.1-1jpp.1.el5  rhel-i386-client-supplementary-5
                                                                          3.9 M
 java-1.5.0-ibm-javacomm i386 1:1.5.0.12.1-1jpp.1.el5  rhel-i386-client-supplementary-5
                                                                           45 k
 java-1.5.0-ibm-plugin   i386 1:1.5.0.12.1-1jpp.1.el5  rhel-i386-client-supplementary-5
                                                                          952 k
 kernel-headers          i386 2.6.18-194.17.1.el5      rhel-i386-client-5 1.0 M
 kpartx                  i386 0.4.7-34.el5_5.6         rhel-i386-client-5 420 k
 python                  i386 2.4.3-27.el5_5.2         rhel-i386-client-5 5.9 M
 python-devel            i386 2.4.3-27.el5_5.2         rhel-i386-client-workstation-5
                                                                          2.9 M
 python-tools            i386 2.4.3-27.el5_5.2         rhel-i386-client-5 942 k
 tkinter                 i386 2.4.3-27.el5_5.2         rhel-i386-client-5 275 k
 xorg-x11-server-Xdmx    i386 1.1.1-48.76.el5_5.2      rhel-i386-client-5 912 k
 xorg-x11-server-Xnest   i386 1.1.1-48.76.el5_5.2      rhel-i386-client-5 1.4 M
 xorg-x11-server-Xorg    i386 1.1.1-48.76.el5_5.2      rhel-i386-client-5 3.3 M
Removing:
 kernel                  i686 2.6.18-194.11.1.el5      installed           44 M
 kernel-PAE              i686 2.6.18-194.11.1.el5      installed           44 M

Transaction Summary
================================================================================
Install       2 Package(s)
Upgrade      14 Package(s)
Remove        2 Package(s)
Reinstall     0 Package(s)
Downgrade     0 Package(s)

Total download size: 107 M
Is this ok [y/N]: y
Downloading Packages:
(1/16): java-1.5.0-ibm-javacomm-1.5.0.12.1-1jpp.1.el5.i3 |  45 kB     00:00     
(2/16): tkinter-2.4.3-27.el5_5.2.i386.rpm                | 275 kB     00:00     
(3/16): kpartx-0.4.7-34.el5_5.6.i386.rpm                 | 420 kB     00:00     
(4/16): xorg-x11-server-Xdmx-1.1.1-48.76.el5_5.2.i386.rp | 912 kB     00:00     
(5/16): python-tools-2.4.3-27.el5_5.2.i386.rpm           | 942 kB     00:00     
(6/16): java-1.5.0-ibm-plugin-1.5.0.12.1-1jpp.1.el5.i386 | 952 kB     00:03     
(7/16): kernel-headers-2.6.18-194.17.1.el5.i386.rpm      | 1.0 MB     00:00     
(8/16): xorg-x11-server-Xnest-1.1.1-48.76.el5_5.2.i386.r | 1.4 MB     00:00     
(9/16): device-mapper-multipath-0.4.7-34.el5_5.6.i386.rp | 2.8 MB     00:01     
(10/16): python-devel-2.4.3-27.el5_5.2.i386.rpm          | 2.9 MB     00:00     
(11/16): xorg-x11-server-Xorg-1.1.1-48.76.el5_5.2.i386.r | 3.3 MB     00:01     
(12/16): java-1.5.0-ibm-devel-1.5.0.12.1-1jpp.1.el5.i386 | 3.9 MB     00:06     
(13/16): python-2.4.3-27.el5_5.2.i386.rpm                | 5.9 MB     00:03     
(14/16): kernel-2.6.18-194.17.1.el5.i686.rpm             |  17 MB     00:06     
(15/16): kernel-PAE-2.6.18-194.17.1.el5.i686.rpm         |  17 MB     00:06     
(16/16): java-1.5.0-ibm-1.5.0.12.1-1jpp.1.el5.i386.rpm   |  48 MB     00:18     
--------------------------------------------------------------------------------
Total                                           1.8 MB/s | 107 MB     00:58     
Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
java-devel is needed by (installed) mockobjects-jdk1.4-0.09-14jpp.3.i386
java-devel is needed by (installed) mockobjects-jdk1.4-0.09-14jpp.3.i386
java-devel is needed by (installed) mockobjects-alt-jdk1.4-0.09-14jpp.3.i386
java-devel is needed by (installed) mockobjects-alt-jdk1.4-0.09-14jpp.3.i386
Complete!
(1, [u'Please report this error in https://bugzilla.redhat.com/enter_bug.cgi?product=Red%20Hat%20Enterprise%20Linux%205&component=yum'])
52.677u 3.481s 3:04.44 30.4%    0+0k 0+0io 0pf+0w
Comment 1 James Antill 2010-09-30 10:40:15 EDT
This probably means that you don't have a package providing "java-devel" installed already, and someone force installed mockobjects ... yum assumes that everything is fine already, rpm doesn't and so complains.

Doing a simple: yum install java-devel ... will probably fix the problem.

To confirm that it is a pre-existing condition you can run:

rpm -Va --nofiles --nodigest

...which asks rpm to check for any existing problems.